Jump to content

Recon on Nano (1.1.3) stuck att 100% when using webpage


micke
 Share

Recommended Posts

Hi,

I got my first Nano and hooked it up.

First thing I did was update it to 1.1.3 and tried to do a 15 second scan (Recon).

Thee status bar worked its way up to 100% and then got stuck there

So, I pressed stop and tried again, this time some nets showed up.

Well so I tried again and it got stuck at 100% again.

I’ve tried this about 40 times and it has worked twice.

 

So, I asked my friend Google and found a thread about the same issue on the 1.1.2 version that looked the same. But after reading thru the thread I don’t think so anymore.

 

Just to be sure that I hadn’t done something, I did a factory reset but that didn’t help.

If I look in the /tmp I can see that a recon-xxxxxx file is created each time I run a scan.

If I look in the file I can see that it contains data that looks (to my noob eyes) correct.

If I use pinesniffer it works as it should.

 

Does anyone have an idea on what this can be?

I should also note that I am new to the Nano so it might just be that I missed something.

Link to comment
Share on other sites

It would be great to get our hands on the recon-* file. To make sure it is actually the problem though, I'd like you to do a couple more things:

  1. Remove all recon-* files (or reboot the WiFi Pineapple)
  2. Run recon
  3. If recon gets stuck at 100%, check your browsers JS console for any errors. If there are please attach them here (imgur is the best way)
  4. If recon gets stuck at 100%, download / copy your recon-* file, and throw it into a pastebin and give us the link

With that information, we should be able to find the issue asap.

Link to comment
Share on other sites

Hi,

Seriously, thanks for the fast replies!

I’m running Chrome (standard Google version).

I cleared out the old recon files and rebooted my Nano but the problem still persists.

I’ve uploaded the newest version of the recon-xxxxx file to:

http://pastebin.com/HHB58PD5

Also, you were right, if I look in the console I see some errors in a js-filse.

I’ve uploaded a screenshot to:

http://imgur.com/a/ylcBM

Thanks! J

Link to comment
Share on other sites

Micke,

I uploaded the JSON you gave us to my WiFi Pineapple, and forced Recon mode to load it. It did so without issues. As pinesniffer generates the correct file, and the webinterface displays the file correctly, I simply do not know what is wrong on your end.

Do you have any plugins running in the browser? If so, can you try with all of them disabled? Can you try firefox?

I have attached a screenshot of your loaded file.

 

recon.png

Link to comment
Share on other sites

Ok, reinstalled one of my laptops with a clean Win10 (grabbed a new ISO from msdn).

Downloaded the latest official release of Chrome and Firefox.

Installed them without making any changes during the installation and without logging in and syncing any settings.

Did a factory reset of my Nano and followed the setup guide (https://www.wifipineapple.com/pages/setup > Windows).

 

Still the same result.

 

If I look at the console in Firefox I can see that it’s the same error as when I tried on my other computer “results.results is null”

 

Am I missing something?

Link to comment
Share on other sites

just a thought but have you tried it on another OS?  I know windows 10 is causing lots pf problems for people
in other areas, may be that is the issue!

regards
kerravon
 

Link to comment
Share on other sites

Ok, so I reinstalled the old laptop I was running Win 10 on and went with Ubuntu (16.04.1 LTS) instead.

Installed the system and updated to the latest version (in the default repos).

Used the Firefox that came with the installation but no luck.

Same as on the Win 10 and on my regular computer (which also runs Win 10).

The only thing that stays the same is that I can see the error “results.results is null” if I check the Firefox console.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...