Jump to content

Reporting Module / email problem


Recommended Posts

Hello community

I'm trying to send reports by email but no success. This is my configuration from the module

From
johndoe@gmail.com

To
johndoe@gmail.com

SMTP Server
smtp.gmail.com

SMTP Port
587

Domain
gmail.com

Username
johndoe@gmail.com

Password
johndoe_password

Use TLS
yes

Use STARTTLS
yes

Also I've downgrade my security from Google Dashboard to use third party clients

GmailSecurity3.jpg

My log from /tmp/reporting.log

2016-10-27-20:00: Failed to save to SD card - no SD card found
2016-10-27-21:00: Failed to send email to johndoe@gmail.com
2016-10-27-21:00: Failed to save to SD card - no SD card found
2016-10-27-22:00: Failed to send email to johndoe@gmail.com
2016-10-27-22:00: Failed to save to SD card - no SD card found
2016-10-27-23:00: Failed to send email to johndoe@gmail.com
2016-10-27-23:00: Failed to save to SD card - no SD card found
2016-10-28-00:00: Failed to send email to johndoe@gmail.com
2016-10-28-00:00: Failed to save to SD card - no SD card found

Any ideas? something wrong with gmail ? I have to tweak something with ssmtp ?

Thanks

Domino

 

Link to post
Share on other sites

There is a bug in reporting module,
You need to edit the /etc/ssmtp/ssmtp.conf and change it with your configuration.
For example, configuration for GMAIL:


root@Pineapple:/etc/ssmtp# cat ssmtp.conf

#
# /etc/ssmtp.conf -- a config file for sSMTP sendmail.
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=your_email@gmail.com

# The place where the mail goes. The actual machine name is required
# no MX records are consulted. Commonly mailhosts are named mail.domain.com
# The example will fit if you are in domain.com and your mailhub is so named.
mailhub=smtp.gmail.com:465

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname
hostname=mail.gmail.com

# Set this to never rewrite the "From:" line (unless not given) and to
# use that address in the "from line" of the envelope.
FromLineOverride=YES

# Use SSL/TLS to send secure messages to server.
UseTLS=YES
#UseSTARTTLS=Yes

AuthUser=your_email@gmail.com
AuthPass=your_gmail_password

# Use SSL/TLS certificate to authenticate against smtp host.
#UseTLSCert=YES

# Use this RSA certificate.
#TLSCert=/etc/ssl/certs/ssmtp.pem


 

  • Like 1
  • Upvote 1
Link to post
Share on other sites
2 minutes ago, Sebkinne said:

Which firmware are you on? This shouldn't be an issue anymore, not for longer time. 

Hello Sebkinne

For me I'm on : 1.1.1 

I've done the changes into /etc/ssmtp.conf @bitxo but no success again. Failed to send ! I'll reboot the device

Link to post
Share on other sites
  • 2 years later...
On 10/31/2016 at 2:31 AM, bitxo said:

There is a bug in reporting module,
You need to edit the /etc/ssmtp/ssmtp.conf and change it with your configuration.
For example, configuration for GMAIL:


root@Pineapple:/etc/ssmtp# cat ssmtp.conf

#
# /etc/ssmtp.conf -- a config file for sSMTP sendmail.
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=your_email@gmail.com

# The place where the mail goes. The actual machine name is required
# no MX records are consulted. Commonly mailhosts are named mail.domain.com
# The example will fit if you are in domain.com and your mailhub is so named.
mailhub=smtp.gmail.com:465

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname
hostname=mail.gmail.com

# Set this to never rewrite the "From:" line (unless not given) and to
# use that address in the "from line" of the envelope.
FromLineOverride=YES

# Use SSL/TLS to send secure messages to server.
UseTLS=YES
#UseSTARTTLS=Yes

AuthUser=your_email@gmail.com
AuthPass=your_gmail_password

# Use SSL/TLS certificate to authenticate against smtp host.
#UseTLSCert=YES

# Use this RSA certificate.
#TLSCert=/etc/ssl/certs/ssmtp.pem


  

I dont see the file i need to edit when i do into etc there is etthercap

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...