Jump to content

Client Mode


D4sh
 Share

Recommended Posts

Hi,

Sorry for the very newbie question here.  But i have been playing with my Nano over the last couple of days.  But when i try to get client mode up and running it never returns my home router when i run the scan, it will pick up the majority of my neighbors kit, but never my own.

When i use my nexus tethered to it, it works great.  But i would like to get client mode up and running.

Thanks,

Simon 

Link to comment
Share on other sites

i have a similar issue. i use my android phone to connect to the nano and when i want to connect to a secured AP and yes i know the password to it, it doesnt connect and it has the latest firmware. 

any suggestions?

 

steps;

turn on the nano

login into the nano

clicking on networking

when i arrive at the wifi client mode i only see 1 wireless interface (wlan1)

i press scan and find a few AP's, then i select the 1 i need and type in the password

i press connect and wait a few seconds and nothing.

 

any ideas what is going wrong ???

 

 

Additional;

maybe something with the kernel IP routing i assume?

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan
172.16.42.0     *               255.255.255.0   U     0      0        0 br-lan

 

 

br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:90:B7:15
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1861 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1664 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:209041 (204.1 KiB)  TX bytes:850768 (830.8 KiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:90:B7:15
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:27 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1794 (1.7 KiB)  TX bytes:1794 (1.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:90:88:2E
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:822 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:81489 (79.5 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:90:88:2E
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2011 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2313 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:290118 (283.3 KiB)  TX bytes:964203 (941.6 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:90:9F:F8
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Edited by Bitbot17
Link to comment
Share on other sites

On 10/14/2016 at 11:59 AM, Bitbot17 said:

i have a similar issue. i use my android phone to connect to the nano and when i want to connect to a secured AP and yes i know the password to it, it doesnt connect and it has the latest firmware. 

any suggestions?

 

steps;

turn on the nano

login into the nano

clicking on networking

when i arrive at the wifi client mode i only see 1 wireless interface (wlan1)

 

wlan0 and wlan1 are both used by PineAP. You will need another wireless adapter to properly use client mode. As for why it's not connecting with wlan1, that I can't help with. But I strongly suggest getting one of the adapters from hakshop to use for client mode.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...