Jump to content
Zylla

Recon freezes at 100%

Recommended Posts

Hi there.
I upgraded to 1.1.2 just recently, and have been experiencing some issues with Recon. It freezes at 100%, without any results showing. I'm also forced to press stop, regardless of the timer i set.
The strange thing is that it occasionally works! But that's like 1/20 times.

While i was debugging it, i noticed that /tmp/recon-$scanID was empty.
So i tried to execute the Recon command manually over SSH, and got this output:

root@nano:~# pinesniffer wlan1mon 15 0 /tmp/recon-test_15
[*] Pinesniffer started on wlan1mon, running for 15 seconds
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::erase
Aborted

root@nano:~# pinesniffer wlan1mon 30 0 /tmp/recon-test_30
[*] Pinesniffer started on wlan1mon, running for 30 seconds
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::erase
Aborted

When i attempt to run the command on my Tetra it works as expected, and the temp file contains the correct output.

Share this post


Link to post
Share on other sites

lmao... i tried to copy the pinesniffer binary from my Pineapple Tetra over to my Pineapple Nano, because i saw their filesize differed a bit, and i know they can run the same executables.
And now it's working as intended!

I get no errors when i execute it over SSH, and it's output in the web-interface is now displaying as intended!

Edited by Zylla

Share this post


Link to post
Share on other sites

Thanks for the report, it looks like a debug version of pinesniffer made it into the NANO tree somehow.

 

Ill get it fixed ASAP. 

Share this post


Link to post
Share on other sites

Just a heads-up. The binary i copied from my Tetra was for version 1.1.0. (The one that works)
The same problem happens on my Tetra when  i upgrade it to version 1.1.1!

Here's a output from my upgraded Pineapple Tetra (1.1.1)
 

root@tetra:/tmp# pinesniffer wlan1mon 15 2 /tmp/recon-test
[*] Pinesniffer started on wlan1mon, running for 15 seconds
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::erase
Aborted

 

Edited by Zylla

Share this post


Link to post
Share on other sites

Zylla,

Thank you again for bringing this to my attention. There have been a couple of interesting bugs with the new Recon mode, but I was sure I had caught them all. I was finally able to reproduce this bug by taking off the antennas, wrapping the WiFi Pineapple in tin foil, putting it into a microwave, and shutting the door.

The issue was hard to reproduce because I had a lot of WiFi Traffic in all the places I have available to test in right now. The actual cause of the issue was a string::pop_back() not being safe to use on empty strings in the OpenWRT version of g++. That's what I get for trusting my compiler :)

The issue only happened when there was a lack of clients, and would only randomly happen. I have fixed it and will release a firmware upgrade with this fix and an exciting new feature in the next couple of days, so stay tuned and thank you again.

Share this post


Link to post
Share on other sites

A microwave actually! That explains why it was working just fine at my office, and not at home (where i do most of these tests.)
I live quite far from the city, and the only wifi traffic here is mine. So that's probably why i was experiencing it almost all the time then.

Well i'm glad you managed to figure it out! Looking forward to the update :)

Share this post


Link to post
Share on other sites

In my situation, it seems that taking a larger period (like 1 minute) is a good workaround.There's not too much traffic either, lots of AP's but just a few clients (<5). 

Looking forward to the update too, though....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...