Jump to content

Strange capture with PineAP after fresh upgrade to Nano 1.1.1


Drewid
 Share

Recommended Posts

I'm getting a really strange output in the PineAP SSID pool from captures.  I get proper test SSIDs captured from my devices in the area but then occasional random strings.

Log probes, log associations, capture SSIDs to log are the enabled check boxes under PineAP with the Daemon running.  

I'll try running airmon-ng tomorrow through kali on the laptop to see if there's anything in the area that I'm missing.  In the testing with all of the other pineapples prior, I've never seen output like this.  

 

Sample output section:

______________________________________

SeriesofTubes

SeriesofTubes5g

S4DxwRA8?c&$M-03;z5Za?|]8e<oQ0:#
Pz+d-rjb<@HCgZyegbP?@1DduvM:(BtI
KiZRl8$xZi!=xC-dZR<.^p]k io0OBx+
TestAPSSID1

______________________________________________

I get a few valid SSIDs and then random strings for a while and then valid output again.  

I don't have any other modules running currently and just got the device today.  

The only two modules I've installed after upgrade and factory reset is:

Site Survey 1.2        
Status 1.1

I'll happily provide any other info to help figure this out.  

Preemptive apologies if this has been covered somewhere else, I searched the forums and didn't find something similar.  

 

 

Link to comment
Share on other sites

What you have suggested has been verified.  I'm currently running the Nano directly from my Anker 10000 battery pack and am not seeing the same behavior. It's a bit surprising that the  RaLink RT5370  included with the Tactical Elite pack would exceed the power available with Juice 4000 with the listed  Voltage: 5V+5%, Amperage: 70mA Average 

Link to comment
Share on other sites

The measured DC voltage of the battery doesn't tell the  whole story. What happens when a battery voltage falls is the 'internal resistance' to give it's proper name increases. This means that sudden increases in current drain eg something switching will produce a brief drop in voltage, an inverted spike, which may drop to almost zero, this results in brief erroneous outputs so explaining brief garbled readings. Note in any power supply there are always filter capacitors across the output to reduce this effect.

Nothing is going to improve a battery too low to function correctly but putting a capacitor of typically 100uF to 470uF across the battery terminals will reduce the effect of glitches/transients happening when the current drain fluctuates. There should also be another capacitor across this (in parallel) of around 100 to 220nf. This may seem pointless as it doesn't affect the total value of capacitance but small caps have a very low inductance so will bypass fast transient current demands far better than the large 100-470uF.

So it is not the actual DC current drain causing the erroneous outputs but the battery fluctuations caused by the connected equipment taking 'gulps' of current during switiching, especially as the battery voltage falls, as people such as highwire noted this starts happening after a time when the battery voltage begins to drop.

I hope this makes sense, being an oldie curing erratic and often corrupted data during power fluctuations was a common problem and 'decoupling' capacitors to give them their proper name are always desirable even when using battery power.

Link to comment
Share on other sites

  • 2 weeks later...

Thank you all, I was having issues with the Pineapple juice 4000 providing enough power.  It was fully charged after receiving it and charging for a few hours.  I ran it for about a day straight on an anker 10k usb power pack without a blip or reset.  I was using the 180* adapter that was included with the pineapple juice so there shouldn't be any cable issues there.   I would plug it straight into the Anker or use a short 6" cable when running with that.  I ran into a few issues last night on the Pineapple juice 4000 where after it got down to 3 out of the four battery lights lit where it would stop responding to wifi connect attempts and the LED on the Nano would go dimmer than it should.  Perhaps I ended up with a bum juice unit.  I've had it run successfully for 3 days straight while attached to an Anker charger.  It is definitely power sensitive.  I've not yet tried running without the 3rd wifi adapter that came with the kit to see if that one thing was sending it over the edge.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...