Jump to content
ckn

sshfs on boot and/or persistence

Recommended Posts

Hi, great little toy, though having some issues with sshfs.

I managed to get autossh and sshfs to connect to a linux box i have on the net over tcp:443 without a hassle.  Great posts from the forum and good videos. Thanks...

autossh works as advertised, and starts on boot, within 60 seconds of connecting i am able to ssh in.

However, i cannot seem to get sshfs to start on boot, and instead have to ssh in, use the turtle menu to start it or exit to the cli and type start sshfs.

both autossh and sshfs exist in /etc/turtle/autostart_modules as symlinks to their respective  /etc/turtle/modules/ files as called by /etc/init.d/turtle

I have even tried to 'wrong way' to do things and set start sshfs in /etc/rc.local 

but with no avail.  

It would be helpful to have sshfs started on boot instead of having to connect to, and manually start on, or shortly after boot.

any known fix?

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

in /etc/rc.local, have you tried something like this:

while [ 1 ]; do sshfs -f username@192.168.1.2:"/tmp" /path/to/local/share; sleep 60; done &

you'll have to change you sshfs settings to fit your needs though. This will loop through trying to connect, until it does, then it will stop trying to connect because of the -f flag

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...