Jump to content

Question for Turtle creators - autossh settings


kanalia
 Share

Recommended Posts

Hi, Can you please kindly explain the following settings:

        option gatetime '0'
        option monitorport '20000'
        option poll '600'

taken from etc\config\autossh. I have a problem with autossh. When I plug my turtle with Ethernet cable already attached it won't work. I need to wait for the orange light to stop blinking, then attach the Ethernet cable, autossh works like a charm then. I thought that if I could delay executing the ssh command maybe it would work with Ethernet cable attached as well. I was going to embed the turtle in IP office phone, where turtle pins will be soldered to the PCB of the phone (which translates to Ethernet cable attached when powering Turtle). I really need to get it working. 

Any help much appreciated, regards, kanalia

Link to comment
Share on other sites

Right folks, I do not know if this is coincedence but it works every time if i change the syntax on VPS. My pc at work is behind firewall so I can reverse ssh to my VPS only through port 80 or 443. I have changed the ssh settings (etc/config/autossh) to:

option ssh '-i /root/.ssh/id_rsa -N -T -R 2222:localhost:22 turtlessh@X.X.X.X -p 443'

and then on my VPS:

ssh -p 2222 root@localhost

This works every time. Previosly i called ssh root@localhost -p 2222 which intermitently connected to turtle but most of the time it thrown a 'Connection refused' error.

Please give this a try and let me know if it works. I lost my hair overnight, so embarasing.

P.S. I hate computers! I was not born to do it. Unfurtunatelly there is nothing else I could do to pay the bills :)

Link to comment
Share on other sites

gatetime is how long the connection should be active before autossh considers the connection 'good'. 0 disables this feature

poll is how long in second autossh should wait before trying again after failing to connect

monitor port is the port that autossh uses to create a tunnel to the host to periodically check on the health of the connection

 

re: not connecting the turtle with the ethernet cable attached... you need to let the turtle boot first before connecting the ethernet cable

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...