Jump to content
Skinny

Windows 10 Internet Connection Sharing Issue with Nano

Recommended Posts

In the process of working with the Pineapple Nano this morning, Windows 10 had a nasty little oddity waiting for me with Internet Connection Sharing (ICS). I thought I'd make everyone aware of the strangeness and the solution. 

The Problem

Windows 10 ICS would not allow the Pineapple to connect through my windows box. After repeated attempts at a solution, I found that Windows 10 was deceiving me. When I looked at the adapter settings, the IP address would appear as one thing and in the command terminal, it would appear as a completely different address.

Win10_ICS_fix01.png

The Fix

The fix to this is to first click the Advanced... button at the bottom right of the IPv4 Properties box. After clicking, it should look like this:

Win10_ICS_fix02.png

Highlight the 192.168..... address and click remove. Next, click ok twice and close the IPv4 settings box. Finally, right click on the Ethernet adapter governing the Pineapple and disable the adapter.

Win10_ICS_fix03.png

Then right click on it again and Enable the adapter. The correct IP address should stick and ICS should work once again.

How Does this Happen?

Whenever I have finished using the Pineapple on my Windows box, I always turn off ICS. For some reason if the Pineapple is plugged back in and you go through the ICS setup process again, windows seems to give you the IP it wants you to have for ICS and let you keep the IP address you specified earlier for the device. It's a bit strange. 

If you leave ICS on after using the Pineapple, upon reconnecting the Pineapple, everything seems to work fine.

Anyway, I hope this proves to be helpful to someone. Have a great day!

  • Upvote 2

Share this post


Link to post
Share on other sites

Hi,

Just a follow up on Windows 10 ICS issue/fix you've explained so well (thank you!).  I connected the Nano to my Windows 10 laptop, it sets itself up just fine and configures the 172.16.42.1 network (which comes up as Network 2 in my Network Connections panel).  I can browse to the Pineapple just fine on port 1471.  As soon as I set internet sharing on my WiFi network and select the Nano network in the drop down box, it reconfigures the Nano network and shows as an "Unknown Network".  I switch off ICS, it comes back to Network 2 again and I'm fine - except I have no internet sharing.  

So back to setting internet sharing again.  Ipconfig shows 192.168.137.1.  So, this is the same problem that you reported.  I followed the fix instruictions.  I changed the adapter manually to 172.16.42.1 via the IPv4 properties/Advanced, then disabled and enabled the adapter, but to no avail - the network persisted as "Unknown" and ipconfig showed just an 1pv6 address.  No amount of disabling and enabling correctedd this. So, this is not the same fix. 

I resolved it finally by setting the IP address to 172.16.42.42 - the network continued to say it was an unidentified network, but everything now works for internet connectivity.  Anyway, just a bit more information on the issue.

 

Share this post


Link to post
Share on other sites

I'm also having trouble with ICS in Windows 10. I followed all the steps from the  oficial video setup, but in my case it displays the correct IP Adress though does not share the connection with Nano. What am I doing wrong?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...