Jump to content

Clear Logs on Internal Storage


Recommended Posts

Being the evil "genius" I am, I dove into playing with the nano as soon as I received it without rtfm.

I was able to get it setup, spoof an ap and get my phone to connect to it.  woot!  I had installed a few modules so decided to give dwall a shot and see how well it worked.

Well, it worked well. Only too bad for me because I hadn't yet connected any kind of external storage. My hunch is that the logs for dwall ate through what was available internally.  In fact the System Log had a ton of error messages telling me I was out of space. I rebooted the nano hoping to clear any temp files.

I see from the Advanced section of the web interface that /dev/root/ is full (looks like tmpfs is fine).

WiFi Pineapple 2016-09-03 13-47-27.png

Navigating to the directory via SSH doesn't show much ".     ..    .rnd  .ssh"

So I'm not sure where to look to free up the space - any suggestions?  Also, is there anything I need to do once I've added the microSD to point modules to use the storage device? 

Any guidance is much appreciated. Thanks!

Link to comment
Share on other sites

When you install an SD card you can install modules to the sd as well as some of the log files not to mention gaining a swap partition. To be honest I haven't run my NANO without a SD so am not sure what you should do exactly. I'm guessing you could remove a module or two to free up some room but ultimately you probably want to get a SD in there ASAP and go from there.

Link to comment
Share on other sites

Easiest way would be to just factory reset, put a sd card in and then install modules to the sd card.  You can search around more in ssh like the pineapple folder maybe or search around for logs folder, but there's so little space on the nano  it would be better to just start fresh and clean with additional storage ready to go.

  • Upvote 1
Link to comment
Share on other sites

System Module logs (PineAP in particular) are stored in /tmp/ (By default). Your output from the Resources panel shows /tmp/ is its own tmpfs, indicated no relation to space being filled up on the "internal" storage. User-developed modules may store there logs elsewhere, common place being in /root/ under a hidden directory.

Explore these commands:

ls /tmp/
ls -la /root/
df /tmp/
df /root/


  • Upvote 1
Link to comment
Share on other sites

Thanks for the responses everyone!

I'll start again with a factory reset and the proper amount of storage.

Thanks @Foxtrot for the suggested commands.  They show that the .rnd file is over 1mb. I know it's a store of "random" data for use with security certs but not much beyond that.  I could probably just delete it and try again, but a factory reset probably puts me on the best path forward and gives me a chance to practice setting it up again.

Thanks again!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...