Jump to content

Recommended Posts

Ok so let me preface this with an apology in case my google fu has failed me.  I've had a ducky for about a week now and have to be able to flash new firmware to it.  I know you have to push the button during insertion to enter dfu mode.  I have tried on a mac, windows 10 VM, and a kali box and have to get it.  Nothing even seems to see it... Is there a way to verify dfu mode?  Im hoping its not a faulty pin.

Any help is greatly appreciated!!

 

 

Link to post
Share on other sites

Didn't see this. I just posted essentially the same issue in anther thread. Same deal - Just got it in the mail the other day and can't seem to get dfu mode to work. Does your LED light up a solid red when you press the button while inserting?

Link to post
Share on other sites

Just had these problems on a ducky here.  Here's what I found and what worked for me.

I didn't seem to get the images/HEXs from the git hub to work. (but can't confirm it 100% only tried 2 and might have screwed something up) I grabbed the text and saved in TextEdit as plain text (might be OSX's line endings if I had to guess).

Had a folder that had ones I DL'd a year or so ago.  Those worked.

On OSX (10.9-Macericks)

Insert while holding button down.

 sudo ./dfu-programmer at32uc3b1256 reset
sudo ./dfu-programmer at32uc3b1256 erase
sudo ./dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem <hexfile>
 sudo ./dfu-programmer at32uc3b1256 reset

 

Now If I got a no device error, I just did the unplug, and reinsert while holding button.

I tried 2 of my older HEX files and both worked.  Hope this helps you guys.

 

(Now if we could get some descriptions on the github page stating what each firmware does, that would be cool.  Just says something along the lines of "moved from googlecode to github currently)

Link to post
Share on other sites

I'm having a problem with putting my duck in dfu mode. I hold the button in upon insertion but it continues to execute the payload. Upon further inspection i realized the replay button doesn't work at all any thoughts on how to fix it or would anyone recommend just purchasing an new one?

Link to post
Share on other sites
On 9/5/2016 at 10:12 PM, 4n0m4ly said:

I'm having a problem with putting my duck in dfu mode. I hold the button in upon insertion but it continues to execute the payload. Upon further inspection i realized the replay button doesn't work at all any thoughts on how to fix it or would anyone recommend just purchasing an new one?

Try removing the SD card.

I have one Ducky that is missing the little rubber part of the button.  Just using a paperclip or such works. But I'd try to find something not conductive.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...