Jump to content

Cannot SSH to Lan Turtle (tried OSX/WIN10)


aristos
 Share

Recommended Posts

Hi,

I purchased the lan turtle this May from Edutech Hakshop, and was on the side until some days ago when I decided to play with it.

Unfortunately I discovered that I cannot SSH to it, with or without the LAN cable on the other side.

I tried both my Macbook and in WIN10 through a Virtual Box machine but no luck, even though I can see the Realtek USB device in Virtual Box.

I would like to ask if this needs to be replaced, or you suggest me to try a "Factory Reset" first?

Thanks

 

Screen Shot 2016-08-07 at 23.36.15.png

Link to comment
Share on other sites

The turtle did have issues with load drivers for certain versions of OSX. Can you post the following extra info:

What version of OSX you are running.

Example output from ifconfig / ipconfig / whatever OSX uses and an indication which adapter is the turtle.

Can you ping the turtle?

Have you tried plugging in the turtle via the ethernet cable to the laptop you are trying to access it from?

 

Link to comment
Share on other sites

Hi,

- OSX Version: El Capitan 10.11.2

- No I cannot ping the lan turtle

- full ifconfig output: 

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet6 ::1 prefixlen 128
	inet 127.0.0.1 netmask 0xff000000
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
	nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	ether b8:e8:56:2e:7d:f8
	inet6 fe80::bae8:56ff:fe2e:7df8%en0 prefixlen 64 scopeid 0x4
	inet 10.100.100.39 netmask 0xffffff00 broadcast 10.100.100.255
	nd6 options=1<PERFORMNUD>
	media: autoselect
	status: active
en1: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500
	options=60<TSO4,TSO6>
	ether 72:00:00:60:91:50
	media: autoselect <full-duplex>
	status: inactive
en2: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500
	options=60<TSO4,TSO6>
	ether 72:00:00:60:91:51
	media: autoselect <full-duplex>
	status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
	ether 0a:e8:56:2e:7d:f8
	media: autoselect
	status: inactive
awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1484
	ether e6:ea:5a:63:e8:9f
	inet6 fe80::e4ea:5aff:fe63:e89f%awdl0 prefixlen 64 scopeid 0x8
	nd6 options=1<PERFORMNUD>
	media: autoselect
	status: active
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	options=63<RXCSUM,TXCSUM,TSO4,TSO6>
	ether ba:e8:56:e2:2f:00
	Configuration:
		id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
		maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
		root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
		ipfilter disabled flags 0x2
	member: en1 flags=3<LEARNING,DISCOVER>
	        ifmaxaddr 0 port 5 priority 0 path cost 0
	member: en2 flags=3<LEARNING,DISCOVER>
	        ifmaxaddr 0 port 6 priority 0 path cost 0
	nd6 options=1<PERFORMNUD>
	media: <unknown type>
	status: inactive
vboxnet0: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	ether 0a:00:27:00:00:00
vboxnet1: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	ether 0a:00:27:00:00:01
vboxnet2: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	ether 0a:00:27:00:00:02
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
	inet 10.10.30.131 --> 10.10.30.131 netmask 0xffffffc0

 

Link to comment
Share on other sites

Once you know which interface is the Lan Turtle (if in doubt, unplug it, run ifconfig as above, replug and run ifconfig again, new interface is the Turtle) run dhclient (or Mac Equivalent) on the interface. Failing that, give it a static IP of 172.16.84.5 (netmask 255.255.255.0) and try again.

Link to comment
Share on other sites

Unfortunately ifconfig returns the same list with or without the lan turtle plugged in.

Yes I have read this post some days ago but the solution was:

"I wanted to say that the solution to this was just getting a replacement LANturtle. Now, everything is working great."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...