Jump to content
cheeto

update with 3g support?

Recommended Posts

Hey guys, 

Does anyone know if the future update will have 3g dongle support?

Cheers!

  • Upvote 1

Share this post


Link to post
Share on other sites

Please see thread: 

 

Down the bottom i posted a working combo on the Tetra. Almost plug and play so no nano "support" needed since it is supported by the OS. Should work on the nano too

Edited by Smarty
  • Upvote 1

Share this post


Link to post
Share on other sites
18 minutes ago, Smarty said:

Please see thread: 

 

Down the bottom i posted a working combo on the Tetra. Almost plug and play so no nano "support" needed since it is supported by the OS. Should work on the nano too

 

Share this post


Link to post
Share on other sites

i plugged my  3G HUAWEI E 173  into my nano and simply does not work.

It does work on the mkv however.  Can someone recommend a compatible 3g usb stick for the nano?

 

thx

Share this post


Link to post
Share on other sites

See the other thread. E173 is not a cdc ether device. Try e3372h-153

Share this post


Link to post
Share on other sites

I actually did look for that one but it's not available where i live. (South America)

I thought that 3g dongles that worked on the mkv would work on the nano.

Any other 3g dongle come time mind?

thx

Share this post


Link to post
Share on other sites

I can't seem to get my 3g dongle to work on the Nano either.  This is the only reason my nano is collecting dust.

@Cheeto, I wouldn't go out and buy a new 3g dongle.   it may not work.   I'd suggest waiting for an update to come out.

Share this post


Link to post
Share on other sites

@medudder, I don't mind waiting as long as I know that the 3g dongle will work in future update.

 According to "Smarty", the e3372h-153 is compatible with the Tetra.   I would hope that it's compatible with the nano too.  Has anyone tried it on the Nano?

 

 

 

Share this post


Link to post
Share on other sites
On 6/23/2016 at 9:35 PM, cheeto said:

@medudder, I don't mind waiting as long as I know that the 3g dongle will work in future update.

 According to "Smarty", the e3372h-153 is compatible with the Tetra.   I would hope that it's compatible with the nano too.  Has anyone tried it on the Nano?

 

 

 

tested E3372H with nano, it works in a specific setup. 
You might find articles with suggestion to mod the E3372H to disable NAT mode or messing around with USB_modeswitch, they are not necessary. 

Setup: Nano Firmware 1.1.1

1) nano + E3372H + battery bank ==> success, provided internet to nano automatically

2) laptop connected to nano which is connected to E3372H ==> fails, eth1 went up when dongle is plugged in but fails to acquire IP address thus no internet

I am not a expert on linux networking so i cant be certain what is wrong with setup (2), but so glad i tested (1). 
 

Share this post


Link to post
Share on other sites

Thanks for your input.  GREAT observation regarding the fact that it doesn't work when connected to a laptop.  I don't recall this being addressed.

It was my understanding that if the dongle worked on the MKV, then it would work on the Nano.   For me, this was not the case.  I own a HUAWEI E173 and it works perfectly on the mkv.   Unfortunately it has never worked on the Nano.   I will try to connect with the battery bank and see what happens,

 

THANKS AGAIN.  I will post the results.   I need to charge the battery 1st.

 

Cheers!!!!

Share this post


Link to post
Share on other sites

I have had mixed success with different 3G dongles and have settled on a couple that work with the nano (HUAWEI HiLink E303 and E3131) but there are for sure others. This info came from this post from a while back.

If your getting a eth1 populated thats great news as it should just be a configuration issue, try editing /etc/config/network and /etc/config/firewall to include the following: -

/etc/config/network

config interface 'wan2'
	option ifname	'eth1'
	option proto	'dhcp'
	option dns	'8.8.8.8, 8.8.4.4'

If using the above and your still not getting an IP on the eth1 interface try a static IP in the same 3g dongle range - the example below is based on the dongle management page at IP 192.168.1.1

config	interface	'wan2'
	option ifname 	'eth1'
	option proto	'static'
	option ipaddr	'192.168.1.2'
	option netmask	'255.255.255.0'
	option gateway	'192.168.1.1'
	option dns	'8.8.8.8, 8.8.4.4'

 

/etc/config/firewall

config zone
	option name		wan2
	list   network		'wan2'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT
	option masq		1
	option mtu_fix		1

and

config forwarding
	option src		lan
	option dest		wan2

config forwarding
	option src		wan2
	option dest		lan

This got both dongles working for me and have been using them for a while. For those of you without an eth1 being populated this probably wont work and you may need additional drivers loaded into the nano, or change dongles. Hope this helps

Share this post


Link to post
Share on other sites

Thanks for the info guys, I hoked up the nano to the battery and i updated the 2 files mentioned above.  I didn't work.

 

Here some info of what im getting in the HOSTNAME window:

 

br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:8B:3B:7D
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19642 errors:0 dropped:306 overruns:0 frame:0
          TX packets:20978 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3617403 (3.4 MiB)  TX bytes:16455978 (15.6 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:8B:3B:7D
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:61 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4327 (4.2 KiB)  TX bytes:4327 (4.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:8B:3A:B5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:734 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:129552 (126.5 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:8B:3A:B5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19824 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21700 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3965720 (3.7 MiB)  TX bytes:17171491 (16.3 MiB)

wlan2     Link encap:Ethernet  HWaddr 00:C0:CA:8B:3C:44
          inet addr:192.168.0.191  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9255 errors:0 dropped:7 overruns:0 frame:0
          TX packets:7188 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7772924 (7.4 MiB)  TX bytes:1648065 (1.5 MiB)

As you can see, there is no eth1.

Could someone upload their tweaked version of the network and firewall files?

thx!!!

Share this post


Link to post
Share on other sites

Hi @cheeto

Sounds like your dongle is serial. You can check for a /dev/ttyUSB0 or similar when its plugged in. Looks like you will have to wait for @Foxtrot's modem manager module

If you cant wait and fancy a read there is some serial modem info found here https://wiki.openwrt.org/doc/recipes/3gdongle

Share this post


Link to post
Share on other sites

@medudder, I don't mind waiting as long as I know that the 3g dongle will work in future update.

 According to "Smarty", the e3372h-153 is compatible with the Tetra.   I would hope that it's compatible with the nano too.  Has anyone tried it on the Nano?

 

I think you're right.  I have to wait it out.

I really wish the nano's mobile broadband were more user friendly.

 

Thanks again for your effort.

 

Cheers

 

 

Share this post


Link to post
Share on other sites
16 hours ago, cheeto said:

@medudder, I don't mind waiting as long as I know that the 3g dongle will work in future update.

 According to "Smarty", the e3372h-153 is compatible with the Tetra.   I would hope that it's compatible with the nano too.  Has anyone tried it on the Nano?

 

I think you're right.  I have to wait it out.

I really wish the nano's mobile broadband were more user friendly.

 

Thanks again for your effort.

 

Cheers

 

 

if your dmesg has the below message when the dongle is plugged in then you probably have an issue with the modeswitch. ie the dongle is behaving as if it is a storage device and not a modem. To debug you could try this link.

http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?p=4521

Quote

May 12 09:24:44 archbook kernel: [ 7286.844556] scsi 68:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
May 12 09:24:44 archbook kernel: [ 7286.845155] sd 68:0:0:0: Attached scsi generic sg1 type 0
May 12 09:24:44 archbook kernel: [ 7286.845427] scsi 67:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
May 12 09:24:44 archbook kernel: [ 7286.849419] sr0: scsi-1 drive

or just purchase a E3372 from China, last check some are selling at around USD$35 on taobao (china's equiv of amazon)

Share this post


Link to post
Share on other sites

Thanks for your feedback guys.

I just. Bought a e3372h.  I'll be picking it up at the end of the year though.  :(. I can't ship anything to South America.

Well, I guess it's safe to say that 3g dongle modems that worked on the Mark V may not work on the nano.

:(

 

Cneers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...