Jump to content

RALINK USB WIFI RT5370 Troubleshooting


jamesford
 Share

Recommended Posts

Having trouble with the NANO recognizing the RALINK USB WIFI RT5370 adapter. I'm either doing it wrong, or the unit was DOA.

I've tried booting the NANO with the RALINK plugged in and booting and then plugging in the RALINK, but it does not seem to recognize the new usb device, here is the output of lsusb when booting the NANO with the RALINK installed. Here is the output of lsusb.

root@Pineapple:~# lsusb

Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc.

Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Using logread I can see the following relevant messages:

Sat May 7 04:20:02 2016 kern.info kernel: [ 114.210000] usb 1-1.3: new high-speed USB device number 5 using ehci-platform

Sat May 7 04:20:17 2016 kern.err kernel: [ 129.290000] usb 1-1.3: device descriptor read/64, error -145

And dmesg output

[ 114.210000] usb 1-1.3: new high-speed USB device number 5 using ehci-platform

[ 129.290000] usb 1-1.3: device descriptor read/64, error -145

[ 144.480000] usb 1-1.3: device descriptor read/64, error -145

[ 144.670000] usb 1-1.3: new high-speed USB device number 6 using ehci-platform

[ 159.750000] usb 1-1.3: device descriptor read/64, error -145

[ 174.940000] usb 1-1.3: device descriptor read/64, error -145

[ 175.130000] usb 1-1.3: new high-speed USB device number 7 using ehci-platform

[ 180.160000] usb 1-1.3: device descriptor read/8, error -145

[ 185.290000] usb 1-1.3: device descriptor read/8, error -145

[ 185.480000] usb 1-1.3: new high-speed USB device number 8 using ehci-platform

[ 190.510000] usb 1-1.3: device descriptor read/8, error -145

[ 195.640000] usb 1-1.3: device descriptor read/8, error -145

[ 195.750000] usb 1-1-port3: unable to enumerate USB device

Any thoughts?

Link to comment
Share on other sites

Not close to a linux machine at the moment but here is the output from dmesg from a mac below. Device was purchased from the hak5 shop.

en6: promiscuous mode enable succeeded

bridge100: successfully restored 4 suspended link-layer multicast membership(s) (err=0)

in6_unlink_ifa: IPv6 address 0x6c099ce12bd43d5b has no prefix

in6_unlink_ifa: IPv6 address 0x6c099ce12fb9c92b has no prefix

in6_unlink_ifa: IPv6 address 0x6c099ce12fb9c7db has no prefix

in6_unlink_ifa: IPv6 address 0x6c099ce12bd44bcb has no prefix

971114.744618 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971114.744753 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971114.744766 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971130.810612 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971130.810994 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971130.811032 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971146.901230 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971146.901372 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971146.901394 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971163.039026 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971163.039301 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971163.039321 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971179.272507 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971179.272639 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971179.272652 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971195.697837 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971195.698155 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971195.698161 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971205.942597 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971205.942799 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971205.942808 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971241.208240 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971241.208394 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971241.208415 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971242.720204 IOUSBHostDevice@14411000: IOUSBHostDevice::start: failed to get device descriptor

971242.720329 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971242.720345 AppleUSB20HubPort@14411000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

971261.176991 IOUSBHostDevice@14412000: IOUSBHostDevice::start: failed to get device descriptor

971261.177209 AppleUSB20HubPort@14412000: AppleUSB20HubPort::resetAndCreateDevice: failed to start device

971261.177239 AppleUSB20HubPort@14412000: AppleUSB20HubPort::resetAndCreateDevice: failed to create device (0xe00002e9), disabling port

Link to comment
Share on other sites

Doesn't seem to be recognized on my mac either, here is the output of ioreg

root# ioreg -p IOUSB

+-o Root <class IORegistryEntry, id 0x100000100, retain 17>

+-o Root Hub Simulation Simulation@1d000000 <class AppleUSBRootHubDevice, id 0x1000002e5, registered, matched, active, busy 0 (2 ms), retain 7>

| +-o IOUSBHostDevice@1d100000 <class AppleUSBDevice, id 0x1000002e6, registered, matched, active, busy 0 (2 ms), retain 13>

| +-o IOUSBHostDevice@1d180000 <class AppleUSBDevice, id 0x10000031d, registered, matched, active, busy 0 (1 ms), retain 13>

| | +-o BRCM20702 Hub@1d181000 <class AppleUSBDevice, id 0x10000035e, registered, matched, active, busy 0 (0 ms), retain 12>

| | | +-o Bluetooth USB Host Controller@1d181300 <class AppleUSBDevice, id 0x1000003ad, registered, matched, active, busy 0 (1 ms), retain 17>

| | +-o IR Receiver@1d182000 <class AppleUSBDevice, id 0x100000383, registered, matched, active, busy 0 (30 ms), retain 14>

| +-o Keyboard Hub@1d110000 <class AppleUSBDevice, id 0x10000033c, registered, matched, active, busy 0 (0 ms), retain 12>

| +-o Apple Keyboard@1d112000 <class AppleUSBDevice, id 0x100000372, registered, matched, active, busy 0 (3 ms), retain 13>

+-o Root Hub Simulation Simulation@1a000000 <class AppleUSBRootHubDevice, id 0x1000002eb, registered, matched, active, busy 0 (2 ms), retain 7>

| +-o IOUSBHostDevice@1a100000 <class AppleUSBDevice, id 0x1000002ec, registered, matched, active, busy 0 (3 ms), retain 11>

+-o Root Hub Simulation Simulation@14000000 <class AppleUSBRootHubDevice, id 0x10000030d, registered, matched, active, busy 0 (1 ms), retain 8>

+-o USB2.0 Hub @14400000 <class AppleUSBDevice, id 0x10000030e, registered, matched, active, busy 0 (1 ms), retain 12>

| +-o USB2.0 Hub @14410000 <class AppleUSBDevice, id 0x10000034f, registered, matched, active, busy 0 (1 ms), retain 11>

+-o USB3.0 Hub @14800000 <class AppleUSBDevice, id 0x100000327, registered, matched, active, busy 0 (2 ms), retain 14>

+-o USB3.0 Hub @14810000 <class AppleUSBDevice, id 0x1000003b3, registered, matched, active, busy 0 (2 ms), retain 11>

+-o Portable SSD T1@14820000 <class AppleUSBDevice, id 0x1000003c5, registered, matched, active, busy 0 (4 ms), retain 11>

+-o Portable SSD T1@14840000 <class AppleUSBDevice, id 0x1000189aa, registered, matched, active, busy 0 (8 ms), retain 11>

Link to comment
Share on other sites

I bought one from eBay mine appears to work fine on OS X El Captain 10.11.4 however it only works with Kali Linux 2016.1 inside a Virtual box. There is no Wireless Utility for OS X I guess for this adapter.

Edited by ZaraByte
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...