Jump to content

Raspberry Pi Tor/VPN router/setup


Bitbot17
 Share

Recommended Posts

hello reader,

i am trying to follow the link here below to make a portable tor/vpn router-ish.

so far i have been able to get to the 4th and 5ft step.

for some reason (pretty sure it has to be the drivers because at 1 point you can download a file for drivers-ish) it wil not send anything receive anything, i am thinking it is because of the driver file. i have tried looking into the files but its not making sense to me since im a noob to it

i am using 2 Alfa Network USB card AWUS036H. and i am using a rpi 3

is there anyone who can help me or can tell me what i am doing wrong?

http://makezine.com/projects/browse-anonymously-with-a-diy-raspberry-pi-vpntor-router/

im sorry if i am not aloud to post links from competitive sites (because im not sure if this is one)

Link to comment
Share on other sites

im guessing the drivers used for the tutorial are for a different chipset than what you have in the alfa. I could be wrong, but that was the problem I had. I just bought new wifi adapters that were made for the tutorial that I followed.

Link to comment
Share on other sites

You can make that alfa card work with airbase-ng instead of hostapd... hostapd is best used with atheros chip, the card and driver must support master mode... I would think hostapd gave out some errors?

Ifconfig wlan0 down

Iwconfig wlan0 mode monitor

Ifconfig wlan0 up

Airbase-ng -i wlan0 -c 6 -b wifipi

(New tab device has been created at0)

Ifconfig at0 up 192.168.69.1

Dnsmasq should have identical configuration as explained in the tutorial but the device name is at0

Link to comment
Share on other sites

You can make that alfa card work with airbase-ng instead of hostapd... hostapd is best used with atheros chip, the card and driver must support master mode... I would think hostapd gave out some errors?

Ifconfig wlan0 down

Iwconfig wlan0 mode monitor

Ifconfig wlan0 up

Airbase-ng -i wlan0 -c 6 -b wifipi

(New tab device has been created at0)

Ifconfig at0 up 192.168.69.1

Dnsmasq should have identical configuration as explained in the tutorial but the device name is at0

thanks ill give it a try today if i have the chance

hostapd never gave me an error, i followed the tutorial with every word.

i am thinking it has to do with the hostapd file.

but like i said im going to try your suggestion later on today

Edited by Bitbot17
Link to comment
Share on other sites

I'm kinda puzzled why you would want to make this. The guide shows a few very, VERY poor examples and since TOR exit nodes are publicly published and active blocked by many services, you either have a valid account (in which case you're not anonymous) or they won't let you access the service in the first place.

Seriously, TOR has no place on your router. Even if you run a hidden service such as a VPN. Watch this CCC talk from last december.

If you want to be anonymous, please read this post of mine from a while back and maybe the last paragraph of this post of mine. I think you'll find that what you want isn't to be anonymous. To solve any problem you must first correctly specify what it is. Start there.

Link to comment
Share on other sites

I'm kinda puzzled why you would want to make this. The guide shows a few very, VERY poor examples and since TOR exit nodes are publicly published and active blocked by many services, you either have a valid account (in which case you're not anonymous) or they won't let you access the service in the first place.

Seriously, TOR has no place on your router. Even if you run a hidden service such as a VPN. Watch this CCC talk from last december.

If you want to be anonymous, please read this post of mine from a while back and maybe the last paragraph of this post of mine. I think you'll find that what you want isn't to be anonymous. To solve any problem you must first correctly specify what it is. Start there.

okay, wat beveel je me dan aan?

okay what do you recommend me then?

i do not want to be 100% anonymous the reason is to only make it difficult for those snooping in public places

Link to comment
Share on other sites

If that is your goal, simply activate the VPN option on your home router (90+% of them support that these days) and have your devices connect to the internet via that. This way your mobile devices only talk crypto in their unsafe locations while the unencrypted communication goes onto the internet from your home network. Added benefit is having the home network resources (fileserver and the like) at your disposal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...