Jump to content

YARD Stick One and Raspberry pi 2


Recommended Posts

Hello everyone,

YS1 does not give me any problems when I plugged it to my laptop on VMware workstation. However, I made the setup for Raspbian on Raspberry Pi 2. The Pi is connected to a hotspot (Android) and is accessed it remotely using SSH. When I ran rfcat -r, I am getting the following error -- Error in resetup(): USBError('error sending control message : Operation not permitted',) I also tried connecting the Pi to LAN using Ethernet cable, but the same error message kept showing up.

Using lsusb command , the YS1 does show up on the list of devices as connected. I am wondering if the YS1 can't be used on the Pi. Maybe, the speed of the Pi is not enough or interfering with the wifi dongle connected to the Pi or any other issue. Any suggestion is appreciated about this issue.


Link to comment
Share on other sites

  • 1 month later...

Sorry for the late responce. I stopped working on this project, but I am back at it again. When I run the rfcat having the YS1 plug to a laptop, I don't get any problems as far as the laptop recognizing the YS1. However, when I connect the YS1 to the PI, the Pi doesn't recognized that the YS1 is plug into it. If I disconnect the YS1 from the Pi as I run rfcat, the Pi does ask me to connect the dongle. But when I connect the dongle(YS1) to the Pi, an error message comes up saying that it not like compatible with the Pi.



Link to comment
Share on other sites

  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...