Jump to content
Sign in to follow this  
D4rkOperat0r

Recon Mode Failure

Recommended Posts

Hi!

I'm having an issue with my Nano (v. 1.0.6) trying to survey AP and clients.

Recon mode starts running (selecting 15s, 30s or 1 min), progress bar reaches 100%, it freezes and doesn't show any results.

I've also tested PineAP and there is some problem broadcasting SSIDs.

Any idea?

Share this post


Link to post
Share on other sites

Hi!

I'm having an issue with my Nano (v. 1.0.6) trying to survey AP and clients.

Recon mode starts running (selecting 15s, 30s or 1 min), progress bar reaches 100%, it freezes and doesn't show any results.

I've also tested PineAP and there is some problem broadcasting SSIDs.

Any idea?

Can you run "ifconfig -a" over SSH and post your results?

If possible, please also attach a pastebin of your entire dmesg log on the WiFi Pineapple.

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

I am having the exact same problem. My nano just arrived today. I flashed it with the latest firmware (1.0.6) and it worked for a bit and now freezes almost every time when doing a recon scan.

Share this post


Link to post
Share on other sites

[ 0.000000] Linux version 3.18.23 (sebkinne@Worker) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46591) ) #9 Thu Mar 10 16:10:47 PST 2016

[ 0.000000] MyLoader: sysp=8a14b024, boardp=44b65156, parts=b69f8d32
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9330 rev 1
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x03ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x03ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
[ 0.000000] On node 0 totalpages: 16384
[ 0.000000] free_area_init_node: node 0, pgdat 80355cf0, node_mem_map 81000000
[ 0.000000] Normal zone: 128 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 16384 pages, LIFO batch:3
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=PINEAPPLE-NANO console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 60944K/65536K available (2466K kernel code, 128K rwdata, 528K rodata, 260K init, 188K bss, 4592K reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.090000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.100000] NET: Registered protocol family 16
[ 0.100000] MIPS: machine is WiFi Pineapple NANO
[ 0.380000] Switched to clocksource MIPS
[ 0.380000] NET: Registered protocol family 2
[ 0.390000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.390000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.400000] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.400000] TCP: reno registered
[ 0.410000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.410000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.420000] NET: Registered protocol family 1
[ 0.420000] PCI: CLS 0 bytes, default 32
[ 0.420000] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.440000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.440000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 0.450000] msgmni has been set to 119
[ 0.460000] io scheduler noop registered
[ 0.460000] io scheduler deadline registered (default)
[ 0.470000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.470000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a AR933X UART
[ 0.480000] console [ttyATH0] enabled
[ 0.490000] bootconsole [early0] disabled
[ 0.500000] m25p80 spi0.0: found mx25l12805d, expected m25p80
[ 0.500000] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
[ 0.520000] 5 tp-link partitions found on MTD device spi0.0
[ 0.520000] Creating 5 MTD partitions on "spi0.0":
[ 0.520000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.530000] 0x000000020000-0x0000001348d4 : "kernel"
[ 0.540000] 0x0000001348d4-0x000000ff0000 : "rootfs"
[ 0.540000] mtd: device 2 (rootfs) set to be root filesystem
[ 0.550000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.550000] 0x000000dc0000-0x000000ff0000 : "rootfs_data"
[ 0.560000] 0x000000ff0000-0x000001000000 : "art"
[ 0.560000] 0x000000020000-0x000000ff0000 : "firmware"
[ 0.590000] libphy: ag71xx_mdio: probed
[ 1.190000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[ 1.200000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.200000] TCP: cubic registered
[ 1.200000] NET: Registered protocol family 17
[ 1.210000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[ 1.220000] 8021q: 802.1Q VLAN Support v1.8
[ 1.230000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.240000] Freeing unused kernel memory: 260K (8036f000 - 803b0000)
[ 2.650000] init: Console is alive
[ 2.650000] init: - watchdog -
[ 5.320000] usbcore: registered new interface driver usbfs
[ 5.320000] usbcore: registered new interface driver hub
[ 5.330000] usbcore: registered new device driver usb
[ 5.380000] SCSI subsystem initialized
[ 5.390000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 5.400000] ehci-platform: EHCI generic platform driver
[ 5.400000] ehci-platform ehci-platform: EHCI Host Controller
[ 5.410000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 5.420000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 5.440000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 5.440000] hub 1-0:1.0: USB hub found
[ 5.440000] hub 1-0:1.0: 1 port detected
[ 5.450000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 5.460000] ohci-platform: OHCI generic platform driver
[ 5.470000] uhci_hcd: USB Universal Host Controller Interface driver
[ 5.480000] usbcore: registered new interface driver usb-storage
[ 5.770000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 5.810000] init: - preinit -
[ 6.420000] hub 1-1:1.0: USB hub found
[ 6.430000] hub 1-1:1.0: 4 ports detected
[ 6.600000] random: procd urandom read with 11 bits of entropy available
[ 6.820000] mount_root: loading kmods from internal overlay
[ 6.970000] usb 1-1.1: new high-speed USB device number 3 using ehci-platform
[ 7.130000] jffs2: notice: (325) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (0 unchecked, 2 orphan) and 2 of xref (0 dead, 2 orphan) found.
[ 7.140000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 7.160000] block: extroot: not configured
[ 7.190000] jffs2: notice: (322) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (0 unchecked, 2 orphan) and 2 of xref (0 dead, 2 orphan) found.
[ 7.250000] usb 1-1.2: new high-speed USB device number 4 using ehci-platform
[ 7.350000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[ 7.360000] block: extroot: not configured
[ 7.370000] mount_root: switching to jffs2 overlay
[ 7.410000] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[ 7.420000] scsi host0: usb-storage 1-1.2:1.0
[ 7.440000] procd: - early -
[ 7.440000] procd: - watchdog -
[ 8.470000] procd: - ubus -
[ 8.680000] scsi 0:0:0:0: Direct-Access Generic STORAGE DEVICE 0933 PQ: 0 ANSI: 6
[ 8.690000] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 9.490000] procd: - init -
[ 11.750000] Loading modules backported from Linux version v4.4-rc5-1913-gc8fdf68
[ 11.760000] Backport generated by backports.git backports-20151218-0-g2f58d9d
[ 11.910000] ath: EEPROM regdomain: 0x0
[ 11.910000] ath: EEPROM indicates default country code should be used
[ 11.910000] ath: doing EEPROM country->regdmn map search
[ 11.910000] ath: country maps to regdmn code: 0x3a
[ 11.910000] ath: Country alpha2 being used: US
[ 11.910000] ath: Regpair used: 0x3a
[ 11.920000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 11.930000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[ 11.940000] usb 1-1.1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[ 11.950000] usbcore: registered new interface driver ath9k_htc
[ 12.300000] RPC: Registered named UNIX socket transport module.
[ 12.300000] RPC: Registered udp transport module.
[ 12.310000] RPC: Registered tcp transport module.
[ 12.310000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 12.340000] tun: Universal TUN/TAP device driver, 1.6
[ 12.340000] tun: © 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 12.370000] usbcore: registered new interface driver rt2800usb
[ 12.380000] usbcore: registered new interface driver rtl8187
[ 12.410000] usbcore: registered new interface driver rtl8192cu
[ 12.450000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 12.460000] usbcore: registered new interface driver cdc_acm
[ 12.470000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 12.480000] usbcore: registered new interface driver cdc_wdm
[ 12.500000] nf_conntrack version 0.5.0 (956 buckets, 3824 max)
[ 12.540000] usbcore: registered new interface driver ums-alauda
[ 12.540000] usb 1-1.1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[ 12.550000] usbcore: registered new interface driver ums-cypress
[ 12.560000] usbcore: registered new interface driver ums-datafab
[ 12.570000] usbcore: registered new interface driver ums-freecom
[ 12.580000] usbcore: registered new interface driver ums-isd200
[ 12.590000] usbcore: registered new interface driver ums-jumpshot
[ 12.590000] usbcore: registered new interface driver ums-karma
[ 12.600000] usbcore: registered new interface driver ums-sddr09
[ 12.610000] usbcore: registered new interface driver ums-sddr55
[ 12.620000] usbcore: registered new interface driver ums-usbat
[ 12.640000] usbcore: registered new interface driver usbserial
[ 12.640000] usbcore: registered new interface driver usbserial_generic
[ 12.650000] usbserial: USB Serial support registered for generic
[ 12.710000] xt_time: kernel timezone is -0000
[ 12.710000] usbcore: registered new interface driver asix
[ 12.720000] usbcore: registered new interface driver cdc_ether
[ 12.730000] ip_tables: © 2000-2006 Netfilter Core Team
[ 12.750000] usbcore: registered new interface driver pl2303
[ 12.760000] usbserial: USB Serial support registered for pl2303
[ 12.770000] PPP generic driver version 2.4.2
[ 12.780000] NET: Registered protocol family 24
[ 12.790000] usbcore: registered new interface driver qmi_wwan
[ 12.800000] usbcore: registered new interface driver rndis_host
[ 12.800000] usbcore: registered new interface driver sierra_net
[ 12.820000] ath9k_htc 1-1.1:1.0: ath9k_htc: HTC initialized with 33 credits
[ 12.830000] usbcore: registered new interface driver option
[ 12.830000] usbserial: USB Serial support registered for GSM modem (1-port)
[ 13.080000] ath9k_htc 1-1.1:1.0: ath9k_htc: FW Version: 1.4
[ 13.080000] ath9k_htc 1-1.1:1.0: FW RMW support: On
[ 13.090000] ath: EEPROM regdomain: 0x0
[ 13.090000] ath: EEPROM indicates default country code should be used
[ 13.090000] ath: doing EEPROM country->regdmn map search
[ 13.090000] ath: country maps to regdmn code: 0x3a
[ 13.090000] ath: Country alpha2 being used: US
[ 13.090000] ath: Regpair used: 0x3a
[ 13.100000] ieee80211 phy1: Atheros AR9271 Rev:1
[ 22.930000] device eth0 entered promiscuous mode
[ 29.410000] device wlan0 entered promiscuous mode
[ 29.560000] device wlan0-1 entered promiscuous mode
[ 29.560000] br-lan: port 3(wlan0-1) entered forwarding state
[ 29.570000] br-lan: port 3(wlan0-1) entered forwarding state
[ 29.590000] br-lan: port 2(wlan0) entered forwarding state
[ 29.600000] br-lan: port 2(wlan0) entered forwarding state
[ 30.390000] br-lan: port 3(wlan0-1) entered disabled state
[ 31.600000] br-lan: port 2(wlan0) entered forwarding state
[ 31.850000] br-lan: port 3(wlan0-1) entered forwarding state
[ 31.850000] br-lan: port 3(wlan0-1) entered forwarding state
[ 33.850000] br-lan: port 3(wlan0-1) entered forwarding state
[ 44.240000] random: nonblocking pool is initialized
root@Pineapple:~# ifconfig

br-lan Link encap:Ethernet HWaddr 00:C0:CA:8D:BB:E9

inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1818 errors:0 dropped:44 overruns:0 frame:0

TX packets:2048 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:305713 (298.5 KiB) TX bytes:1103178 (1.0 MiB)

eth0 Link encap:Ethernet HWaddr 00:C0:CA:8D:BB:E9

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Interrupt:4

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:481 errors:0 dropped:0 overruns:0 frame:0

TX packets:481 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:38892 (37.9 KiB) TX bytes:38892 (37.9 KiB)

wlan0 Link encap:Ethernet HWaddr 00:C0:CA:8D:92:9E

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:786 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:62656 (61.1 KiB)

wlan0-1 Link encap:Ethernet HWaddr 02:C0:CA:8D:92:9E

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1835 errors:0 dropped:0 overruns:0 frame:0

TX packets:2223 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:333853 (326.0 KiB) TX bytes:1179564 (1.1 MiB)

wlan1 Link encap:Ethernet HWaddr 00:C0:CA:8D:C2:4E

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@Pineapple:~#

Reporting Log

Share this post


Link to post
Share on other sites

It looks as though my Nano just lapsed into the very same condition. Just today recon will start, register 100%, and then freeze indefinitely. I've reset the Nano to factory default to no avail. When I get home I will try to reload the firmware. Also, I took some current measurements in different states before it started behaving in this manner. I'll check those numbers vs what it draws now to see if it's potentially a hardware issue.

Judging from past posts this seems to be a reoccurring problem. If I see a solution or a cause, I'll report back.

Share this post


Link to post
Share on other sites

Miracle of miracles, something fixed itself. Recon is working again. From the time of my last post, here is everything I did. I don't know what fixed it.

1. After a factory reset, I restarted the nano and recon was still not working. It would hang at 100%. I tried directly connected with a laptop and through wireless management.

2. I took the Nano apart to smell and see if any component had fried. Everything looked good. (As a side note the board says "MKV nono Rev8")

3. I booted the board without the case and without the memory card. Recon still did not work through the wireless management. Shut the Nano down and left it for several hours.

4. Replaced the memory card and rebooted this time with my android phone tethered to the Nano.

5. Checked for a firmware upgrade (there wasn't one).

6. Noticed that when I selected Modules from the menu, none of my modules were present. I clicked manage modules. They were all listed. Went to the dashboard. Looked at the menu again and then all my modules appeared under the Modules heading.

7. Ran Recon and everything worked.

I have tried to think about the last action I took before Recon stopped working. I think I had just tried to install the dependencies for the tcpdump module. After I installed them, I got an error when I tried to turn tcpdump on. It was late so I left it alone. I have no idea if this would affect Recon. If anyone else is still having this problem, I'd love to hear how you got it in that state and if you found a solution. Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...