Jump to content
StevenH1901

Pineapple and Login/Password Wi-Fi

Recommended Posts

I just got my WiFi Pineapple Nano a few days ago, and have been trouble getting it connected to the internet.

The WiFi AP I'm trying to get it to connect to is secured via WPA2 Enterprise. You have to use a username and password to login to the network. My laptop is connected successfully, and I have shared the network connection to the Pineapple, but it still wont connect.

Routing Table attached.

post-53280-0-44364500-1458507077_thumb.p

Share this post


Link to post
Share on other sites

I've had this problem too. Funny thing is...I did get it to work for a little bit. I have no clue so I use wlan2 or android to connect works well.

Share this post


Link to post
Share on other sites

Does the Pineapple have to connect to the same network that others are connected to? I think I'm misunderstanding how the Pineapple works.

My understanding is that a Client connects to an AP that's being filtered through the Pineapple and the Pineapple sends the Clients traffic to whatever AP the pineapple is connected to.

Share this post


Link to post
Share on other sites

This could be the work of a IDS (Intrusion Detection System). It is possible the AP on the nano is identified as an unauthorized Access Point

Share this post


Link to post
Share on other sites

I had similar problem with connecting to WPA pesronal AP.

The problem is that the configuration is not written correctlyat /etc/config/wireless.

For example I had to manually add the option encryption value for WPA at the mentioned file.

The value that you should add can be found at the following https://wiki.openwrt.org/doc/uci/wireless under the WPA Modes section

E.g my configuratioon after the manual add loooked like this

config wifi-iface
option device 'radio2'
option ifname 'wlan2'
option mode 'sta'
option ssid 'XXXXXXX'
option network 'wan'
option key 'XXXXXXXXXXX'
option encryption 'psk-mixed+tkip+ccmp' <----------------Manually added this
To check if you can connect do not use the Connect but from the Client Mode again becuase it will mess the file.
Try to restart the network service by typing to the ssh prompt /etc/init.d/network restart
If it connects succesfuly then at the Nerworking tab at the web panel (try refreshing) you will be able to see the obtained IP. Otherwise you can check with the ifconfig command at the command prompt.

Share this post


Link to post
Share on other sites

I'm very foggy on the lingo for this stuff, so it's difficult for me to ask the question properly.

I can't seem to figure out how to connect client mode to an (infrastructure?) network. It seems the management interface on 1471 only lets you connect to open, WEP, or WPA networks with pre shared keys. I'm trying to connect to a WPA network with PEAP login/password requirement (I have an account at this place in questions).

In gui linux, I can use the network manager to select the network and it prompts me for login/pass, but since the NANO is only command line (ssh) or web interface, I can't seem to get this accomplished.

Thanks in advance,

-Luc

Share this post


Link to post
Share on other sites

I guess no one knows - I feel like it's a regular thing to do. Every laptop and phone I've ever used can authenticate on those types of networks, but the nano can't (or at least I can't make it do it).

Share this post


Link to post
Share on other sites

Here is what my /etc/NetworkManager/system-connections/. looks like for my linux laptop for this network - is this any help?

[ipv6]
method=auto
[connection]
id=<the SSID>
uuid=7bfxxx....xxxxdf
type=802-11-wireless
[802-11-wireless]
ssid=<the ssid>
mode=infrastructure
mac-address=4C:DE:AD:BE:EF:6B
security=802-11-wireless-security
[802-1x]
eap=peap;
identity=<the user ID>
phase2-auth=mschapv2
password-flags=1
[ipv4]
method=auto
[802-11-wireless-security]
key-mgmt=wpa-eap
auth-alg=open

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...