Jump to content

RTL SDR Not Working in Win 7


Recommended Posts

I have been using HDSDR with a Lenovo ThinkPad W510 Laptop and a RTL2832/R820T DVB-T+DAB+FM DV3 USB2.0 for over 2 years on top of XP Pro 32B SP3 with no issues ... I recently did a fresh install of Win 7 Pro SP1 on this machine which is certified and originally delivered with W7 Pro 64b, but cannot get any SDR software to recognize/find the RTL Device in Win 7 ... I rebooted this machine today in XP and proved that the RTL device is still working properly (HDSDR 2.7)

So basically, for some reason, I cannot get any of the latest versions of 3 SDR programs; SD#, HDSDR or SD-RADIO to find this RTL device in Windows 7 Pro 64b SP1

I downloaded all the Software and details from Zadig, SD#, HDSDR, and SD-RADIO sites, sifted through numerous links on this topic to no avail.

After initially inserting the RTL device, Windows 7 fails to install drivers (which was expected) ... downloaded and installed the latest WinUsb (v6.1.7600.16385) driver using Zadig 2.2.689 ... Windows 7 indicates the device has been installed correctly.

Laptop has 2 USB 2.0 ports and both are returning the same results

Results:
- SD# says it cannot find a RTL DEVICE
- HDSDR 2.7 with ExtIO_RTL2832.dll cannot find a RTL DEVICE
- SDR-RADIO with RTLUSB-20130209 cannot find a RTL DEVICE
- rtl-sdr both the 32 and 64 bit versions of rtl_test return NO DEVICE

Some observations between W7 and XP
- W7 has 2 Bulk-In Device entries ... XP has none
- W7 has 2 USB Composite Devices ... XP has 1 USB Composite Device
- in W7 the Zadig instructions say to install the driver on the Bulk-in 0 Device ... in XP this driver appears to be attached to the Composite Device
- both W7 and XP appear to be using the same revision of WinUsb v6.1.7600.16385

I have deleted ALL Composite and Bulk-in devices several times for both 2.0 USB ports and reinstalled the Bulk-in 0 device with no difference

Just ran USBDeview.exe version 2.55 ... it is reporting that Bulk-In 0 is not connected (confusing as Zadig wants the WinUSB driver installed on this device) ... Bulk-In 1 is connected and Composite device name is RTL2838UHIDIR

Any suggestions would be greatly appreciated

Link to comment
Share on other sites

Solved!!!

I was mistakenly attempting to use USB 3.0 ports ... moving the RTL Device to a USB 2.0 Port solved the problem

The W510 Laptop has 4 USB ports; 2 Intel USB 2.0 Ports and 2 NEC USB 3.0 Ports ... in XP, the RTL device worked fine from these same ports ... so somehow thought that these ports were USB 2.0 until I reviewed my user manual

While I have read some posts suggesting that USB 3.0 ports do work in Windows 7, it appears that for the Lenovo W510, WinUsb (v6.1.7600.16385) doesn't work with the supplied NEC USB 3.0 ports.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...