Jump to content

Recommended Posts

On 1/23/2019 at 5:27 PM, Jair said:

HI,

I have a problem with EP on my nano.

After reset it by press reset button 10 seconds, I got clean 2.4.2 FW. 

Then I only installed EvilPortal modules on internal system and Create a new Basic portal.

Activate that poral and start EP.

No matter how I restart open SSID ap, I can only connect to open ssid without popup any windows. The network connection is good. Seems EP can not redirect my portal request.

I can see redirect rule already in iptables.

DNAT       tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:80 to:172.16.42.1:80

My Tetra is working fine. 

Is your nano connected to the internet?

I've same issue like you and I though it's because my nano was broken somehow. But it solved after it's connected to the internet

Share this post


Link to post
Share on other sites

Hello, I have the issue that I use a macbook pro to configure the Nano. This means that, to be able to user internet sharing, I needed to change the IP of the nano to an other range.

As the IP is changed to 192168.2.10 Evil portal won't work anymore, and as stated some months ago, breaks the EP.

Is there a way to work around this and make EP listen on IP 192.168.2.10?

Thx a lot...

Chest...

Share this post


Link to post
Share on other sites

I managed to find includes/evilportal.sh where the iptables are defined.

I changed all ip's to the new range 192.168.2.x like this:

iptables -t nat -A PREROUTING -s 192.168.2.0/24 -p tcp --dport 80 -j DNAT --to-destination 192.168.1.10:80

as 192.168.1.10 is the actual IP of the pineapple but is seems not enough...

Share this post


Link to post
Share on other sites

i had this working for ages and then ran an update on my pineapple, now i can create and launch the EP see the SSID but every device is unable to connect? this boots me off to another Wi-Fi. ive removed the SD card and used internal incase the card was corrupt but still nothing.

 

im unsure of the version but just re-installed from GH and again same isssue

Share this post


Link to post
Share on other sites

Alright, I don't know if it was already resolved or anything, but redirection to internal page doesn't work. I know https redirection is still on todo list, but how about redirecting to another .php or .html stored on nano? Is that even possible?

Share this post


Link to post
Share on other sites
On 4/22/2019 at 10:17 AM, simoncfc said:

i had this working for ages and then ran an update on my pineapple, now i can create and launch the EP see the SSID but every device is unable to connect? this boots me off to another Wi-Fi. ive removed the SD card and used internal incase the card was corrupt but still nothing.

 

im unsure of the version but just re-installed from GH and again same isssue

Check your filtering options

Share this post


Link to post
Share on other sites

thanks did that and still didnt work. but will keep looking

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hey guys,

I have an issue with EP  (currently using 3.2)

When leaving EP on for a while 15 - 20 min or so, my portals no longer need to sign in.   The connection status goes from "sign in required" to "connected" without having to enter creds.

The portals I am using have always worked in the past.

Before posting, I downgraded the firmware, re-installed previous versions of EP but i still have the same issue. 

Anyone else having this problem?

 

Cheers!

 

-----

 

forget it,  I solved my problem.  This issue was the source of my internet for some reason.

thx anyway!!

Edited by cheeto

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...