Jump to content

Turtle configuration


kanalia
 Share

Recommended Posts

Hi Chaps

I posted this question before but I am going to go into details a bit more this time. This is the current config of the device:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fda4:1103:3ec4::/48'
config interface 'lan'
option ifname 'eth0'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '172.16.84.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option ifname 'eth1'
option macaddr '00:e0:4c:36:1c:12'
option proto 'dhcp'
config interface 'vpn'
option ifname 'tun0'
option proto 'dhcp'
config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
As you can see the Ethernet end is configured to be served an IP by DHCP, the host will be allocated an IP in 172.16.84.* range and then both networks are bridged. In domain environment I can access the internet but I am not on domain any more which makes Turtle useless in this case. So the question is - is it possible to have 'lan' on the same network as 'wan'?
Regards, kanalia

post-53156-0-94877500-1457602086_thumb.j

Link to comment
Share on other sites

Hi Chaps

I have figured it out myself. Simply go to etc/config/network and change the config for 'lan' to:

config interface 'lan'
option ifname 'eth0 eth1'
option type 'bridge'
option proto 'dhcp'
This bridge will make both adapters visible to target network so both adapters will be allocated an IP by DHCP. Have fun!!
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...