Jump to content

Nano AP & Client scan Stopped Working

Kapu Lanai

Recommended Posts

Last night I booted up the nano fine and did an ap/client scan for 1 minute on continuous. It produced great results. Then after trying to deauth a client on my network to the pineapple. Ap/client scan stopped producing data. Only AP scan works.

I had two tabs running. One for recon. Another was to set settings for PineAP.

Now I've factory reset. Twice. And still the same problem. Is this something that a manual flashing would fix?

Any help would be greatly appreciated. Thanks.

Edited by Kapu Lanai
  • Upvote 1
Link to comment
Share on other sites

Ap/client scan stopped producing data. Only AP scan works.

I had the same issue, there may be a better fix out there but I fixed it in ~15 minutes by doing a firmware recovery, the how-to guide is here: https://www.wifipineapple.com/pages/faq


Begin by downloading the factory firmware image for your device.

  • WiFi Pineapple NANO Factory Firmware Image - SHA256: 58b2401b790b484532351cfef3988e6d839682ae853bdb879c45f2e03e42c29e
  • Unplug the WiFi Pineapple completely from all power sources.
  • Press and hold the Reset button on the bottom of the Pineapple
  • Plug in the pineapple to your computer using the USB Y-cable
  • Keep holding the reset button for 10 seconds at least then release
  • The blue LED should remain solid (didn't for me)
  • Go to the adapter settings in network
  • (Windows 10)
  • Connection Icon in the bottom right
  • Network settings
  • Ethernet tab
  • Change adapter settings
  • Right click the Ethernet connection to the Pineapple and click properties
  • Click internet protocol version 4 and click properties
  • Click the "use this IP address radio button and set the IP address to
  • Set the subnet mask to then click okay
  • From your browser type the URL bar and press enter
  • Click Choose File and select the factory firmware image (This may happen automatically)
  • Click Update Firmware
  • This process can take several minutes, when I did this update there was no redirect after the update had finished so I left it to run for ~15 minutes to be safe however the Pineapple will restart after the update is complete so keep an eye on it.
  • Reset the the WiFi Pineapple Ethernet interface back to with submask

hope this helps,

if you or anyone else wants to learn more about the pineapple feel free to PM me, I'm fairly new to this and am looking for others that want to get up to speed on this kit with me.

  • Upvote 1
Link to comment
Share on other sites

so you wanna say installing the firmware newly will help more than just reset all setting to initially firmware?!?

I expect the factory reset (to latest firmware settings) to be a new installation of the stored firmware.

Maybe Seb can clarify...

Link to comment
Share on other sites

Thanks for the input. I'm thinking my pinapple was underpowered from a wall plug. I added a USB range extender for the wlan2 dongle. I'm betting my plug didn't have quite enough power to do all it was asked. Even though I factory reset, plugging into my USB y cable from PC seemed to do the trick.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...