Jump to content
Hak5 Forums

Recommended Posts

I just updated the DWall module to work with firmware version 2.0.0+. 

Simply update the module via the Module Manager. 

  • Like 2

Share this post


Link to post
Share on other sites

Hey guys the version of dwall didn't work with the actually nano version? sometimes work but than stop after a second or two. Its possible to downgrade the newest nano version to got it running? or maybe you guys have another solution?

 

Share this post


Link to post
Share on other sites
Posted (edited)

Just tried Dwall on my nano using v1.2. For me it wouldn't do anything from the GUI at all.

I was  getting  /pineapple/modules/DWall/assets/http_sniffer: can't load library 'libpcap.so.1.3'

the module created the libpcap link so not sure what was going on.

To fix it i deleted the link and remade it.

To delete

rm  /usr/lib/libpcap.so.1.3

To re-add

ln -s /usr/lib/libpcap.so.1 /usr/lib/libpcap.so.1.3

 Maybe this helps others. Maybe not :)

 

 

 

Edited by Just_a_User

Share this post


Link to post
Share on other sites
11 hours ago, Just_a_User said:

Just tried Dwall on my nano using v1.2. For me it wouldn't do anything from the GUI at all.

I was  getting  /pineapple/modules/DWall/assets/http_sniffer: can't load library 'libpcap.so.1.3'

the module created the libpcap link so not sure what was going on.

To fix it i deleted the link and remade it.

To delete


rm  /usr/lib/libpcap.so.1.3

To re-add


ln -s /usr/lib/libpcap.so.1 /usr/lib/libpcap.so.1.3

 Maybe this helps others. Maybe not :)

 

 

 

The issue is that sub 2.0.0 firmwares have a different libpcap filename. 

I don't usually support older firmware versions, but I can quickly roll that fix in. 

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, Sebkinne said:

I don't usually support older firmware versions,

Just to clarify it was firmware v2.0.2 & Dwall v1.2 on the nano. Or do i mis understand something?

Edited by Just_a_User

Share this post


Link to post
Share on other sites
20 minutes ago, Just_a_User said:

Just to clarify it was firmware v2.0.2 & Dwall v1.2 on the nano. Or do i mis understand something?

Oh wait, that's odd. I'll look at it when I get back from my holiday. 

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, Sebkinne said:

Oh wait, that's odd. I'll look at it when I get back from my holiday. 

Forget it, i think its something thats happening with the upgrade from 1.1.3 to 2.0.2. If I use a 2..0.2 factory flash file it works well. If I use the 1.1.3 and upgrade I seem to get issues again, especially if i update libpcap manually on 1.1.3.

Best to do a firmware recovery using the latest factory firmware rather than upgrade from old version I think.

As you were, and enjoy the break!

Edited by Just_a_User

Share this post


Link to post
Share on other sites
6 hours ago, Just_a_User said:

Forget it, i think its something thats happening with the upgrade from 1.1.3 to 2.0.2. If I use a 2..0.2 factory flash file it works well. If I use the 1.1.3 and upgrade I seem to get issues again, especially if i update libpcap manually on 1.1.3.

Best to do a firmware recovery using the latest factory firmware rather than upgrade from old version I think.

As you were, and enjoy the break!

Firmware upgrades completely wipe out your system, so this should not be the case. I'll take a look. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×