Jump to content

DD WRT Port Forwarding Issue


Rainman_34
 Share

Recommended Posts

So I flashed my D-Link router with the DD WRT firmware because lets face it D-Link anything is unsecure. In the past I have been able to get it to forward ports to my server. However that was about two years ago and I am getting back into the network security realm and want to have my home server setup again. I am currently just trying to forward ports to my VPN server and it is not working. In the router I setup the following.

Service I give it's own unique name so it is not seen but lets call the first one Mine1. Then I give the port type TCP. Then I give the source port 943. Then I give the source IP and since I will never know my outside IP I give it 0.0.0.0/0. Then I give the destination port of 943 and finish with the destination ip of 192.168.1.132. I click enable and save the changes, apply settings and reboot my router. Then when I try to connect the connection is denied. I do an nmap scan of my router and these ports appear closed on the router. When I attempt the connection directly to the .132 address it works just fine so I know the ports are open on the server.

I have also gone into the router and attempted to change iptables which also does not work. Any help with this would be greatly appreciated. Without port forwarding the home server really doesn't do any good. Thanks again for any help provided.

Link to comment
Share on other sites

...

Then I give the source IP and since I will never know my outside IP I give it 0.0.0.0/0. Then I give the destination port of 943 and finish with the destination ip of 192.168.1.132.

I thought there was only 1 IP address on the screen (destination). Maybe a different version of DD-WRT has source and destination. What version are you using?

Link to comment
Share on other sites

That was me that was rambling on about which page you were on...then I realized I was talking about an old version (I haven't used DD-WRT in a while) and so I deleted the post an replaced it with a more generic version :)

I'm 99% sure that I have set up port forwarding in DD-WRT in the past without touching IPTables (it probably does that "under the hood" for you). It might be that entering the stuff additionally in there is messing you up. Try it without the IPTables entries.

Link to comment
Share on other sites

I have tried leaving source net blank and without doing the iptables. When I get home I will post a picture of how I have it setup right now with the version of dd wrt I have. I know in the past all I did was put in the ports and destination IP and it worked fine. I may try my netgear to ensure it is the router

Link to comment
Share on other sites

Attached is a picture of my port forwarding page. As far as the version goes all I can find is v24 sp2 for a D-Link DIR-615 E3 from march 2013 which is the latest version for my router. Also for port 943 that has been /0 before. I just input it wrong when I was changing it back after some other attempts.

post-52597-0-57114300-1457043395_thumb.p

Edited by mojo0243
Link to comment
Share on other sites

Just using a router and its not opening the ports for some reason. Wven staying inside the network and using the router ip i cant reach the .132 address but if I connect directly to the .132 it connects so I know the ports are open on the server just not the router.

Edited by mojo0243
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...