Jump to content

Stuck on "detecting wifi pineapple"


Go to solution Solved by xcureanddisease,

Recommended Posts

Nevermind. I figured it out. Not sure if its SUPPOSED to be this way but I load up wp6.sh and when it says CONNECTING... I pressed the little button on the back twice, and it worked that way.

Do you mean the rest button? That will just reboot your device. Interesting that that allowed your computer to figure out the routes.

Best Regards,

Sebkinne

Link to post
Share on other sites

Do you mean the rest button? That will just reboot your device. Interesting that that allowed your computer to figure out the routes.

Best Regards,

Sebkinne

This is the button I pushed twice : sAErMF5.jpg

So I setup the Tetra using the guide, then I downloaded all the modules by connecting it to my router via ethernet, then I tried to do internet sharing, So I disconnected the Tetra from my router, I went through the RECOMMENDED setup and when that was done, I tried to CONNECT and it got stuck there. I waited about 15 minutes before I pressed that button(out of curiosity) and about 45 or so seconds later it connected.

Edited by xcureanddisease
Link to post
Share on other sites

It is because the pineapple does not respond to ping ( perhaps iptables blocking it ) a quick fix is to get your pineapples MAC address and

alter the wp6.sh script (https://www.wifipineapple.com/tetra/scripts/wp6.sh ) from :

...

printf "Detecting WiFi Pineapple..."
until ping $spineappleip -c1 -w1 >/dev/null
do
...
to:
...
printf "Detecting WiFi Pineapple..."
until arp -a|grep -c "00:13:37:xx:xx:xx" > /dev/null
do
...
# Where the xx:xx:xx is alignet to your pineapples macaddress..
Edited by Thermostaten
Link to post
Share on other sites
  • 3 years later...

Just in case this helps anyone on Kali2 when running the wp6.sh script. It appears that the script tries to add the 'ip route', but for me it never did. So I went in and added the route manually: 'sudo ip route add 172.16.42.0/24 dev eth2'. Eth2 was the eth port my pineapple connected on when plugging in the micro USB. I then re-ran the script using the 'C' option (you may need to run the guided first) and then everything worked.

You can also check your routes by running: 'ip route' You should have something like this: '172.16.42.0/24 dev eth2 scope link'

Edited by rylore
Link to post
Share on other sites
  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...