Jump to content
Whistle Master

General TETRA Discussion

Recommended Posts

So playing around with the Tetra tonight I noticed some things:

1. I only see the two wlan interfaces (wlan0, wlan0-1, and wlan1), but I noticed when I scan for networks with wlan1 it shows my 5ghz networks. So that got me wondering how all of the 5ghz stuff is setup and how it works with regards to PineAP as well as the other modules.

Recieved my tetras today and just had a quick look. Since the Tetra has 2 dualband radios is was expecting to see either wlan0 and wlan 1, or wlan0 wlan0-1 , wlan1 and wlan1-1. As posted by bored369 im getting 3 logical devices.

Can someone help me out,

- why im getting 3 adapters, wlon0, 0-1 and 1 for 4 radios?

- what adapter corresponds to what radio / band?

- is there a schematic what physical antenna sma connector leads to wich adapter?

Wille im at it: looking at recon mode it would be great it client/ap macs would have a vendor lookup and display it!

Last: i recieved 4 tetras, none had the instruction card wich is listed. I dont think i need it, but maybe check with your supplier?

Ps. Recieved everything in order within 44 hours! Awesome! thanks guys

Edited by Smarty
  • Upvote 1

Share this post


Link to post
Share on other sites

Recieved my tetras today and just had a quick look. Since the Tetra has 2 dualband radios is was expecting to see either wlan0 and wlan 1, or wlan0 wlan0-1 , wlan1 and wlan1-1. As posted by bored369 im getting 3 logical devices.

Can someone help me out,

- why im getting 3 adapters, wlon0, 0-1 and 1 for 4 radios?

- what adapter corresponds to what radio / band?

- is there a schematic what physical antenna sma connector leads to wich adapter?

Wille im at it: looking at recon mode it would be great it client/ap macs would have a vendor lookup and display it!

Last: i recieved 4 tetras, none had the instruction card wich is listed. I dont think i need it, but maybe check with your supplier?

Ps. Recieved everything in order within 44 hours! Awesome! thanks guys

re: Wille im at it: looking at recon mode it would be great it client/ap macs would have a vendor lookup and display it!

+1 and if we could add a way to keep that in a log so that we can go from screen to screen with the info we collected.

Share this post


Link to post
Share on other sites

Recieved my tetras today and just had a quick look. Since the Tetra has 2 dualband radios is was expecting to see either wlan0 and wlan 1, or wlan0 wlan0-1 , wlan1 and wlan1-1. As posted by bored369 im getting 3 logical devices.

Can someone help me out,

- why im getting 3 adapters, wlon0, 0-1 and 1 for 4 radios?

I figured it's the same setup as the pineapple nano, just with 5ghz and dualband on each wlan. So wlan0 is the broadcasting, wlan0-1 is the management ap virtual adapter, and wlan1 is the injector/sniffer.

That's about all I know, would be nice to know which side is which though.

  • Upvote 1

Share this post


Link to post
Share on other sites

I figured it's the same setup as the pineapple nano, just with 5ghz and dualband on each wlan. So wlan0 is the broadcasting, wlan0-1 is the management ap virtual adapter, and wlan1 is the injector/sniffer.

That's about all I know, would be nice to know which side is which though.

Nice to know that's how that works.

Share this post


Link to post
Share on other sites

Im not using the Tetra in the classical way :D. I want to interface with the radio's directly using small bash scripts etc. So for me its important to know what wireless interface corresponds with each radio. Also when i want to change my antenna configuration its important to know what interface leads to what antenna connector.

So for me its still unclear why i get 3 interfaces... and what wire goes where...?!

Firts attempt to getting my LTE dongle to work the Tetra died... :( Seems i also got the 1A walladapters... :( Should i contact aftersales for this?

Share this post


Link to post
Share on other sites

When i start wlan0 and wlan1 in monitor mode i can have both wlan0mon and wlan1mo scanning the 2.4ghz and 5ghz band. Thats good enough for me.

IM assuming that both the atheros radios have a seprate antenna connector for 2.5 and 5 ghz.

Could someone help me out to what adapter (0 or 1) each sma connector leads to and to what frequency its attended for?

Edited by Smarty

Share this post


Link to post
Share on other sites

Smarty -

With the front (LED side) of the WiFi Pineapple TETRA facing you, the two antennas on the left are wlan0 and the two on the right are wlan1. Another way to put look at it is that the two wlan0 antennas are closest to the RJ45 Ethernet port while the two wlan1 antennas are closest to the Reset button. Both radios are in a diversity configuration by default and ship with dual-band antennas.

Also it sounds like your power issue is related to the extra draw of the LTE modem. The upgraded PSU will fix that. You'll be receiving an email shortly if you haven't already.

Cheers,

Darren

  • Upvote 1

Share this post


Link to post
Share on other sites

In the Status module which will be soon available I have a vendor lookup for MAC address for clients connected to the pineapple. Same for the SiteSurvey module I'm building right now, there is the vendor lookup for APs.

re: Wille im at it: looking at recon mode it would be great it client/ap macs would have a vendor lookup and display it!

+1 and if we could add a way to keep that in a log so that we can go from screen to screen with the info we collected.

Share this post


Link to post
Share on other sites

Smarty -

With the front (LED side) of the WiFi Pineapple TETRA facing you, the two antennas on the left are wlan0 and the two on the right are wlan1. Another way to put look at it is that the two wlan0 antennas are closest to the RJ45 Ethernet port while the two wlan1 antennas are closest to the Reset button. Both radios are in a diversity configuration by default and ship with dual-band antennas.

Cheers,

Darren

Thanks! Thats all i wanted to know :) Ill be on the look out for your email. Edited by Smarty

Share this post


Link to post
Share on other sites

I've had my Tetra for a bit and after a few hiccups (operator error) I have been able to work my way through the set up. I have PineAP harvesting and broadcasting SSIDs but clients can't seem to connect to the Tetra. I've tried Windows 10 and 8, Linux, Android, OS X and iOS clients and while the devices can see the rogue networks they can't connect to them. Any help would be appreciated.

  • Upvote 1

Share this post


Link to post
Share on other sites

Smarty -

With the front (LED side) of the WiFi Pineapple TETRA facing you, the two antennas on the left are wlan0 and the two on the right are wlan1. Another way to put look at it is that the two wlan0 antennas are closest to the RJ45 Ethernet port while the two wlan1 antennas are closest to the Reset button. Both radios are in a diversity configuration by default and ship with dual-band antennas.

Also it sounds like your power issue is related to the extra draw of the LTE modem. The upgraded PSU will fix that. You'll be receiving an email shortly if you haven't already.

Cheers,

Darren

Was having similar power issues. DHL just delivered the extra PSU. USA plug type :D but I can live with that. I'm in the UK but couldn't wait for the EU shop to have the TETRA in stock. So I can't complain :P

Plus, it came with a super awsome wifipinapple logo sticker.

Thanks Darren

+1

Share this post


Link to post
Share on other sites

I've had my Tetra for a bit and after a few hiccups (operator error) I have been able to work my way through the set up. I have PineAP harvesting and broadcasting SSIDs but clients can't seem to connect to the Tetra. I've tried Windows 10 and 8, Linux, Android, OS X and iOS clients and while the devices can see the rogue networks they can't connect to them. Any help would be appreciated.

I am seeing exactly the same too. I have been playing all weekend but cannot get past the failing of targets to associate. If i manually associate i can get modules to work.

I have tried various kinds of deauth etc too but just like Denningsrogue i cannot ever get targets to associate with the tetra.

Any help greatly appreciated Seb/Darren, unless Denningsrogue managed to solve the issue?

I am using a 12v 1.5A supply as well as 2*usb3 through the eth0 port.

As a future suggestion, It would be great for the EU customers if you could switch to a power adapter where you can change the input plug type.

Share this post


Link to post
Share on other sites

Hi,

I am seeing the same thing also - Running 1.0.2 Firmware, have SSID pool being broadcast with SSID filter enabled and MAC address filter disabled as I want everyone connecting to a particular SSID.

My Dash says 1 SSID in pool but no clients.

Share this post


Link to post
Share on other sites

I just received my Tetra, delivered with a 2A power supply - it booted up and updated just fine via an Android link to a Nexus 6 phone on the Fi network - no problems at all. The interface is very clean, I think I'm going to like this. If all is well in a week or so I'll put my old Mk 5 up for sale.

Share this post


Link to post
Share on other sites

Hello all long time no postie. Have been away for abot but have noticed in my absence the Hak5 crew has turned out a few new pineapples so thought il pop my big head back in and see what the fuss is about :)

Long story short I started with a wifi pineapple before I even took my first kali course so without the pineapple my pen testing days wouldn't have even have started so props for that, only thing is all my work is mainly done via Kali/metasploit and yeah the mark v was great but for me mainly it was just a mitm box everything else was Kali or metasploit. So am wondering other than the spec of the new devices what will make me spend nearly $400 on both devices and will I be able to do more than mitm attacks?

Will it in some time incorporate metasploit as tbh if the pineapple and metasploit had a night of passion the off spring would be amazing!!

Any thoughts and opinions would be great as it's either this or a new drone ;)

Share this post


Link to post
Share on other sites

Tonight I had the opportunity to deploy the Tetra during a fun event. I'll be making a video about it this weekend. In a very nerdy way, it was absurdly fun because of this:

pineappleresults-e1463624014463.jpg

Turns out to be 18.5 SSIDs per minute. Just kinda made me giggle.

  • Upvote 3

Share this post


Link to post
Share on other sites

Hello everyone just got my new Pineapple TETRA today very happy with it so far ive been playing with alot of the tools so far with it or Modules but wanted to ask everyone what are there most used/must have modules on the manager page.

Share this post


Link to post
Share on other sites
1 hour ago, dverrazano said:

Will Tetra ever be available again?  Can't even pre-order now.  What gives?

 

 

It's just out of stock. It'll be back in Stock soon.

Share this post


Link to post
Share on other sites

Hi Everybody!

Pls help me! I have a Tetra and i forgot my password! :( I know, this is a stupid thing! :)

What can i do???

Thx a lot!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...