Jump to content

Recommended Posts

Did not see the download link for 1.0.6 any info where it's located checked wifi pineapple.com but only showing 1.0.5 for download

Share this post


Link to post
Share on other sites

Hi,

I was wondering if there is a way to view PineAP log files in Maltego....or if this could be done?

Thanks!

  • Upvote 1

Share this post


Link to post
Share on other sites

After having played with my new Nano for some days, it seems to be working - at least to start with - and at least without having started any modules.

But after a while (say one hour) it looses connectivity.

The registered "clients" then have no WiFi connectivity. I.e. they are no longer connected through the WiFi Pineapple.

If I then connect a new Client to the WiFi Pineapple, it is detected and listed as a new "client", but it does not have any WiFi connectivity.

The Android App also seem to be an a Beta stage (?)

As to modules - I have posted some comments on some of them - NONE of them seem to be working properly. :-(

Skib

Share this post


Link to post
Share on other sites

Hey guys,

I am no expert, but I am trying to learn. I just recieved my nano and everything is working. However, I installed kali linux 2016 in vmware workstation on windows 8.1 and I used the wp6 script and got it all working as well, but I am confused about my internet connection options and cracking wireless networks on wpa/wp2. Right now, the computer I am using is connected to my router by ethernet, and I have the wifi pinnaple nano plugged in, but can I not use wlan0 or monitor mode to do injection?

Share this post


Link to post
Share on other sites

that should help, watch the wifi pineapple academy videos and they will help out a lot and with some common knowledge the Mark5 mondule vidoes should be similiar to some of the Mark6 modules.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi everyone, ID just like to say the pineapple nano is awesome, I am a total noob to all of this, 12 month ago I hadn't heard of Kali linux, WiFi pineapple or any of this,someone told me to take a look at Kali,I liked what I was reading,so I decided to start with pentesting my WiFi network,then friends and family, a few successes and a lot of fails, reading up more and came across the WiFi pineapple mark v(but was out of stock),so read a lot of things about it and what you can do with it,I like the idea/concept, so with a lot more fails and only a couple of successfull network tests,I was going to build a 3gpu cluster for the hashes,then decided,fck it I'm just going to get a pineapple, ID heard the nano had came out,looking on the site and there in stock, what do I get the nano or the tactical nano? The tactical of course :-D I like the idea/concept IL help support the developers,and the sticker looks good on my car ;-) .now I am a total noob,12 month ago I didn't know a thing,and my knowledge is very limited, I had a couple of small problems getting the nano set up and running, I had to factory reset it 3 times and ask for help about SSH (stupid dumb...the password doesn't show as typing,but is still being entered.). Other than that,the nano has been totally noob friendly,anything I couldn't do,I research it, I haven't had any real problems,it runs good,IV had clients connected with Internet access,it's done everything IV wanted it to upto now, I just need to learn more,I need to learn how to do a landing page, but I just jumped in feet 1st with very limited knowledge and have found the WiFi pineapple nano awsome. Thankyou

  • Upvote 1

Share this post


Link to post
Share on other sites

@Freaky Nightmare

I promise no one is as green as I am. Quick question...how did you factory reset the nano (told you). Press & hold the reset button I presume. Im working the nano on my Android device and it says 'Waiting for connection' and will never connect. I tried connecting through NetHunter and it still cannot connect.

Any suggestions...anyone?

Share this post


Link to post
Share on other sites

When I click the pineapple app, it tells me to enable tethering, click it, enable tethering, it will load the pineapple login screen, enter your password and log in, it will load pineapple dashboard, scroll down a bit and click get notifacations, if it loads you've got internet access, if it doesn't, on my Nexus 5, in notifacations it says USB charging, click to change, select file transfer, then load the notifacations again on pineapple dashboard, they should load, I did have to restart my phone for the pineapple to get connected

  • Upvote 1

Share this post


Link to post
Share on other sites

Hey guys,

Any idea if the next firmware update will have mobile broadband support? (like the mkv)

This would be a huge plus for users that are unable to tether their Nano with an Android device.

I'd really like to use my usb dongle with Nano.

cheers

Share this post


Link to post
Share on other sites

Hey Quick question? Where did Hak5 come up with the IP for the Pineapples? just curious

Share this post


Link to post
Share on other sites

Yes keep hold of the reset button for 6 seconds, are you using the pineapple app from play store?

Yes sir I am. I also have the Pineapple connector in NetHunter on my Nexus6 device but I have yet to figure that out as I am still battling through this. Thank you so much for the reply.

Share this post


Link to post
Share on other sites

When I click the pineapple app, it tells me to enable tethering, click it, enable tethering, it will load the pineapple login screen, enter your password and log in, it will load pineapple dashboard, scroll down a bit and click get notifacations, if it loads you've got internet access, if it doesn't, on my Nexus 5, in notifacations it says USB charging, click to change, select file transfer, then load the notifacations again on pineapple dashboard, they should load, I did have to restart my phone for the pineapple to get connected

First of all thank you once again...this is the furthest Ive gotten thanks to your advice...here are the steps I went through in order before I got it up and running.

Nano had no internet connection. It did before when I tinkered with it so I think I screwed it up. The app is successfully downloaded, I enabled tethering, ensured file transfer is enabled on my Nexus, and I still get the "waiting for connection" ...

Restarted the device with the nano connected to it ... same result

Restarted the device again with the nano connected to it ... and now the nano's pineapple server address comes up in the address bar on the screen and is attempting to load....and after a while it says "ERR_CONNECTION_TIMED_OUT"

Ensured that my Nexus device is on the network name I gave the nano...that didn't work...My Nexus connects but there is no internet now.

I will do a factory reset...

Ok...after the factory reset and a couple of restarts on my device it worked.

1. Here is what I learned. I had to be away from any networks that my device picks up in order for the nano to make a connection.

2. I also had to have a good clear view of the sky. In my room it was a 'no-go'. Out on the patio, which has a sheetmetal roof it was in and out. With a clear view of the sky it worked...bulletins did load.

Probably something that is a no brainer for you but it took me resetting it per your instructions along with some troubleshooting to get it right.

Again thank you...If I may ask...

What first nano tool would you recommend I use? How are you using that specific tool(s)?

Share this post


Link to post
Share on other sites

First of all thank you once again...this is the furthest Ive gotten thanks to your advice...here are the steps I went through in order before I got it up and running.

Nano had no internet connection. It did before when I tinkered with it so I think I screwed it up. The app is successfully downloaded, I enabled tethering, ensured file transfer is enabled on my Nexus, and I still get the "waiting for connection" ...

Restarted the device with the nano connected to it ... same result

Restarted the device again with the nano connected to it ... and now the nano's pineapple server address comes up in the address bar on the screen and is attempting to load....and after a while it says "ERR_CONNECTION_TIMED_OUT"

Ensured that my Nexus device is on the network name I gave the nano...that didn't work...My Nexus connects but there is no internet now.

I will do a factory reset...

Ok...after the factory reset and a couple of restarts on my device it worked.

1. Here is what I learned. I had to be away from any networks that my device picks up in order for the nano to make a connection.

2. I also had to have a good clear view of the sky. In my room it was a 'no-go'. Out on the patio, which has a sheetmetal roof it was in and out. With a clear view of the sky it worked...bulletins did load.

Probably something that is a no brainer for you but it took me resetting it per your instructions along with some troubleshooting to get it right.

Again thank you...If I may ask...

What first nano tool would you recommend I use? How are you using that specific tool(s)?

I am a noob, i knew little before buying the nano, im not sure what iv done, but clients no longer have internet access :-( , i may reset and start again. Its a learning curve,and iv got a hell of a lot to learn, and breaking things keeps it fun, as long as i can keep reseting its all good :-)

  • Upvote 1

Share this post


Link to post
Share on other sites

I am a noob, i knew little before buying the nano, im not sure what iv done, but clients no longer have internet access :-( , i may reset and start again. Its a learning curve,and iv got a hell of a lot to learn, and breaking things keeps it fun, as long as i can keep reseting its all good :-)

Cool ... I will do the same and share with you. Thanks again.

Share this post


Link to post
Share on other sites

My pineapple nano will not connect to my Linux VM. I know the port is working because it will read a thumb drive. When the interface asks me to connect the nano to the computer all I get is the infinite ........................

However my VM will read a thumb drive.

Any suggestions anyone :-) ?

Share this post


Link to post
Share on other sites

I have two questions for the knowledgable and willing. Ballparked, how involved would it be to create a module that tells you what programs you have running and what interfaces are being utilized by them?

The second question has to do with the titles of the tabs in chrome. I tend to have 3+ pineapple windows open when I'm piddling via chrome on an Iphone 6s and I bounce around often selecting the same page I'm done with at the moment. When The tab-selector/changer is selected, All I see is multiple tabs that say 'Wifi Pineapple..'. Kind of a hastle. If I were you I'd give me the middle finger and say Keep-practe but I'm throwing it out there to see if you (The developers/senior users) have seen it changed around or tried it before in some tester release? Keep up the grande work.

  • Upvote 2

Share this post


Link to post
Share on other sites

Hi guys,

Love my new nano! Here's a few questions:

- how can I change the management port from 1471 to something else?

- it would be insanely great if GUI access can be limited from a few IP's only

- Why does PineAP wifi network allow its client access to GUI as well as the actual management wifi network?

Cheers.

Share this post


Link to post
Share on other sites

hello want someone to help me or advise because I can not connect a USB client mode with ralink 5370 , recognizes my nano perfectly .

But I can not connect to my router which is 10 meters can not believe it impossible for me and come to think that has a manufacturing defect as it seems that not enough

power to linking with my router please, if you this happening the same and found the solution please help since it is rare that it can not connect in client mode

Thanks

 
 
but I can not connect to my router which is 10 meters can not believe it impossible for me and come to think that has a manufacturing defect as it seems that not enough

 

Share this post


Link to post
Share on other sites
On 5/27/2016 at 9:20 PM, mariolatino said:

hello want someone to help me or advise because I can not connect a USB client mode with ralink 5370 , recognizes my nano perfectly .

But I can not connect to my router which is 10 meters can not believe it impossible for me and come to think that has a manufacturing defect as it seems that not enough

power to linking with my router please, if you this happening the same and found the solution please help since it is rare that it can not connect in client mode

Thanks

 
 
but I can not connect to my router which is 10 meters can not believe it impossible for me and come to think that has a manufacturing defect as it seems that not enough

 

I'm having a slightly difficult time in understanding your issue. I am no NANO expert just yet, for clarity, maybe we can start narrowing down your issue

Are you saying that you cant get connected to your wifi router on WAN2 ? What dongle are you using ? Does WAN2 see the network when you perform a scan?

 

Share this post


Link to post
Share on other sites

hello I was trying to connect to my router to play a bit since discovered that can be used for client mode wlan2

but it has become impossible for me to connect to my router because it does not connect unless this winged it, this makes me think that my nano is the problem.

 

Share this post


Link to post
Share on other sites
1 hour ago, mariolatino said:

hello I was trying to connect to my router to play a bit since discovered that can be used for client mode wlan2

but it has become impossible for me to connect to my router because it does not connect unless this winged it, this makes me think that my nano is the problem.

 

A couple quick questions

1. What dongle \ adpater are you using in the USB port?

2. Does the nano detect the apadter correctly?

3. What version firmware are you running?

4. What you are in the Networking -> WiFi Client Mode settings, does the NANO detect a WAN2?

5. If so, does your home network get detected?

 

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, Captain said:

A couple quick questions

1. What dongle \ adpater are you using in the USB port?

2. Does the nano detect the apadter correctly?

3. What version firmware are you running?

4. What you are in the Networking -> WiFi Client Mode settings, does the NANO detect a WAN2?

5. If so, does your home network get detected?

 

Thanks

*WLAN2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...