Jump to content

Go to solution Solved by Darren Kitchen,

Recommended Posts

Hey Community,

I'm always have an wlan2 (nano-USB-adapter) plugged in the pineapple so I don't need a further device for internet connection.

(yeah, I know: one more adapter sucking energy)

BUT: Is there a way to keep the encryption passwords for the host networks saved? I mean, testing at home is fine, but when I move my position I always have to log in manually if my primary host is out of reach.

Any suggestions on how to automate the client mode connect on changing hosts?

Thanks.

Link to post
Share on other sites

I think you could manually edit the wireless config with the correct credentials. Although I'm not sure exactly as to how the network manager is configured on the NANO if it would work as desired.

hmm, I think /etc/config/wireless will be the right place. But I have no clue what to add to gain a backup/alternative/List of hotspot (for STA mode).

Anyone an idea?

Link to post
Share on other sites

The configuration file /etc/config/wireless only has the last wireless connected.

if you change the SSID, you lose the old data.

config wifi-iface
option device 'radio2'
option ifname 'wlan2'
option mode 'sta'
option macaddr 'xx:xx:xx:x:xx:xx'
option network 'wan'
option ssid 'xxxx'
option encryption 'psk2+ccmp'
option key 'xxxx'

Link to post
Share on other sites

if you change the SSID, you lose the old data.

that's exactly the problem. I'm looking for a configuration in which I can store multiple network ssids and keys so that I do not have to care about what AP is available.

Is there any syntax like that:

config wifi-iface

option device 'radio2'

option ifname 'wlan2'

option mode 'sta'

option network 'wan'

option ssid 'xxxx'

option encryption 'psk2+ccmp'

option key 'xxxx-key'

// alternatively

option said 'yyyy'

option encryption 'psk2+ccmp'

option key 'yyyy-key'

Link to post
Share on other sites
  • Solution

What you're describing is a Preferred Network List - something a WiFi network manager would handle.

There's a network manager on the WiFi Pineapple in the form of /etc/config/network and /etc/config/wireless -- but since it's a router OS they are static by default.

Another way to handle this would be to have a daemon or constantly running script that starts on boot to monitor wlan2 WiFi (or possibly Internet) connectivity, and when unavailable move to the next AP in the list. This could be done by bypassing the built-in WiFi client mode manager that references /etc/config/wireless and rather interface directly with "iw".

I recommend making a feature request at wifipineapple.com/bugs -- it'll help us know what to prioritize on with the next firmware update.

  • Upvote 2
Link to post
Share on other sites

What you're describing is a Preferred Network List - something a WiFi network manager would handle.

There's a network manager on the WiFi Pineapple in the form of /etc/config/network and /etc/config/wireless -- but since it's a router OS they are static by default.

Another way to handle this would be to have a daemon or constantly running script that starts on boot to monitor wlan2 WiFi (or possibly Internet) connectivity, and when unavailable move to the next AP in the list. This could be done by bypassing the built-in WiFi client mode manager that references /etc/config/wireless and rather interface directly with "iw".

I recommend making a feature request at wifipineapple.com/bugs -- it'll help us know what to prioritize on with the next firmware update.

Thanks Darren. I think you got exactly what I was talking about.

Thanks Darren.

Done !

Thanks for creating the suggestion ;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...