Jump to content

Recommended Posts

@Mitchell-Y can you provide a screenshot?  I just installed the module and made a TLS/SSL key and an encrypted TLS/SSL key and they downloaded right away.

Share this post


Link to post
Share on other sites
On 7/3/2018 at 1:48 AM, Mitchell-Y said:

If anyone can provide some help or a solution. Please do 

try this - from terminal run the following - make sure your pineapple has Internet or it wont work.

/pineapple/modules/Papers/includes/scripts/./installDepends.sh

I had this once on a fresh firmware install, not sure why but its like its not installing zip and unzip even though the dependencies "are installed". i ran again and they installed and downloads worked again. they need zip to compress them before download. @sud0nick  maybe worth a look on FW 2.1.2 might be nothing  tho.

Edited by Just_a_User

Share this post


Link to post
Share on other sites

Thanks guys, after some tinkering i think i figured it out. 

The dependancy wasnt installing, id click to install and it would act like it was but it didnt, i had my phone connected to it via tethering and it mustve switched of the tethering or glitched cause the dependacy didnt install, i tried like 4 more times and on the 4th go it went through and installed so at that moment i was able to download the keys, i will do further testing 

i also need to get Visual studio for my tests 

but ill worry about that later 

 

Share this post


Link to post
Share on other sites

Now im running into a new issue 

im following the guide at: https:*//www.*youtube*.com/*watch*?v=*Bvo43J*vmeW0when i get to the portal cloning part i do ensure that my created payload is in the right folder, ive checked the filepath of the payload in the payloader injectionset is set right in the html area, but i do use google as the test site (not sure if thats a big deal) and when i go to clone the portal i set it to 'payloader' 

 

 

however i get this: 

https://gyazo.com/ee71781a953a641e3d1644b67f8f7999

I set the windows to the payload option and leave the rest at 'none' and i leave default payload as 'windows' 

then i clone 

I get an error message

heres my log: 

https://gyazo.com/5c9cc2c9ea5a63462b67a2bf382ebdc7

 

i know..i used gyazo links, its what i had at the time of writing this besides snipping tool

can someone see what im doing wrong or what im missing?

Share this post


Link to post
Share on other sites
1 hour ago, Mitchell-Y said:

can someone see what im doing wrong or what im missing?

Some sites dont clone, im thinking its some form of protection. but now its an issue with PortalAuth you should really go over to the official PortalAuth thread to see if others have had similar issues and solved them or find a reason why it cant be cloned.

 

 

Edited by Just_a_User

Share this post


Link to post
Share on other sites

Make sure you use the official thread when having trouble with a module.  I get notifications when someone responds in the official thread but not when a new one is made.  As for your issue, it's strange that it said the dependencies were installed when they weren't.  It checks by using opkg to list installed packages and greps out zip and unzip.  So if it said the dependencies were installed then opkg thought they were, too.  When I get some time I'll see if I can reproduce the issue.

 

Share this post


Link to post
Share on other sites

Following up here, I dusted off my TETRA and upgraded to the latest firmware.  Before doing so I downloaded all of my keys from Papers and re-uploaded them after the upgrade.  I had no trouble with installing dependencies, uploading the keys, or resetting the SSL cert on my pineapple.  Not sure why this happened but if you run into it again we can dig into the issue some more.

Share this post


Link to post
Share on other sites

Version 1.6 is now available on GitHub.  The PR has been submitted to be added to the module manager.  Here is the changelog:

December 28, 2018
- Added feature to encrypt/decrypt existing private keys
- Added feature to view certificate properties in the web console
- Fixed a bug that prevented error logs from loading in the web console
- Removed null alert when enabling SSH keys

https://github.com/sud0nick/Papers

Share this post


Link to post
Share on other sites

I have setup a new WIFI Pineapple TETRA with firmware 2.4.2.

I have two questions regarding your module.

1) after installing the module Papers (version 1.5) via "Manage Modules" it gets installed (message appears).

If I click on the button/link "Paper" on the left side where the installed modules appear nothing happens (only URL changes to the suffix "#Papers", but in the main frame still the previous content appears which was loaded before).

Other modules are working, so if I click on modules name the main frame shows the modules configuration/content as expected.

This problem seems to be module-related, this also happens with your module "PortalAuth".

2) How can I install Papers module in version 1.6 from GitHub on the WIFI Pineapple TETRA? Could not find a guide.

Could you  please support me?

Thank you.

Share this post


Link to post
Share on other sites

Sure, the versions on the module manager should be working but it's best to get my latest from GitHub anyway.  All you need to do is download the repo from GitHub and copy it over to the /pineapple/modules/ directory on your Pineapple.  Once it's there just run the following command in an SSH session to ensure the permissions are correct:

chmod 755 -R /pineapple/modules/Papers/

And that's it.  Everything should work from the browser after that.

  • Upvote 1

Share this post


Link to post
Share on other sites

Version 1.9 is now available on GitHub!  I'll submit the PR for the module manager soon.

Here is the changelog:

December 26, 2019

- Fixed bug in latest firmware that prevented the module from detecting whether a key is enctyped.
- Fixed bug in latest firmware that broke the nginx config when removing SSL certs.
- Added requirement to remove SSL certs before uninstalling dependencies due to a change made by adde88 that swaps nginx/nginx-ssl as dependencies in the latest firmware.
- Added requirement to install dependencies (nginx-ssl) before gaining the ability to install SSL certificates.
- Updated the Status section help file.

 

Share this post


Link to post
Share on other sites

Im having some trouble getting this module to work on a Nano with 2.6.2:   It seems that installing the dependencies from Papers (either the new version from github or the 'old' version from module manager)  breaks my the Web connectivity on my Nano.   Neither refreshing the page, rebooting,  nor fully cycling the power brings it back.  I can still SSH in tho.

After some poking around and trying  to manually install the depends, I found that the issue is with nginx-ssl:   The dependency script successfully stops nginx and  removes it, (installs zip, unzip, etc) but the installation of nginx-ssl fails.  Thus, there is no nginx to restart, and therefore the web interface does not work.   if i manually reinstall and restart (regular)nginx,   the nano resumes full functionality.

Trying to install nginx-ssl manually is usually met with a message about how it cannot be installed because there isnt enough room in overlay;  but even on a fresh firmware-recovered nano and a clean sd card with only Papers installed, I still get this error message:

* check_data_file_clashes: Package libubox20191228 wants to install file /lib/libubox.so
	But that file is already provided by package  * libubox20170601
 * opkg_install_cmd: Cannot install package nginx-ssl.

     I should prob mention that i did get the new version fully installed and working a few weeks ago but I recently had to do a firmware reset, which is why im trying to reinstall (and especially frustrated that it isnt working 😉.)   If i remember correctly,   I had a similar problem where it wouldnt work if the nano was already "loaded up" with other modules (space issue?)... but it did  successfully loaded the dependencies (and nginx-ssl) on factory reset and newly formatted sd... so obviously there were no libubox conflicts....    Did something change with the packages? Any ideas?

Thanks in advance

Edited by Charbot

Share this post


Link to post
Share on other sites

   I found a few things like this that would seem to indicate that the problem is with OpenWRT packages being updated.   I tried it again today and found different libubox conflicts than last time.     On a whim, I renamed the existing /lib/libubox.so  and I was finally able to manually install nginx-ssl.  Great!... However it would not start , issuing a couple complaints like this:     

Error relocating /lib/libubus.so: blob_parse_untrusted: symbol not found

I then tried renaming the newly installed libubox.so and re-renaming the old one back to original =  /lib/libubox.so ..and...Bingo.   Nginx started right up, my pineapple was reachable at its IP,  Papers has its depends installed and I could successfully create a 'test' key.   I havent had time to really give the nano and other modules a thorough run-thru, but at first glance, it doesnt seem like I broke anything.   I guess the libubox conflicts will get solved eventually as openwrt does its housekeeping, but in the meantime this may be a valid workaround.

..now on to  tackling my problem with Cursed Screech!

Edited by Charbot

Share this post


Link to post
Share on other sites

hi there i and a friend of mine in the usa dowloaded the papers module v 1.8 and everytime we tried to run it we are unable to connect to the wifipineapple webpage is this a know error and is there a fix

 

Share this post


Link to post
Share on other sites
42 minutes ago, Thomas123 said:

hi there i and a friend of mine in the usa dowloaded the papers module v 1.8 and everytime we tried to run it we are unable to connect to the wifipineapple webpage is this a know error and is there a fix

 

got this kinda working but now unable to install depedecies

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...