Jump to content
Hak5 Forums

Recommended Posts

Foxtrot   

I'm trying to use the wp6 script to get internet but it's not working. I'm properly connected to my home Wi-Fi on my computer. Here is a picture http://pasteboard.co/WGcRSnX.png

Any help is appreciated

The problem is obvious...

Your gateway for wlan0 is set to 0.0.0.0, surely this is wrong.

Set your gateway for wlan0 and youre set.

Share this post


Link to post
Share on other sites

I have the nano connected to an Asus C300 chromebook with wifi connection. I have flashed it with the latest firmware, I used the wp6 script, but it still won't load bulletins from wifipineapple.com. I can go to wifipineapple.com in my browser; it works fine. What would you suggest?

Share this post


Link to post
Share on other sites
Lion7608   

I'm finally able to connect. However still with issues...

I've my PC running under Kali 2.0. Firmware of my Nano is 1.0.5. with wlan0 connected to the internet en eth1 connected to my Nano.

By adding an extra route in Kali I'm now able to connect tot the Internet from my Nano through my PC.

I used the following command in Kali: route add default gw 192.168.0.1 metric 80 dev wlan0

When I connect the Nano and open the Networking tab, the following is displayed:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan

At this moment I'm able to use the internet from the Nano.

However if I push the button 'Upade Route' the first line disappears. From that moment on internet connection has gone.

It loses its default route. Why this happens, I don't know. Who can?

Share this post


Link to post
Share on other sites
Ted_   

Can someone show me a pic of the routing section of your nano?

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan

Default Route: 172.16.42.42 br-lan

USB wired, after wp6.sh on a Linux laptop.

Share this post


Link to post
Share on other sites
Lion7608   

Thnx for your reply. What happens if you push 'Update route'?

In my nano the first line (containing the default route) disappears.

From that moment on of course no route to the PC exists, resulting in no internet connection from my nano. I tried it with Windows10 and Kali 2.0. Same result.

Share this post


Link to post
Share on other sites

Lukas here. I originally asked the question; " Does anybody have any idea why the Wifi pineapple Nano won't load bulletins from wifipineapple.com?" Has anyone experienced this problem? i can't use it without a wifi connection. Any idea?

Share this post


Link to post
Share on other sites

When I plug my Nano into one of my Linux laptops, I have to run the wp6.sh script. Until I do the Nano will not load the bulletins from wifipineapple.com. I only have to do this on my Linux boxes. No problems when using my Android phones.

Here is a link to the forum topic on wp6.sh

https://forums.hak5.org/index.php?/topic/37142-questions-about-wp6sh/

Edited by Tech_Terry
  • Upvote 1

Share this post


Link to post
Share on other sites
netrix   

Hello, i'm a complete noob with issues connecting my wifi pineapple to windows. ( 10 pro )

I followed the instructions per this video https://www.youtube.com/watch?v=Nv1eiIwOPKo

I'm currently connect via Ethernet when checking to see if my nano is connected.

I have started completely over just to make sure. I get the same results so far.

Nano is connected with USB 2.0 ports. Windows found ASIX with no issues.

Any Ideas on what i should try or do? showing no internet access on the adapter for the nano. Internet has been shared to nano.

Thank you - anyone who is willing to help me get this corrected. :D

Share this post


Link to post
Share on other sites
Foxtrot   

Can you take pictures of your network settings?

The same ones you used when you were following the video guide.

Share this post


Link to post
Share on other sites
netrix   

alright i set the DNS to 8.8.8.8 - i put this information within the nano IPv4 properties.

i hit refresh on network connections checked status and showing no internet access, unless i need to be putting this info onto my Ethernet adapter.

Share this post


Link to post
Share on other sites
AlfAlfa   

alright i set the DNS to 8.8.8.8 - i put this information within the nano IPv4 properties.

i hit refresh on network connections checked status and showing no internet access, unless i need to be putting this info onto my Ethernet adapter.

You also need the default gateway to be set... Use 172.16.42.1 I believe is the correct thing to put in the gateway field.

  • Upvote 1

Share this post


Link to post
Share on other sites
juanb007   

Hi

i was able to the web interface and wanted to connect nano in client mode so i can download modules and check for software updates. I gave it the password of my AP at home to connect to the internet and nothhing ! i dont know even if it was able to connet to the AP. how can i Know? i tried to download modules and aldo to check for updates but it gives be back an error that it cant reach the downloads:

error connecting to Wifipineapple.com.please check your connection.

I do have internet connection from the pc. maybe its a default route configuration.

please help.

thanks

marco

Share this post


Link to post
Share on other sites
Beight   

I'm having a similar issue. I'm also new to using the pineapple, but I have followed thorugh the instructions and video and I'm still having issues. (maybe I missed something obvious but if so I'm not seeing it).

The issue I'm seeing is that clients who connect to the Nano's AP (public, not management) cannot reach the internet. If I configure the Landing Page, that shows up for them.

From the Nano web interface I can retrieve the bulletins as described in the video showing that I have internet access.

The Nano is connected to my Windows 10 box via the Y USB cable. Internet connectivity is supplied via wired Ethernet.

If I turn on the 'WiFi Client Mode' where I connect wlan1 to another wireless AP, then clients connecting to the Nano's AP do have internet. When I turn this off and rely on the connectivity through the USB connection it doesn't work. Again from the Nano web interface, it can retrieve updates, modules, etc. It's just the clients connected to the Nano AP that cannot get to the internet.

Here is routing from the Nano:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan

One the windows side I have the Pineapple sharing my Ethernet (wired) connection.

IPv4 settings for the WiFi Pineapple ASIX are set as follows:

IP: 172.16.42.42

Subnet: 255.255.255.0

Default Gateway: 172.16.42.1 (using the advice by AlfAlfa)

Prefered DNS Server: 8.8.8.8 (using advice by Foxtrot)

Anyone have any ideas that could help here? (with getting clients who connect to the Nano's AP internet access that is)

Thanks in advance.

Share this post


Link to post
Share on other sites
Foxtrot   

You also need the default gateway to be set... Use 172.16.42.1 I believe is the correct thing to put in the gateway field.

You don't need to set a default gateway in Windows.

IPv4 settings for the WiFi Pineapple ASIX are set as follows:

IP: 172.16.42.42

Subnet: 255.255.255.0

Default Gateway: 172.16.42.1 (using the advice by AlfAlfa)

Prefered DNS Server: 8.8.8.8 (using advice by Foxtrot)

Anyone have any ideas that could help here? (with getting clients who connect to the Nano's AP internet access that is)

Thanks in advance.

Please try unsetting the default gateway and trying again. On Windows 10 setting a gateway breaks functionality for me. I never set one anyway, and it works fine.

Share this post


Link to post
Share on other sites
AlfAlfa   

Would the gateway be 172.16.42.1 or 172.16.42.0 though?

You can also set the DNS server to the same as the proper gateway address and it'll grab the DNS from the router/gateway instead of entering it manually.

Are you sure foxtrot? Maybe I'm confusing regular router manual configuration with configuration for pineapples. On windows 7 if I don't put the gateway for a manual config with my router it doesn't work. That has probably changed in newer versions of windows and it does a better job of figuring it out automatically?

However there has been cases where I had two interfaces up and had to not set the gateway in the second interface and only in the first. Also had to change the metric of the second interface to be higher than the first interface. (since I wanted it to get the internet access from the first interface, but still have the second connected at the same time) So just to be clear if you have two interfaces connected simultaneously in windows, set the one you want it to grab internet access to with a lower metric value than the one you just want connected but not to use for internet access. (the metric value is somewhere in the advanced settings)

Share this post


Link to post
Share on other sites
Beight   

Thanks for the help guys.

Some more troubleshooting on this end.

Removed the gateway.

Removed the DNS.

Restarted everything.

Didn't change anything else. So it looks like it did in the videos again.

Was retesting and noticed I can get to sites like ""http://google.com". So internet connectivity does appear to be there, but why would unsecure traffic be blocked?

Any ideas? Thanks again.

Share this post


Link to post
Share on other sites
AlfAlfa   

Well then it's working then! That is a security feature called HSTS built into the browser. Once you go to the TLS/SSL version you can't go to the unsecured version anymore! That's what I think your issue is anyway, see this for a possibly working bypass: https://forums.hak5.org/index.php?/topic/37642-hsts-bypass-and-ssl-stripping/?hl=hstsOr use a custom browser, or one that lets you disable the feature.

Share this post


Link to post
Share on other sites
Foxtrot   

Well then it's working then! That is a security feature called HSTS built into the browser. Once you go to the TLS/SSL version you can't go to the unsecured version anymore! That's what I think your issue is anyway, see this for a possibly working bypass: https://forums.hak5.org/index.php?/topic/37642-hsts-bypass-and-ssl-stripping/?hl=hstsOr use a custom browser, or one that lets you disable the feature.

Actually HSTS should just upgrade your session to a HTTPS version, not just disallow you completely. Also, I think the whole point of HSTS is that it can't be disabled...

Share this post


Link to post
Share on other sites
AlfAlfa   

Yes that's true, it should upgrade to HTTPS which it does for me. You're also right there isn't a 'disable HSTS setting' but a trick to get it to bypass HSTS (at least in firefox):

"According to several forums, you can disable HSTS by introducing a new configuration variable. First, go to the Firefox configuration page (about:config), right-click, choose "New Integer", then provide the name "test.currentTimeOffsetSeconds" (no quotes) with a value of 11491200. This should bypass HSTS, although you may also need to clear the Cache and Active Logins in the Clear Recent History dialog (Ctrl-Shift-Del).


This apparently works because of a function called GetPreloadListEntry that checks to see if the current time is less than the next list expiration time; since the time is effectively calculated to be later than the expiration time, no check is performed. This effectively disables HSTS checks."

If you're on the box you can disable it is the point, but yes I agree it shouldn't be able to be disabled just through a MITM. Though setting that variable could be a neat trick to allow the old sslstrip to work again on a compromised box, until they change the code where that doesn't work anymore that is.

Edited by AlfAlfa

Share this post


Link to post
Share on other sites
8bit   

Hey all, just wondering if I could pick your brains in regards to some connectivity issues I'm trying to sort.

Couple of points to make - I'm using Kali 2 (not in a VM) and Linux is reasonably new to me.. but the best way to learn is to dive into it, so I'm trying to make it my main machine.. Apologies if I'm asking some basic usage/command related questions.

I did also search all the current posts and tried a few suggestions, but I just cant nail it - so here it goes

I've connected the Nano to my Kali machine and this is the current situation

- I followed darren's video to set it up

- I've reset Nano and redone setup

- I ran the wp6.sh v6.4 script which is the latest

- I've tried all options, (advanced, Automatic etc) and double checked settings each time

- I can see, ping and connect to the Nano. No problems there

- I couldn't connect to the Internet from my kali machine, so manually added a default route and now that's also fine - but maybe ive done this wrong

- I can ssh to the Nano and tried ping and tracreroute from there to 8.8.8.8. - both failed

- Traceroute literally stops at 72.16.42.1

So to help you, help me and maybe help myself, this is what I have - and a BIG thank you in advance for your time and hope to be in here more often once I move on to getting some practice in


Pineapple Nano Network Config

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan


results from wp6.sh - basically the same IP's etc from the auto setup

WiFi Pineapple Network [172.16.42.0/24]:
WiFi Pineapple Netmask [255.255.255.0]:
Host IP Address [172.16.42.42]:
WiFi Pineapple IP Address [172.16.42.1]:

Advanced IP settings will be saved for future sessions.
Default settings may be restored by selecting Advanced IP settings and
pressing [ENTER] when prompted for IP settings.

Press any key to continue
Settings saved.

Saved Settings: Share Internet connection from wlan0
to WiFi Pineapple at eth1 through default gateway 192.168.1.1

SSH on pineapple, tracerout to 8.8.8

root@Pineapple:~# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 Pineapple.lan (172.16.42.1) 2996.232 ms !H 2998.321 ms !H 2998.714 ms !H

Route config on Kali - I had to manually add the default route

Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway 0.0.0.0 UG 80 0 0 wlan0
172.16.42.0 0.0.0.0 255.255.255.0 U 100 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 600 0 0 wlan0

ifconfig eth1 on Kali

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 172.16.42.124 netmask 255.255.255.0 broadcast 172.16.42.255
inet6 fe80::2c0:caff:fe8d:dda2 prefixlen 64 scopeid 0x20<link>
ether 00:c0:ca:8d:dd:a2 txqueuelen 1000 (Ethernet)
RX packets 12207 bytes 3707058 (3.5 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 10745 bytes 3454805 (3.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ifconfig wlan0 on Kali

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fd58:1f28:2d47:f200:2677:3ff:fe37:28d0 prefixlen 64 scopeid 0x0<global>
inet6 fe80::2677:3ff:fe37:28d0 prefixlen 64 scopeid 0x20<link>
ether 24:77:03:37:28:d0 txqueuelen 1000 (Ethernet)
RX packets 509984 bytes 692724373 (660.6 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 283378 bytes 30253251 (28.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


Thanks a million guys and look forward to hopefully getting it sorted

-8bit


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×