Jump to content

Just Bricked my Nano - Howto unbrick


Recommended Posts

I assume that you follow the procedure described in the docs

I haven't tried it when I have done firmware recoveries on my Nano, but I don't think that SSH is supposed to be available in that mode. Not that it should make any difference, but, have you tried different browsers when trying to connect to the Nano "recovery web server" @ Incognito window? Making sure you aren't trying to use https? Making sure that the Nano gets sufficient power? I seldom trust that the Nano gets enough power even when using the Y-cable so I supply extra juice with a USB wall plug power supply.

Link to comment
Share on other sites

  • Replies 56
  • Created
  • Last Reply

It will most likely make no difference at all, but since you seem out of options, why not try anything that is possible. Don't forget that you still need to connect to the Nano using the USB cable when trying to do a recovery so even if adding power, you need to put the other USB connector of the Y-cable into the computer. I'm sure you understand that, just want to be extra clear about it.

Link to comment
Share on other sites

yes, that's not a problem.
I fed the pineapple with an alternative source, I verified that the browser was in normal mode, and that the address was correct (not https: //) I repeated the procedure ..... but the problem persists.



Link to comment
Share on other sites

  • 2 weeks later...

Hi All

Please help !!

Plugged in the nano and was working

Solid blue light 

Then suddenly it off

No lights at all

I had it on a usb power bank ( voltage was fine )

Now cant get any thing

Tried the Y cable into the laptop and nothing.


Is it dead ??

Link to comment
Share on other sites

I did other tests with my NANO: at the moment when I connect my NANO to the PC if I try to perform the procedure indicated by Dereck, I can assign an IP address but if I try to scan the network with NMAP, I cannot find active IP addresses, the only one on is the one from assigned me but with no door open. if, on the other hand, I connect my Pineapple to the power supply without performing any reset, and wait for the blue LED to stop and then connect it to the network I can identify an IP, on this the Port Mapper (rpcbind) is active. if I scan the interface I can identify ports 80 and 53.


sudo nmap -e enx00c0ca914cc0

If I try to connect with the browser to I see a blank page. I believe that the http "server" is active, but it has nothing to run, the question remains, is it possible to inject the factory bin file into memory under these conditions?

Is there a program to do it?


Thank you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...