Jump to content

OPKG update issue


dre2007
 Share

Recommended Posts

Hello everyone;

When I SSH into the NANO and do an opkg update, it gives me the following error.

* opkg_download: Failed to download https://www.wifipineapple.com/nano/packages/Packages.gz, wget returned 1

When I iceweasel to it, it indeed doesn't exists.

So, I thought, why doesn't this URL exist and messed a litle with the url and changed the nano subdirectory in markv, this packages.gz does exist.

I don't change it in the repositories because it is a way different build as I read earlier on some forums but I wanted to point out that this link doesn't work, is it because this is also the download link for the modules which are not yet available and you want to introduce later?

Why am I doing an opkg update?

Because opkg install python-twisted-web gives me an error and I need that one for the sslstrip to work ( it states unknown package ).

The installation instructions that I created for myself after some digging around:

opkg update
opkg install python
opkg install python-twisted-web <-- this gives me the error mentioned
wget http://www.NotShowingUrlButThisIsTheSoftwareSite/software/sslstrip/sslstrip-0.9.tar.gz<-- I'm not sure if I am allowed to point to other sites so thats why I removed the URL

tar -zxvf sslstrip-0.9.tar.gz
cd sslstrip-0.9
python ./setup.py install

If I run sslstrip never the less, I get the following error with this command "sslstrip -p -l 4444":

Traceback (most recent call last):
File "/usr/bin/sslstrip", line 27, in <module>
from twisted.web import http
ImportError: No module named twisted.web

Questions:

1- Why is the URL incorrect

2- Where do I obtain python-twisted-web

3- Is the reason of my ssltrip error the lack of having python-twisted-web

PS.: Darren, you were right on the udhcpc command ;)

Thanks in advance,

Andre

Link to comment
Share on other sites

Hi,

I had a few questions on opkg and packages in the wifipineapple.com/nano stream. I sshed into the nano on my tablet and tried running "opkg update" but I wasn't able to get the nano packages.gz. It kept saying connection reset by peer. I tried manually running wget and was able to get it. Then I figured that it was the https that wasn't set up correctly I guess. So I edited the /etc/opkg.conf and change https to http for the nano stream. And that worked.

Then I installed reaver, and tried to run it but now I'm getting a cannot open libpcap.so.1.1 error. Is that because the package isn't finished being updated for the system? Or is there something else I should be doing?

Thanks.

Link to comment
Share on other sites

Hi dre2007,

1. The URL is correct, simply not available yet.

2. From the repo once it is up

3. That's not the correct way to install SSLStrip on OpenWRT. You'll need to wait for the package to become available. This will take care of the install for you.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...