Jump to content

Can't Get to Recovery Mode


jfrancis
 Share

Recommended Posts

I've got a Lan Turtle that works 100% perfectly, except that I seem to have forgotten the account/password I used (I assume it's "root" and *something*, but none of my normal passwords seem to work). It's been in a box for three or four months, and I finally pulled it out to use it today, and realized I can't log into it. It still creates a reverse shell to my linux box out on the internet, and both that port and the local (USB side) port respond to ssh. So I followed the directions on the wiki to do a factory default/firmware upgrade. But no matter what I do, I can't get it into recovery mode. If I let it boot normally, it assigns me the address 172.16.84.235, and I can ssh/ping it at 172.16.84.1. If I hold the button down for three seconds (I've tried everything from 1 second to 30 seconds), it never does anything useful. Ever. If I watch /var/log/syslog, it clearly finds and enumerates the ethernet and attempts to get a DHCP address from the device. But it never does. I can disable the lan manager and manually assign myself 192.168.1.2/24, but nothing ever appears as 192.168.1.1. If I do 'sudo arp -a', I've got nothing. If I do an 'ifconfig eth1', I get zero bytes RX. ping gets me nothing, nmap gets me nothing. No matter how long I let it sit. Same behavior on Mint 22, Kali, and Ubuntu Server 14.04.3.

Help! What am I doing wrong?

Link to comment
Share on other sites

I am. I push and hold the button, plug it in, count off three seconds (though like I said, I've tried everything from 1 to 30 seconds), then let go. Meanwhile, if I watch syslog, it does *almost*, but not quite the same thing that it does when I'm not pushing the button. The difference is that the dhcp daemon keeps retrying forever, and never gets an address. And killing dhcpd and setting the address by hand doesn't do any better. No matter what I do, the interface (eth1) shows 0 RX packets/bytes.

I'm gonna go try it on my Mac, just for grins. I know it shouldn't make any difference, but this is just downright bizarre. I've done this a thousand times with other (similar) devices. It's not rocket science. Or at least it wasn't before today. :)

Link to comment
Share on other sites

Ok, it's fixed. For future reference, at least with the version of firmware that came on my Turtle (or "Turetle", as it called itself), the trick is not to hold down the button while booting. No possible combination of booting and that button seemed to work. Rather, wait until the thing boots all the way up, and only then push the button and hold it for three seconds. Don't know why I'd never tried that trick before. Probably because I was trying to follow the directions instead of experimenting. Lesson learned. I was then able to upload new firmware, which wiped the root password. All good.

Thank you for the help.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...