Jump to content

Recommended Posts

Hello,

I have a question regarding mounting the SD on the Nano. I don't see an fstab file on the Nano and where is the "Save Fstab" file in the web interface saving the fstab file? Here is what I've done.

Nano is powered off, I put in an SD card into the Nano and powered up the Nano.

SSH as root into the Nano after power up complete.

Run df command, the SD card is not mounted. Issuing mount -a does not mount it.

I cd to /etc/ to find the fstab file is a link to /tmp/fstab. The /tmp/fstab file does not exist.

I then decided to power up the Nano first and then plug in the SD card.

After Nano powers up, I plug in the SD card, run df command, the SD card is mounted. Seems it mounts automatically only after inserting card into running Nano.,

I have used the web interface and clicked the "Save Fstab" option with the SD card mounted, but I do not see a /etc/fstab file being saved.

Do I simply create an /etc/fstab file so Nano mounts it at power up?

Share this post


Link to post
Share on other sites

Hi ntimodatr,

The file it edits is at /etc/config/fstab.

There seems to be an issue with some devices not firing the correct events off to auto-mount. I'll have a fixed firmware out soon.

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

So I have been doing some messing around with my SD cards.

I found that to get the SD to mount after format you just have to remove 'M' at the end of +1024M in the /pineapple/modules/Advanced/formatSD/fdisk_options file.

o
n
p
2

+1024M
n
p
1


w

However, unlike using the Formatting option on boot the NANO does not recognize the SD card partitions as sd1 and sd2 it recognizes them as sda1 and sda2.

So if you edit your Fstab file through the browser to look like this:

config 'global'
	option	anon_swap	'0'
	option	anon_mount	'0'
	option	auto_swap	'1'
	option	auto_mount	'1'
	option	delay_root	'5'
	option	check_fs	'0'

config 'mount'
	option	target		'/sd'
	option	device		'/dev/sdcard/sda1'
	option	fstype		'ext4'
	option	options		'rw,sync'
	option	enabled		'1'

config 'swap'
        option      device      '/dev/sdcard/sda2'
        option      enabled     '1'

It will boot up with the SD card space and Swap space loaded correctly.

I hope this helps and if this has already been found sorry for the late reply.

  • Like 1

Share this post


Link to post
Share on other sites

There is actually a bug in the current WiFi Pineapple NANO firmware that causes issues with micro SD card mounting. This issue has been fixed and will be available soon as an OTA upgrade.

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

I don't know if card model matters but I'm using a Samsung Pro+ 32GB and Pro+ 64GB.

There is actually a bug in the current WiFi Pineapple NANO firmware that causes issues with micro SD card mounting. This issue has been fixed and will be available soon as an OTA upgrade.

Best Regards,

Sebkinne

@Sebkinne I understand that there is a bug right now but if people need a workaround until the Update is pushed my first post should help guide people through getting auto-mount to work.

Share this post


Link to post
Share on other sites

Another post on mounting an SD card.

I don't know how to mount the USB drives but I read some other posts so if someone could help me out with the info provide below that would be great:

Firmware: 1.0.1

Installation: Clean install

df -h shows:

Filesystem Size Used Available Use% Mounted on
rootfs 2.4M 288.0K 2.2M 12% /
/dev/root 12.5M 12.5M 0 100% /rom
tmpfs 29.9M 92.0K 29.8M 0% /tmp
tmpfs 29.9M 68.0K 29.8M 0% /tmp/root
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 2.4M 288.0K 2.2M 12% /overlay
overlayfs:/overlay 2.4M 288.0K 2.2M 12% /
FDISK -l shows (partial result ):
Disk /dev/sda: 31.1 GB, 31104958464 bytes
255 heads, 63 sectors/track, 3781 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 1 3782 30371840 c Win95 FAT32 (LBA)

I did:

mkdir /mnt/sda1

mount -a <-- nothing happend as I can't browse the /mnt/sda1 dir

mount /dev/sda1 /mnt/sda1 <-- nothing happend again

Also did:

mount -t ntfs /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: No such device <-- this is the result

PS: I also did what Heavenbreaker stated and copied and paste it in and removed the M after 1024 in the file. Still no luck after reboot...

What am I missing?

Edited by dre2007

Share this post


Link to post
Share on other sites

Hey. Got this working by making some edits to the fstab under the Advanced tab.

I can't copy/paste right now, but the device was `/dev/sda1` and the mount point `/sd`. I also set the format as ext4 in the fstab

After that, I manually formatted with `fdisk`

fdisk /dev/sda

then deleted/recreated the partition

after that I formatted it with

mkfs.ext4 /dev/sda1

After a reboot, my disk was mounted. Hope that helps

Share this post


Link to post
Share on other sites

Again, because I hear and see this issue being reported so often, I just wanted to clarify:

The issue is known to us and we have resolved it. It fixed and we'll push that update this week.

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

Again, because I hear and see this issue being reported so often, I just wanted to clarify:

The issue is known to us and we have resolved it. It fixed and we'll push that update this week.

Best Regards,

Sebkinne

Hello sebkinne,

this was indeed the issue and now it is mounted for me aswell, instead of booting I did mount /dev/sda1 /mnt/sda1

Now I can see the following output:

root@Pineapple# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 2.4M 292.0K 2.2M 12% /
/dev/root 12.5M 12.5M 0 100% /rom
tmpfs 29.9M 88.0K 29.8M 0% /tmp
/dev/mtdblock3 2.4M 292.0K 2.2M 12% /overlay
overlayfs:/overlay 2.4M 292.0K 2.2M 12% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 28.4G 43.9M 26.9G 0% /mnt/sda1
Now I wonder, how do I specify the mounted partition as the target for installation?
I did opkg install xxxx.ipk --dest /dev/sda1
I did opkg install xxxx.ipk --dest /mnt/sda1
but but commands failed.
Dmesg shows:
[ 291.110000] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Hopefully someone can help me out on this one.

Share this post


Link to post
Share on other sites

While this may mount the card, it's not the way we will mount the card, and the mount points are wrong. You'll have to wait for this week's firmware.

Best regards,

Sebkinne

Share this post


Link to post
Share on other sites

Hi Sebkinne,

Thanks for comming back to me on this one.

However, do you have a good read up of how to achieve in the way I did?
i am just curiouse as of what I did wrong.

It mounted, but why can't I use it as a destination?

Didn't I specify it somewhere where I should have?

Thanks again :)

Share this post


Link to post
Share on other sites

Finally I got this thingy setup..

I created a partition with fdisk /dev/sd1

It was mounted all the time, I was just misusing the opkg command and the fstab had to correspond with the device which you can find in dmesg

I had to check how it could be used with opkg so I did vi /etc/opkg.conf

There I saw that it was dest sd /sd

This meant that I should not use opkg install ***.ipk --dest /sd but without the / in front of sd.

Thanks for all the tips and heads up :)

Share this post


Link to post
Share on other sites

Hello,

I am new to this and I just received my NANO a couple of days ago, so please bear with me :smile: . I was downloading modules and trying them out, and then I ran out of memory space... So i removed ALL the modules I already have thinking it would make some space on my NANO... but NO! Even with no modules it writes: " You do not have enough free space to install this module. Please insert an SD card and ensure that it is formatted correctly." How can I free some memory space? I even added a sdcard (I also formatted it) but it still tells me that I do not of enough memory space... Please Help.

Thank you,

PureInspire :ph34r:

Share this post


Link to post
Share on other sites

If you SSH into the NANO and enter the following commands what do you see?

ls /pineapple/modules/
ls /sd/modules/

If you don't have an SD card inserted that second command should return an error. If you still see your modules installed from the first command then something went wrong when you tried to remove them.

Have you used any logging features? If you've used it a lot you may have filled up your internal space with a bunch of logs.

Edited by sud0nick

Share this post


Link to post
Share on other sites

  1. Plug it into the NANO

In the web interface, go to the Advanced tab.

In the top right corner you should see a dropdown arrow next to USB. Click it and select Format SD Card.

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

Is it possible to mount the system on to the extended space allotted by an SD card? I can't currently opkg install anything, due to lack of space.

opkg -d sd install ... fails on grep ***.control, because it looks for the files in the /var directory rather than /sd/var.

Is there a fix for this?

Share this post


Link to post
Share on other sites

While this may mount the card, it's not the way we will mount the card, and the mount points are wrong. You'll have to wait for this week's firmware.

Best regards,

Sebkinne

Hi Seb!

Looks like the bug remains in the latest firmware. I´ve updated to 1.0.5 and my SD card is not mounted:

df -h output

root@Pineapple:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    2.3M      2.2M     80.0K  97% /
/dev/root                12.5M     12.5M         0 100% /rom
tmpfs                    29.9M    108.0K     29.8M   0% /tmp
/dev/mtdblock3            2.3M      2.2M     80.0K  97% /overlay
overlayfs:/overlay        2.3M      2.2M     80.0K  97% /
tmpfs                   512.0K         0    512.0K   0% /dev

fstab config:

root@Pineapple:~# cat /etc/config/fstab
config 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '5'
        option  check_fs        '0'

config 'mount'
        option  target          '/sd'
        option  device          '/dev/sdcard/sd1'
        option  fstype          'auto'
        option  options         'rw,sync'
        option  enabled         '1'

logread output after formatting SD card:

Fri Feb 12 00:11:27 2016 kern.info kernel: [ 1592.690000] usb-storage 1-1.2:1.0: USB Mass Storage device detected
Fri Feb 12 00:11:27 2016 kern.info kernel: [ 1592.720000] scsi host5: usb-storage 1-1.2:1.0
Fri Feb 12 00:11:28 2016 kern.notice kernel: [ 1593.720000] scsi 5:0:0:0: Direct-Access     Generic  STORAGE DEVICE   0933 PQ: 0 ANSI: 6
Fri Feb 12 00:11:28 2016 kern.notice kernel: [ 1593.730000] sd 5:0:0:0: Attached scsi generic sg0 type 0
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.240000] sd 5:0:0:0: [sde] 493568 512-byte logical blocks: (252 MB/241 MiB)
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.250000] sd 5:0:0:0: [sde] Write Protect is off
Fri Feb 12 00:11:29 2016 kern.debug kernel: [ 1594.250000] sd 5:0:0:0: [sde] Mode Sense: 21 00 00 00
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.250000] sd 5:0:0:0: [sde] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
Fri Feb 12 00:11:29 2016 kern.info kernel: [ 1594.270000]  sde: sde2
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.290000] sd 5:0:0:0: [sde] Attached SCSI removable disk
Fri Feb 12 00:11:29 2016 daemon.err block: failed to swapoff /dev/sdcard/sd2 (-1)
Fri Feb 12 00:11:29 2016 kern.info kernel: [ 1594.670000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:35 2016 kern.info kernel: [ 1600.820000]  sde: sde2
Fri Feb 12 00:11:36 2016 daemon.err block: failed to swapoff /dev/sdcard/sd2 (-1)
Fri Feb 12 00:11:36 2016 kern.info kernel: [ 1601.030000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:36 2016 daemon.err block: Unkown action change
Fri Feb 12 00:11:36 2016 kern.info kernel: [ 1601.390000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:40 2016 daemon.err block: failed to swapon /dev/sdcard/sd2 (-1)

Share this post


Link to post
Share on other sites

Hi D4rkOperat0r,

It actually looks like your card needs to be re-formatted.

The system is seeing the card and it's partitions correctly, but fails to mount.

If you go to the Advanced tab, under USB select "Format SD card". After that, reboot and the card should mount.

Best Regards,

Sebkinne

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Seb!

Looks like the bug remains in the latest firmware. I´ve updated to 1.0.5 and my SD card is not mounted:

df -h output

root@Pineapple:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    2.3M      2.2M     80.0K  97% /
/dev/root                12.5M     12.5M         0 100% /rom
tmpfs                    29.9M    108.0K     29.8M   0% /tmp
/dev/mtdblock3            2.3M      2.2M     80.0K  97% /overlay
overlayfs:/overlay        2.3M      2.2M     80.0K  97% /
tmpfs                   512.0K         0    512.0K   0% /dev

fstab config:

root@Pineapple:~# cat /etc/config/fstab
config 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '5'
        option  check_fs        '0'

config 'mount'
        option  target          '/sd'
        option  device          '/dev/sdcard/sd1'
        option  fstype          'auto'
        option  options         'rw,sync'
        option  enabled         '1'

logread output after formatting SD card:

Fri Feb 12 00:11:27 2016 kern.info kernel: [ 1592.690000] usb-storage 1-1.2:1.0: USB Mass Storage device detected
Fri Feb 12 00:11:27 2016 kern.info kernel: [ 1592.720000] scsi host5: usb-storage 1-1.2:1.0
Fri Feb 12 00:11:28 2016 kern.notice kernel: [ 1593.720000] scsi 5:0:0:0: Direct-Access     Generic  STORAGE DEVICE   0933 PQ: 0 ANSI: 6
Fri Feb 12 00:11:28 2016 kern.notice kernel: [ 1593.730000] sd 5:0:0:0: Attached scsi generic sg0 type 0
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.240000] sd 5:0:0:0: [sde] 493568 512-byte logical blocks: (252 MB/241 MiB)
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.250000] sd 5:0:0:0: [sde] Write Protect is off
Fri Feb 12 00:11:29 2016 kern.debug kernel: [ 1594.250000] sd 5:0:0:0: [sde] Mode Sense: 21 00 00 00
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.250000] sd 5:0:0:0: [sde] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
Fri Feb 12 00:11:29 2016 kern.info kernel: [ 1594.270000]  sde: sde2
Fri Feb 12 00:11:29 2016 kern.notice kernel: [ 1594.290000] sd 5:0:0:0: [sde] Attached SCSI removable disk
Fri Feb 12 00:11:29 2016 daemon.err block: failed to swapoff /dev/sdcard/sd2 (-1)
Fri Feb 12 00:11:29 2016 kern.info kernel: [ 1594.670000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:35 2016 kern.info kernel: [ 1600.820000]  sde: sde2
Fri Feb 12 00:11:36 2016 daemon.err block: failed to swapoff /dev/sdcard/sd2 (-1)
Fri Feb 12 00:11:36 2016 kern.info kernel: [ 1601.030000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:36 2016 daemon.err block: Unkown action change
Fri Feb 12 00:11:36 2016 kern.info kernel: [ 1601.390000] Adding 20k swap on /dev/sdcard/sd2.  Priority:-5 extents:1 across:20k
Fri Feb 12 00:11:40 2016 daemon.err block: failed to swapon /dev/sdcard/sd2 (-1)

I can add myself to having issues with the SD-card. It's mounted and all but when clients get connected and starts generating traffic and I've enabled tcpdump the network interface starts to disconnect and reconnect.

And in the dmesg I can see this:

[ 861.840000] device br-lan entered promiscuous mode

[ 948.240000] Write-error on swap-device (8:0:48)

[ 948.250000] Write-error on swap-device (8:0:56)

[ 948.260000] Write-error on swap-device (8:0:64)

[ 948.270000] Write-error on swap-device (8:0:72)

[ 948.270000] Write-error on swap-device (8:0:80)

[ 948.280000] Write-error on swap-device (8:0:88)

[ 948.280000] Write-error on swap-device (8:0:96)

[ 948.310000] Write-error on swap-device (8:0:104)

[ 948.310000] Write-error on swap-device (8:0:112)

[ 948.320000] Write-error on swap-device (8:0:120)

[ 948.330000] Write-error on swap-device (8:0:128)

[ 948.330000] Write-error on swap-device (8:0:136)

[ 948.340000] Write-error on swap-device (8:0:144)

[ 948.350000] Write-error on swap-device (8:0:152)

[ 948.430000] Write-error on swap-device (8:0:160)

[ 948.450000] Write-error on swap-device (8:0:168)

[ 948.490000] Write-error on swap-device (8:0:176)

[ 948.510000] Write-error on swap-device (8:0:184)

[ 948.510000] Write-error on swap-device (8:0:192)

[ 948.520000] Write-error on swap-device (8:0:200)

[ 948.550000] Write-error on swap-device (8:0:208)

[ 948.560000] Write-error on swap-device (8:0:216)

[ 948.560000] Write-error on swap-device (8:0:224)

[ 948.570000] Write-error on swap-device (8:0:232)

[ 948.570000] Write-error on swap-device (8:0:240)

[ 948.590000] Write-error on swap-device (8:0:248)

[ 948.610000] Write-error on swap-device (8:0:256)

[ 948.610000] Write-error on swap-device (8:0:264)

[ 948.640000] Write-error on swap-device (8:0:272)

[ 948.660000] Write-error on swap-device (8:0:280)

[ 948.700000] Write-error on swap-device (8:0:288)

[ 948.750000] Write-error on swap-device (8:0:296)

[ 948.790000] Write-error on swap-device (8:0:304)

[ 948.820000] Write-error on swap-device (8:0:312)

[ 948.830000] Write-error on swap-device (8:0:320)

[ 948.870000] Write-error on swap-device (8:0:328)

[ 949.020000] usb 1-1.3: USB disconnect, device number 11

[ 949.020000] rndis_host 1-1.3:1.0 usb0: unregister 'rndis_host' usb-ehci-platform-1.3, RNDIS device

So something seems to not work when using the SD-card. It's a Samsung SDHC-card of 32GB. I've formatted it through the webinterface and that doesn't help. Any help is appreciated. For a while I was thinking it was me who was crazy.. hah..

/crashie

Share this post


Link to post
Share on other sites

So something seems to not work when using the SD-card. It's a Samsung SDHC-card of 32GB. I've formatted it through the webinterface and that doesn't help. Any help is appreciated. For a while I was thinking it was me who was crazy.. hah..

/crashie

I've provided detailed logs in my other thread:

https://forums.hak5.org/index.php?/topic/37655-error-when-downloading-pcaps-from-the-nano/

Edited by crashie

Share this post


Link to post
Share on other sites

Hello again!

I wrote a post about problems with my connection to the pineapple a while ago and have solved that problem. it was just me who are a newbie learning.

I have now bought myself a microsdcard and want it to be recognized. 8 GB of storage.

What kind of filesystem should the sdcard have?

I have FAT32 right now i think.

And in what order should i connect it?
is there a guide/script i have missed?

Very happy with the nano. i have learned so much in the last two weeks.

Hope someone can help me!

Share this post


Link to post
Share on other sites

Hello again!

I wrote a post about problems with my connection to the pineapple a while ago and have solved that problem. it was just me who are a newbie learning.

I have now bought myself a microsdcard and want it to be recognized. 8 GB of storage.

What kind of filesystem should the sdcard have?

I have FAT32 right now i think.

And in what order should i connect it?

is there a guide/script i have missed?

Very happy with the nano. i have learned so much in the last two weeks.

Hope someone can help me!

When you are in the webinterface go to Advanced, press the arrow down beside "USB" and choose Format SD Card.

/crashie

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...