Jump to content
turtlebacon

Adding Additional WiFi Card

Recommended Posts

For the atheros chipset is it plug and play?

I have a proxim 8494 with an atheros chipset and it recognizes it when plugged but I'm not sure how to mount/initialize it. Since it doesn't show up on the interface list but it does is dmesg, I'm thinking there is no driver or I have to manually install it.

Thanks.

Edited by HammerHead_0718
  • Upvote 1

Share this post


Link to post
Share on other sites

It's difficult to say which brand and model adapters since chipset can change so it's best to go by chipset/driver.

Currently in 1.0.3 includes:

Basically anything Atheros

RaLink cards using the RT2800 driver

The Realtek RTL8187 and 8188CU drivers

The Ralink RT3070 chipset in the Alfa USB WIFI you sell seems to register properly and creates a wlan2

Thu Jan 14 06:31:57 2016 kern.info kernel: [ 1483.020000] usb 1-1.3: new high-speed USB device number 5 using ehci-platform

Thu Jan 14 06:31:57 2016 kern.info kernel: [ 1483.260000] usb 1-1.3: reset high-speed USB device number 5 using ehci-platform

Thu Jan 14 06:31:57 2016 kern.info kernel: [ 1483.400000] ieee80211 phy2: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected

Thu Jan 14 06:31:58 2016 kern.info kernel: [ 1483.500000] ieee80211 phy2: rt2x00_set_rf: Info - RF chipset 0005 detected

Thu Jan 14 06:31:58 2016 kern.debug kernel: [ 1483.530000] ieee80211 phy2: Selected rate control algorithm 'minstrel_ht'

Share this post


Link to post
Share on other sites

I'm seeing an issue where I connect with a usb wifi dongle at wlan2 to an access point (mobile hotspot). If client mode loses it's connection to the AP with wlan2, it will reconnect, but this time using wlan1. Same happenes on a reboot. If I'm accessing the GUI through an SSH tunnel, upon starting a Recon scan, wlan1 gets put into monitor mode and wlan2 doesn't reconnect, thus losing my access to the Nano. Only and physical restart solves this without having to ssh in over ethernet and shuffle radios around.

Has anyone gotten their USB WiFI adapter on wlan2 to succeessfully reconnect after a restart? Here are some config that might help diagnose.

# /etc/config/wireless
config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ehci-platform/usb1/1-1/1-1.1/1-1.1:1.0'
	option htmode 'HT20'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid 'Pineapple_77A9'
	option encryption 'none'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ehci-platform/usb1/1-1/1-1.3/1-1.3:1.0'
	option htmode 'HT20'

config wifi-iface
	option device 'radio2'
	option mode 'sta'
	option network 'wan'
	option ssid 'ZuneHD'
	option encryption 'psk2+ccmp'
	option key 'hunter2'

root@vegetable:~# lsusb
Bus 001 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

# after a reboot, whereas before the reboot, wlan2 was on ssid ZuneHD

root@vegetable:~# iwconfig
wlan2     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"ZuneHD"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: EA:85:50:86:4F:B6   
          Bit Rate=72.2 Mb/s   Tx-Power=30 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-29 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:9  Invalid misc:62   Missed beacon:0

Share this post


Link to post
Share on other sites

+1. Connects with wlan2. Eventually disconnects and reconnects with wlan1 for some reason. Even though /etc/config/wireless shows it's never been configured to. If I reboot, WLAN1 connects again.

/etc/config/wireless entry for wlan2

config wifi-device 'radio2'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/ehci-platform/usb1/1-1/1-1.3/1-1.3:1.0'
option htmode 'HT20'

config wifi-iface
option device 'radio2'
option mode 'sta'
option network 'wan'
option ssid 'ZuneHD'
option encryption 'psk2+ccmp'

option key 'hunter2'

dmesg output:

Bus 001 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

Edited by audibleblink

Share this post


Link to post
Share on other sites

+1 exact same issue, I choose Wlan2 from the drop down and type in password for AP and it connects , once I refresh the page it's connected using WLAN1 , and on reset it auto connects using WLAN1 even if Wlan2 is available,

Also disconnect doesn't work as it disconnects and just auto reconnects before I can ever get Wlan2 to connect, WLan1 reconnects too quick.

I've had to change AP password to prevent it auto connecting.

Is there ever a case when a user would want client mode in Wlan1?,

Share this post


Link to post
Share on other sites

The short version is that it's an issue with how the interfaces are being enumerated and our we use wlan1 in monitor mode. Seb can get into more of the specifics, but we were able to reproduce the issue today and are working on a fix.

A workaround may be to reset the wireless config, disable PineAP, reboot with the USB adapter plugged in, do client mode with wlan2 *then* re-enable PineAP.

Share this post


Link to post
Share on other sites

Same issue as reported in another thread. Reproduced it with Seb today and working on a fix. Has to do with the way interfaces are enumerated along with how we use the monitor interface for PineAP.

Share this post


Link to post
Share on other sites

Thanks for the work around , and I saw the latest video stating that 1.4 is going to be release in the next 24 hours, does this mean that this fix will make it to 1.4 or is it planned for 1.5?

Share this post


Link to post
Share on other sites

The short version is that it's an issue with how the interfaces are being enumerated and our we use wlan1 in monitor mode. Seb can get into more of the specifics, but we were able to reproduce the issue today and are working on a fix.

A workaround may be to reset the wireless config, disable PineAP, reboot with the USB adapter plugged in, do client mode with wlan2 *then* re-enable PineAP.

I had this same issue and followed the steps described as a work around, and it did end up working nicely.

Share this post


Link to post
Share on other sites

We will be releasing version 1.0.4 asap. It will contain lots of WiFi fixes and improvements.

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

Anyone tried the Alfa AC adapter?

Im thinking about getting that as its dual band.

Share this post


Link to post
Share on other sites

Any advice on setting up a Raspi Dongle? model :wlu6331 Any help is greatly appreciated. TY

When it comes to WiFi dongle support the make and model is must less significant than chipset and driver.

Make > Model > Chipset > Driver
                         ^-What concerns us

If you can provide detailed information about the dongle, such as the chipset and/or driver, that would be super helpful in determining support.

Just based on what's on my desk I that I've tested I can say with confidence the following dongles work with 1.0.5+

ALFA AWUS036NEH - Ralink RT3070 - https://hakshop.myshopify.com/products/alfa-usb-wifi-awus036neh

ALFA AWUS036H - Realtek RTL8187

ALFA AWUS036NHA - AtherosAR9271

Generic - Ralink RT5370 - https://hakshop.myshopify.com/products/ralink-usb-wifi-rt5370

Share this post


Link to post
Share on other sites

Will support be added for RTL8812AU chipset?

Share this post


Link to post
Share on other sites

When it comes to WiFi dongle support the make and model is must less significant than chipset and driver.

Make > Model > Chipset > Driver
                         ^-What concerns us
If you can provide detailed information about the dongle, such as the chipset and/or driver, that would be super helpful in determining support.

Just based on what's on my desk I that I've tested I can say with confidence the following dongles work with 1.0.5+

ALFA AWUS036NEH - Ralink RT3070 - https://hakshop.myshopify.com/products/alfa-usb-wifi-awus036neh

ALFA AWUS036H - Realtek RTL8187

ALFA AWUS036NHA - AtherosAR9271

Generic - Ralink RT5370 - https://hakshop.myshopify.com/products/ralink-usb-wifi-rt5370

Broadcom

BCM43143 chipset

​802.11b/g/n

Share this post


Link to post
Share on other sites

I'm aware and it's getting fixed ;)

Next firmware upgrade, along with lots of other small things.

Best Regards,

Sebkinne

I'm using Edimax nano-size wifi.

lsusb detects it,

Bus 001 Device 006: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

same for dmegs

[10658.560000] usb 1-1.3: new high-speed USB device number 6 using ehci-platform

[10658.690000] rtl8192cu: Chip version 0x10

[10658.870000] rtl8192cu: MAC address: 74:da:38:xx:xx:xx

[10658.870000] rtl8192cu: Board Type 0

[10658.880000] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1

[10658.880000] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin

[10658.890000] ieee80211 phy2: Selected rate control algorithm 'rtl_rc'

[10660.870000] rtl8192cu: MAC auto ON okay!

[10660.990000] rtl8192cu: Tx queue select: 0x05

but when I check the network interfaces (ifconfig or iwconfig) the wifipineapple stops responding, by console or web.

Is this device compatible with 1.0.5 ??

thanks.

  • Upvote 1

Share this post


Link to post
Share on other sites

Why add an additional card I'm not sure I understand. When I do usb tether on my phone doesn't the connected phones have access to Internet through my 4g connection? I have an alfa awus051nh but don't see how I can use /benefit from it.

Share this post


Link to post
Share on other sites

Why add an additional card I'm not sure I understand. When I do usb tether on my phone doesn't the connected phones have access to Internet through my 4g connection? I have an alfa awus051nh but don't see how I can use /benefit from it.

99% of the time I connect another card is for client mode. Yes, I could just tether it on my phone, but WiFi is faster for me a lot of times and doesn't run down my phone battery. And even though I have an "unlimited" data plan, I can't tether very much.

Or maybe you're trying to do multiple things at once on different channels.

I also seem to pick up more WiFi while wardriving if I use two. I guess one might miss a beacon, but the other will pick it up.

Share this post


Link to post
Share on other sites

Why add an additional card I'm not sure I understand. When I do usb tether on my phone doesn't the connected phones have access to Internet through my 4g connection? I have an alfa awus051nh but don't see how I can use /benefit from it.

To do the same without cable.

you can share 4g by wifi.

Share this post


Link to post
Share on other sites

could anyone help to enable or activate wlan2 on nano?

i have a tplink wireless adaptor connected to the nano usb

nano networking has no detected wlan2 and it does not show as an option

nano does not have the wifimanager module so this can not be used as an option

Share this post


Link to post
Share on other sites

could anyone help to enable or activate wlan2 on nano?

i have a tplink wireless adaptor connected to the nano usb

nano networking has no detected wlan2 and it does not show as an option

nano does not have the wifimanager module so this can not be used as an option

What chipset is your tplink wireless card?

Best Regards,

Sebkinne

Share this post


Link to post
Share on other sites

Based on comments in this thread, I'd love to see support for the Edimax nano-sized wifi (driver listed by bitxo). Also as commented, the ability to enter a hidden ssid for client mode.

Share this post


Link to post
Share on other sites

If you know what the driver for the Edimax nano is that might help them with adding it to the next firmware, As for the hidden SSID for client mode, Im hoping that is added to the new firmware also.

Share this post


Link to post
Share on other sites

Hi,

I had the same problem with the Edimax nano-sized usb dongle (EW-7811Un).

In order to fix the problem please use a newer wifi firmware file.

Overwrite rtl8192cufw_TSMC.bin to /lib/firmware/rtlwifi/ on wifi pineapple nano with an updated one.

I uploded my rtlwifi from an updated arch linux desktop 

https://mega.nz/#F!sN0V3IzZ!hz4x_wE5PnQZHRrZQ8EcZQ

If you don't trust my link, then just copy the file from your desktop :)

Best wishes,

shpala

Share this post


Link to post
Share on other sites
On 12/27/2015 at 9:56 PM, Darren Kitchen said:

wlan0 is for the Rogue AP. wlan1 is in a supporting sniffing and injection role. wlan1 can be used as a client interface, but you lose those PineAP functions. To provide the NANO with Internet access, eth0 or wlan0 are preferred, either tethering with a computer or smartphone. If you must use WiFi client mode it is best to use a separate adapter. Not all drivers for MK5 supported adapters have been baked into the initial NANO firmware. If you can provide the chipset and output of dmesg for the radio you wish to support that would be helpful. I can say from experience the Ralink 3070 in the ALFA AWUS036NEH works as well as the Atheros 9271. More adapters will be supported in time. Thanks for contributing feedback!

 

Hi Daren,

Does the name changes?

I am trying to add wifi adapter (RALINK5370) and doesn't seem to work. I get dropdown option only when i connect the wifi adapter, does that mean it is detected and i can use the same?

Below is the reading. I am getting wlan0 and wlan0-1 by default and once the wifi adapter is connected i get wlan1. But this always stays in off mode.

Before connecting wifi adapter:
root@Pineapple:~# iwconfig
lo        no wireless extensions.

usb0      no wireless extensions.

wlan0-1   IEEE 802.11bgn  Mode:Master  Tx-Power=17 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=17 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

br-lan    no wireless extensions.

root@Pineapple:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:91:9E:0B
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9292 errors:0 dropped:1591 overruns:0 frame:0
          TX packets:7620 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1333577 (1.2 MiB)  TX bytes:3297606 (3.1 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:91:9E:0B
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:654 errors:0 dropped:0 overruns:0 frame:0
          TX packets:654 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:56426 (55.1 KiB)  TX bytes:56426 (55.1 KiB)

usb0      Link encap:Ethernet  HWaddr 96:1C:52:E9:27:B7
          inet addr:192.168.42.189  Bcast:192.168.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2138 errors:0 dropped:10 overruns:0 frame:0
          TX packets:2024 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:979694 (956.7 KiB)  TX bytes:453328 (442.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:91:6F:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3060 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2805 (2.7 KiB)  TX bytes:433068 (422.9 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:91:6F:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10329 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10014 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1681829 (1.6 MiB)  TX bytes:3884867 (3.7 MiB)

---------------------------------------------------------------------
After connecting wifi adapter
root@Pineapple:~# iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

wlan0-1   IEEE 802.11bgn  Mode:Master  Tx-Power=17 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=17 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

br-lan    no wireless extensions.

root@Pineapple:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:91:9E:0B
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11389 errors:0 dropped:1591 overruns:0 frame:0
          TX packets:9965 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1701888 (1.6 MiB)  TX bytes:4256316 (4.0 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:91:9E:0B
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:660 errors:0 dropped:0 overruns:0 frame:0
          TX packets:660 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:56828 (55.4 KiB)  TX bytes:56828 (55.4 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:91:6F:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3095 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2805 (2.7 KiB)  TX bytes:445120 (434.6 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:91:6F:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12426 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12395 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2079498 (1.9 MiB)  TX bytes:4921454 (4.6 MiB)

Below is the post i am getting help from.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...