Jump to content

Recommended Posts

I've been getting my Nano all set up and am finally happy with how things are configured. It's my first Pineapple and so far I'm happy :)



One thing I've been having an issue with is adding an additional wifi card and getting it to work properly.



I have both the Alfa ASWUS036H and TP-LINK TL-WN722N...



The Alfa doesn't really detect properly as a wifi device but does show up in the lsusb command. I tried installing an opkg driver update for the realtek chipset and it seemed to install but not to help.



As for the The TP-LINK... It shows up in both lsusb and as a wireless device within the "Wi-Fi Clients" section on the "Networking" page within Pineapple admin interface. However.. when I try to use wlan2 (the TPLINK) to connect to a local AP, it ends up using wlan1 even though I have instructed it to use wlan2. Any thoughts? I think one time I was able to establish a link from wlan2 -> to local wifi network via the wifi client ... but as soon as I would start PineAP things would go haywire and quit working. Ideally PineAP should work fine since it's only using wlan1... some kind of conflict ?



My goal is to add a third wifi adapter so I can use it to connect to a local wifi network and bridge the internet access from that card over to any clients that connect.




Thanks in advance!


Link to post
Share on other sites
  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

The drivers aren't included in the current version. They are in 1.0.2 which should be released this week.

wlan0 is for the Rogue AP. wlan1 is in a supporting sniffing and injection role. wlan1 can be used as a client interface, but you lose those PineAP functions. To provide the NANO with Internet access,

Same issue here. wlan2 can scan for networks, but will not connect. wlan1 scans and connects to the same network just fine...but of course prevents pineAP. I'm using a AWUS036NHA from the hakshop.

Was contemplating the addition of a low-profile 11ac adapter off the USB port on end as well, to overcome the no 5 GHz thing. Would be interested in hearing thoughts on whether it's envisioned to be supported before I go that route.

Link to post
Share on other sites

turtlebacon, you mean to tell me that even though the Pineapple Nano has two interfaces, you can't use one to connect to a network and the other interface to host an AP and share access with it? Or is it just that one of those interfaces is being used for a pineapple function so you need to plug in a third to do everything you need?

I'm asking because I'm currently using my computer with two interfaces (one built in, the other an Alfa with AR9271) to host and AP with one and connect to wifi with the other (then forward internet from one to the other with iptables) so two interfaces seems all you need for that... However if I wanted to also have a device in monitor mode and running a pixie dust attack or something like that at the same time, I would need a third interface. Is this the issue, that other interface is just busy doing something for you so it can't be used as one of the two?

I want to know now that you brought this up as I was considering getting one just in order to not require me to use up my interfaces on my computer for this, and I could offload that and have the pineapple do it...

Who has this working with the Nano can you give some insight in how well it works for this function (connecting to wifi with one interface and sharing it with another)? Will it work as reliably and well as my current setup? Just looking for a solution where I can just have a little device help me with this, and the Nano with two interfaces built in seemed like the perfect thing!

EDIT: Thanks Darren that clears it up for me, technically I could if I was willing to sacrifice temporarily the PineAP functions while using wlan1 in WiFi client mode! Or just plug in my AR9271, or tether with a computer or mobile device and be able to use all functionality! :smile:

Edited by AlfAlfa
Link to post
Share on other sites

wlan0 is for the Rogue AP. wlan1 is in a supporting sniffing and injection role. wlan1 can be used as a client interface, but you lose those PineAP functions. To provide the NANO with Internet access, eth0 or wlan0 are preferred, either tethering with a computer or smartphone. If you must use WiFi client mode it is best to use a separate adapter. Not all drivers for MK5 supported adapters have been baked into the initial NANO firmware. If you can provide the chipset and output of dmesg for the radio you wish to support that would be helpful. I can say from experience the Ralink 3070 in the ALFA AWUS036NEH works as well as the Atheros 9271. More adapters will be supported in time. Thanks for contributing feedback!

  • Upvote 1
Link to post
Share on other sites

@AlfAlfa - It's exactly as Darren described. It's an asset and helps offload two full adapters into one device - and adding the third device is possible just will require some tinkering. No big deal.

My intention is to have the rogue AP (wlan0), the sniffing/injecting (wlan1), and 3g/internet access (wlan2) so that any combination is possible with ease. I just need to get a little more familiar with the commands needed and will probably try to make a module to simplify things.

@Darren - I'll follow up with a PM once I get the dmesg output and chipset info. I think the TP-Link is actually detecting properly but the software isn't liking when I tell wlan2 to be the wifi client - any thoughts on that? It scans with wlan2 but when I connect it reverts to wlan1.

Link to post
Share on other sites

I'm having the exact issue. I'm using a dongle w/ ralink 3070 chipset. Each time I've tried to connect to my home network with it (wlan2) its using wlan1 instead. And then PineAP doesn't work correctly. My wireless config file shows that radio2 is the USB dongle, and its setup for my home network, but it just doesn't work that way.

At one point both my PineAP and management APs got cleared. I used the "wireless detect...." command to reset and reboot and start again. All set back up, same issues.

root@Pineapple:~# lsusb
Bus 001 Device 005: ID 0e66:0017 Hawking Technologies HAWNU1 Hi-Gain Wireless-150N Network Adapter with Range Amplifier [Ralink RT3070]
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc.
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@Pineapple:~#

GNU nano 2.4.1                                       File: /etc/config/wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ehci-platform/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Pineapple_4B1A'
        option encryption 'none'
        option hidden '1'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option ssid 'PineAdmin'
        option key '***********'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option ssid 'Pineapple_70D7'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ehci-platform/usb1/1-1/1-1.1/1-1.1:1.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio2'
        option mode 'sta'
        option network 'wan'
        option ssid 'Crysis'
        option encryption 'psk2+ccmp'
        option key '******'

root@Pineapple:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:80:7C:2D
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:120231 errors:0 dropped:769 overruns:0 frame:0
          TX packets:243010 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5863570 (5.5 MiB)  TX bytes:363996938 (347.1 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:80:7C:2D
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:441 errors:0 dropped:0 overruns:0 frame:0
          TX packets:441 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:39629 (38.7 KiB)  TX bytes:39629 (38.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:8D:70:D7
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:8D:78:EA
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:244507 errors:0 dropped:49 overruns:0 frame:0
          TX packets:117164 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:364067172 (347.2 MiB)  TX bytes:9357441 (8.9 MiB)

wlan2     Link encap:Ethernet  HWaddr 00:0E:3B:33:4B:1A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:445 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:50255 (49.0 KiB)

wlan2-1   Link encap:Ethernet  HWaddr 00:0E:3B:33:4B:1B
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:117914 errors:0 dropped:0 overruns:0 frame:0
          TX packets:242627 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7246283 (6.9 MiB)  TX bytes:368760260 (351.6 MiB)

root@Pineapple:~#

Link to post
Share on other sites

Same issue here. wlan2 can scan for networks, but will not connect. wlan1 scans and connects to the same network just fine...but of course prevents pineAP. I'm using a AWUS036NHA from the hakshop. I tried with a little Edimax nano-sized wifi (much less conspicuous looking) but there doesn't seem to be support for it yet.

Seb I think we got a bug on our hands here :)

telot

Edited by telot
  • Upvote 1
Link to post
Share on other sites

Same issue here. wlan2 can scan for networks, but will not connect. wlan1 scans and connects to the same network just fine...but of course prevents pineAP. I'm using a AWUS036NHA from the hakshop. I tried with a little Edimax nano-sized wifi (much less conspicuous looking) but there doesn't seem to be support for it yet.

Seb I think we got a bug on our hands here :)

telot

I'm aware and it's getting fixed ;)

Next firmware upgrade, along with lots of other small things.

Best Regards,

Sebkinne

  • Upvote 1
Link to post
Share on other sites

I seem to have the same issue, but with a twist. I currently have ALFA AWUS036NH connected and it works great once. BUT now it won't show up in the WIFI Client Mode and to make matters worse it sees it as wlan0! Which I can't select on the Client Mode.--- any help is greatly appreciated. :smile: = :ph34r:

wlan0 Link encap:Ethernet HWaddr 00:C0:CA:36:63:36
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:30756 (30.0 KiB)

wlan1 Link encap:Ethernet HWaddr 00:C0:CA:8D:70:7D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan2 Link encap:Ethernet HWaddr 00:C0:CA:8D:78:CC
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Link to post
Share on other sites

Have also run into this using a RT5370 adapter.

1 Plugged in as wlan2

2 run a client mode scan, find a bunch of networks - unfortunately my hidden network doesn't show.

3 Tried an open network, it claimed to connect.

4 Refreshed the page and it had changed to wlan1, kicking off all PineAP functionality much like above posts.

5 Going to the PineAP page everything was unchecked except for daemon, which was still running somehow.

Is there a way to manually specify a hidden WPA2 network with proper credentials? Seems that only OPEN networks are showing up, is WPA not possible for client mode or something?

Edited by jujubes
Link to post
Share on other sites

Glad to read that! :smile:

Hells yeah! Thanks Seb!

telot

Link to post
Share on other sites

I've noticed that with another usb wifi card plugged in, client mode seems to randomly start on its own and connect to things using wlan2 or 3. I keep clicking disconnect, and yet every time I return to the Networking page, it's connecting to something at random again.

Because of this, it's killing off the PineAP settings (Allow + Log Associations, Probes) as well, though the daemon keeps running and everything is checked beneath it. Is this maybe caused by "Allow Associations" option?

How I discovered this is by first seeing a new client connect, and when I go to check it out everything is a * and no host name, then I checked the wifi card itself and it was lit up and blinking.

Edited by jujubes
Link to post
Share on other sites

I've noticed that with another usb wifi card plugged in, client mode seems to randomly start on its own and connect to things using wlan2 or 3. I keep clicking disconnect, and yet every time I return to the Networking page, it's connecting to something at random again.

Because of this, it's killing off the PineAP settings (Allow + Log Associations, Probes) as well, though the daemon keeps running and everything is checked beneath it.

How I discovered this is by first seeing a new client connect, and when I go to check it out everything is a * and no host name, then I checked the wifi card itself and it was lit up and connected, which is how I even noticed it, otherwise I would have assumed another client had actually connected!

As I previously stated, WiFi Clientmode is currently unstable / buggy with an external WiFi Card.

An update will be pushed most likely this week.

Best Regards,

Sebkinne

Link to post
Share on other sites

Trying to use my ALFA USB on the NANO.

When I plug it in I see this in DMESG:

[ 1128.700000] usb 1-1.3: new high-speed USB device number 5 using ehci-platform
And LSUB:
root@Pineapple:~# lsusb
Bus 001 Device 005: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc.
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
SO it appears to be seeing it but when I do IFCONFIG:
br-lan Link encap:Ethernet HWaddr 00:C0:CA:80:7C:2D
inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2214 errors:0 dropped:22 overruns:0 frame:0
TX packets:2310 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:538481 (525.8 KiB) TX bytes:979634 (956.6 KiB)
eth0 Link encap:Ethernet HWaddr 00:C0:CA:80:7C:2D
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2231 errors:0 dropped:0 overruns:0 frame:0
TX packets:2324 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:570497 (557.1 KiB) TX bytes:980278 (957.3 KiB)
Interrupt:4
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:118 errors:0 dropped:0 overruns:0 frame:0
TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9839 (9.6 KiB) TX bytes:9839 (9.6 KiB)
wlan0 Link encap:Ethernet HWaddr 00:C0:CA:8D:6F:E7
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:21361 (20.8 KiB)
wlan0-1 Link encap:Ethernet HWaddr 02:C0:CA:8D:6F:E7
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:20881 (20.3 KiB)
wlan1 Link encap:Ethernet HWaddr 00:C0:CA:8D:77:F8
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Any help?
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...