Jump to content

Recommended Posts

  • Replies 188
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Introduction: This process requires an Android phone capable of running the EasyTether app which can be downloaded here: http://www.mobile-stream.com/a/easytether-device.apk and also possibly an SD c

Sounds like your AT&T phone is doing something "special" with tethering. We're using the standard API AFAIK. Surely it's a matter of debugging. Here's a workaround until we can diagnose the idios

$$$$$

I can not get tethering to work on my Samsung Galaxy S4.

"Tethering Disabled

You must first configure USB Tethering."

When entering "Configure" i do not see "USB TETHERING" Any suggestions?

btw: when i connect the pineapple to the phone i hear a short "connect beep"

Ray

Link to post
Share on other sites

The first question is have you been able to tether your phone to any other device or if your provider allows for tethering as quite a few require a higher data plan or a fee to enable tethering on the phones?

Have not tried with other devices. I will check with the service provider if such a limitation exist.

Link to post
Share on other sites

I'm not sure what I've done with my nano.

I was working with it yesterday plugged into my Kali laptop. However today I've taken it out and plugged my phone into it to use it and I can't get logged in to it.

When I fire up the pineapple app and enable tethering, I get error invalid request or server failure. Http proxy.

And the IP I am getting is 192.168.42.71:1471.

I'm not sure this is correct and I've tried holding in the reset button for 6 seconds like Seb said in another thread.

Any idea what I did wrong with this thing?

Thanks.

Link to post
Share on other sites

I'm using the WiFi pineapple app. And I can't post any more posts today for some reason.

I open the app, it says to enable USB tethering. I hit configure, slide the slider. Then close that and it opens up a webpage and takes me to 192.168.42.1:1471.

Which then gives me the proxy error.

Its weird. It worked before I left the house.

Link to post
Share on other sites
Hmm your account should be active enough for unlimited posting. I'll look into it.


And that may not be the correct IP the app is finding. Mine for example was 192.168.42.145:1471


If you have a network discovery app, try running that and see what it finds on the 192 network.


Another possibility is the IP range may differ per device.

Link to post
Share on other sites

Okay, I am home now and on a laptop.

I can get logged in to the nano so long as my phone is connected to my home wifi. If my wifi on my phone is off, I can't seem to connect for some reason.

I must have been logged into wifi when I originally set up my nano.

Do I have some sort of a configuration problem maybe? Or is it an issue with my phone that my tethering isn't working? It's weird, as soon as I flip on wifi, I can access the pineapple. If I turn it off, I get this proxy error.

And thanks for the unlimited posting.

Link to post
Share on other sites

Yes, running the app takes me to the 192.168.42.71:1471 address and let's me log in.

If I shut off WiFi, I am no longer able to connect.

I guess I need to test connecting to the pineapple over WiFi with my laptop while my phone is tethered to make sure the pineapple is getting internet access.

Maybe I can test by connecting to my management AP.

Link to post
Share on other sites

I've seen some phones force WiFi disable on USB Tether (which is stupid, btw). Vanilla Android doesn't do this on my Nexus.

Now the behavior you're describing seems quite odd. I'd recommend tethering with your phone in a WiFi state, then connecting to the WPA management interface from your laptop, SSH in and test the connection. Also any output of ifconfig -a and dmesg would be helpful in further diagnosing the issue.

Link to post
Share on other sites

Similar behavior here. App states I need tethering enabled and kicks me over to Settings. I enable it and hit back and it still states it's disabled. SSHd in over ethernet and the Nano does indeed have a an IP and internet access. Running a CM13 nightly on a SIM-less WiFi only Galaxy S4. ¯\_(ツ)_/¯

Edited by audibleblink
Link to post
Share on other sites

At this point I think we have enough reports of the above described behavior to confirm this as a known issue. What we need to do is gather as much information as possible on which devices present the problem along with their carrier and OS details. It seems like not all phones use the standard USB Tethering mechanism or block incoming traffic over the shared network. We may be able to work around this using another means but we should confirm the exact cause of the issue first.

  • Upvote 1
Link to post
Share on other sites

What we need to do is gather as much information as possible on which devices present the problem along with their carrier and OS details.

How can we help? Is there a preferred means of reporting? What specific info about device/OS is helpful?

Device model: GT-I9505 (Galaxy S4)
Android 6.0.1
Kernel: 3.4.107-cyanogemod-g2cdea58
Link to post
Share on other sites

Sorry I've been away for a few days. Work has been crazy.

I haven't tried firmware 1.0.3 yet but I got my nano out while at hockey with my son but the battery isn't charged enough that I will fish upgrading the firmware.

As for my phone, I have a OnePlus One on the Bell Network in Canada. I have unlimited data and as far as I know Bell doesn't block my tethering ability at all. Its my work phone and I have some pretty good access on it. The OnePlus is actually mine, and I popped my work simcard in it.

It is all up to date with stock Cyanogen OS.

Anything I can help with more, or is this issue solved in 1.0.3?

Link to post
Share on other sites

On my Nexus (5 I think) running latest OS Chrome isn't saving and filling in the password properly, but on the desktop it works fine. Anybody else seeing this?

Also the Android device unfortunately charges from the USB port and it can't be turned off from the Android side I believe. Any adapters to alleviate this issue?

Ideally I'd like the Android to stay tethered throughout the day (without draining the Pineapple battery) and would autofill the password for quick access.

Thanks much

Link to post
Share on other sites

On my Nexus (5 I think) running latest OS Chrome isn't saving and filling in the password properly, but on the desktop it works fine.

Silly question, but is it filling in incorrect information that you've previously supplied that was also incorrect?

Have you tried:

  • clear cache, history, passwords etc
  • check 'save passwords' toggle?

maybe some more info on what happens when you say 'saving and filling in the password properly'

Link to post
Share on other sites

I have noticed similar behavior on my Nexus 5,

When you enable internet tether, android automagically assigns an address to your USB device via DHCP.

The problem is, at least on my Nexus 5, that Android doesn't have a way of recognizing what is the device that you are tethered to, so it assigns a new random IP each new time you plug it in or reboot it, therefore we are asking to remember the password only for that new IP each time... One time I was lucky to receive an address I had previously saved the password for and it logged me in right away.

To make things worse, the 172.16.42.0/24 network doesn't seem available from the Android device, at least from my testing (There might be some configuration I am not aware of for this) , so we can't connect to 172.16.42.1:1471 from the android device...

EDIT: This is also annoying when I try to use my Kali Nethunter Terminal to SSH into it, I have to copy the IP address from the browser and accept the 'new' fingerprint each time... pretty inconvenient I should say, I'd really like to do ' ssh 172.16.42.1 '.. instead of dealing with a new random address each time..

Suggestions are welcome, I'm out of clues ;)

Edited by PK_420
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...