Jump to content

webscarab error


Vurraz
 Share

Recommended Posts

Hello, I've tried using webscarab today to try to crawl a website...

I've noticed that webscarab uses 127.0.0.1:8008 as a proxy so I've set my Iceweasel browser proxy appropriately and when I tried navigating to the target website I've received this error in my browser, how do I fix it?

Please notice that I've replaced the actual domain name with 'xx' for discretion..

WebScarab encountered an error trying to retrieve
GET xx
Host: xx
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.5.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Referer: xx
Cookie: __cfduid=db03a54a38722d4dbc1fdca62cdd39c031450900438; __utma=169678269.239294492.1450900443.1450900443.1450907363.2; __utmz=169678269.1450900443.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); PHPSESSID=her04reoorrl33fe2isrf8hka1; __utmb=169678269.15.10.1450907363; __utmc=169678269; __asc=afdea951151d0d5e16a3fb78073; __auc=afdea951151d0d5e16a3fb78073
Connection: keep-alive
Cache-Control: max-age=0
The error was :
No appropriate protocol (protocol is disabled or cipher suites are inappropriate)
at sun.security.ssl.Handshaker.activate(Handshaker.java:470)
at sun.security.ssl.SSLSocketImpl.kickstartHandshake(SSLSocketImpl.java:1450)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1320)
at sun.security.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:721)
at sun.security.ssl.AppOutputStream.write(AppOutputStream.java:122)
at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
at org.owasp.webscarab.model.Request.writeDirect(Request.java:233)
at org.owasp.webscarab.model.Request.writeDirect(Request.java:214)
at org.owasp.webscarab.httpclient.URLFetcher.fetchResponse(URLFetcher.java:242)
at org.owasp.webscarab.plugin.openid.OpenIdHTTPClient.fetchResponse(OpenIdHTTPClient.java:59)
at org.owasp.webscarab.plugin.saml.SamlHTTPClient.fetchResponse(SamlHTTPClient.java:94)
at org.owasp.webscarab.plugin.proxy.CookieTracker$Plugin.fetchResponse(CookieTracker.java:130)
at org.owasp.webscarab.plugin.proxy.BrowserCache$Plugin.fetchResponse(BrowserCache.java:101)
at org.owasp.webscarab.plugin.proxy.RevealHidden$Plugin.fetchResponse(RevealHidden.java:100)
at org.owasp.webscarab.plugin.proxy.BeanShell$Plugin.fetchResponse(BeanShell.java:229)
at org.owasp.webscarab.plugin.proxy.ManualEdit$Plugin.fetchResponse(ManualEdit.java:243)
at org.owasp.webscarab.plugin.proxy.ConnectionHandler.run(ConnectionHandler.java:223)
at java.lang.Thread.run(Thread.java:745)
Link to comment
Share on other sites

Webscarab is trying to do an SSL handshake with... something, basically make the connection HTTPS, but the thing you're trying to talk with only speaks HTTP. That's why you get the error.

Like this:

Iceweasel <---> WebScarab <---> Website

When webscarab talks to Website, the communication there is expected by WebScarab to be HTTPS, but instead it's plain HTTP, which it apparently can't handle.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...