Jump to content

eth0 only works on 10Mbit/FD


ananas
 Share

Recommended Posts

Hi,

As far as I can remember I think my Mark V has always worked on 100Mbit/FD on its LAN port.

Recently I started having troubles with the device, couldn't reach it anymore through the LAN. As I wasn't actively using it at that moment I left it for what it was.

Now a few months later I wanted to get working on the device again and had to troubleshoot why I couldn't reach it anymore.

After a lot of testing and trying settings it seems I can only get layer 2 and higher connectivity when the device operates at a fixed linerate of 10Mbit/FD.

Things I have tested:

- Different (verified to correctly work) cables

- Different network devices

- Set speed/duplex on auto mode (this negociates the line to 100Mbit/FD on the Mark V side, the other side can't really get a connection, the line flaps really fast. If checked with ethtool 90% of the time it reports up and 10% of the time it reports down)

- Set speed/duplex fixed on 100Mbit/FD

- Upgraded firmware to latest version

- Tried different power adapter

I also wanted to try a full reset using the recovery firmware, however when I set the dip's to their correct positions I am unable to get a connection to the device. I did do a factory reset which didn't help.

Another thing I find mildly weird is that the device reports it can run on 1Gbit, however the Mark V specs say 100Mbit.

Below is the current output of ethtool with the speed/dup set to fixed.

root@Pineapple:~# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 10Mb/s
Duplex: Full
Port: MII
PHYAD: 4
Transceiver: external
Auto-negotiation: off
Current message level: 0x000000ff (255)
drv probe link timer ifdown ifup rx_err tx_err
Link detected: yes
Does anyone have any suggestions left I could try, or am I to accept that my LAN port is defective?
Edited by ananas
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...