Jump to content

Problem update lanturtle


kalebra
 Share

Recommended Posts

hi i have a problem with my lanturtle, i had updated the firmware and now i cant acces by ssh. The lanturtle dont give me ip so i put the ip with the range 172.16.84.1 but the problem is the access password of ssh that i dont know the new password, i have tried with ("sh3llz") and he doesnt run. somebody can help me? Thank you very much.

Link to comment
Share on other sites

  • 7 months later...
On 20-10-2015 at 5:40 PM, Mr-Protocol said:

Make sure you clear out your "known hosts" file to accept the new key to allow the connection.

If you have accepted the new key, and the default password and your original password do not work, you may need to follow the unbrick instructions:

http://lanturtle.com/wiki/#!index.md#Factory_Reset_/_%22Unbricking%22

HEllo Mr.Protocol,

were do I find de known Host? And were do I to copy  the latest factory image from https://downloads.lanturtle.com/turtle-2-factory.bin to? I ask this because I think I probably have the same problem as Kalebra. 

Link to comment
Share on other sites

The issue with being able to SSH to the LAN turtle after an update is with the known hosts file on your computer. It will vary depending on what OS you are on. Linux stores it typically in ~/.ssh/known_hosts and it should give you a command line option to remove specifically that one when it says they don't match.

As far as manually upgrading: https://lanturtle.com/wiki/#!index.md

Link to comment
Share on other sites

Well Mr. Protocol,

my problem is that connected over the Turtle with the internet both leds are blinking but I have no internet connection. When I go to the MD5 and download the  WinMD5free I can put in  MD5: 9270d5e6822299e180017e50628d6973  code as I did in the attachement then it matches ofcourse. But were do I find the default MD5 value and can I replace it by this new code? The operating system I am working in is Windows 7. When I start the putty it still says no internet connection.  So I can change or fill in anything. 

I hope you can help me on track anyhow.

REGARDS jOS

 

CHECKSUM Testprogramma.JPG

Link to comment
Share on other sites

I am confused on what you are doing.

The MD5 is just to verify the server side MD5 hash with your downloaded one to make sure the file is not corrupt before flashing. The MD5 should match.

View https://downloads.lanturtle.com/ for the latest firmware upgrade download and MD5 hash. Compare the MD5 hash on the site to the file you downloaded.

Then follow the manual upgrading instructions here: https://lanturtle.com/wiki/#!index.md

Plug in the LANTurtle to your computer's USB that has the upgrade firmware and allow Windows to install the driver and get an IP from the LANTurtle. Then proceed with using SCP (WinSCP tool is free for Windows) and following the above link instructions.

Make sure you DO NOT UNPLUG THE LANTURTLE while this is happening. If you do, it's a paper weight.

Give it plenty of time to flash.

Link to comment
Share on other sites

Hello Mr.Protocol,

I would like to explain what I did and Im doing so far and ask some questions to find out wether I am doing things right. First thing I did was the download of " Turtle-2.bin " file. It was downloaded in the Downloads map. I downloaded it from https://downloads.lanturtle.com/turtle-2-factory-bin as the instructions mentioned.  Viewing  https://downloads.lanturtle.com Turtle-2.bin should be Version 2 Update - MD5: 479ebbb06ceea051d383d2e635a08e18.  I choosed the Update !

My questions - Is the "Downloads" map correct, and if not which map do I have to choose.

                      - Do I somehow have to open the "Turtle-2.bin" file, and if yes with which program? 

Can you tell me if I did correct so far so that I can continue with  the further instructions?

Thank you so far,

Regards Jos

 

Link to comment
Share on other sites

If you just want to update it and it's working properly before that. Use the turtle-2.bin that was downloaded using the "UPGRADE" link.

Manually Upgrading
LAN Turtle firmware may be updated"over the air" by choosing Check for Updates from the Config menu. If an Internet providing Ethernet connection is not available, updates may be flashed to the device manually using the following process:

Download the latest UPDATE file from https://downloads.lanturtle.com/
Verify that the MD5 checksums match
Manually SCP the file to the LAN Turtle in /tmp (ex: scp turtle-2.bin root@172.16.84.1:/tmp/)
From the LAN Turtle, exit shell to the bash prompt and issue: sysupgrade -n /tmp/turtle-2.bin
Wait about 5 minutes for the LAN Turtle to flash the firmware and reboot

Link to comment
Share on other sites

Goodmorning Mr. Protocol,

The problem started as I wanted to update it on 30-5-2016 while working after the first installation. I did the procedure "Check for Updates from the Config menu" exactly as told in the installation video. The update started but  just stopped and did not continue not after 5 minutes and not after 30minutes. After that I had to pull out the turle because I needed the USB port for other activities. As I pushed in the LAN Turtle again only the green led burned. So I followed instructions opend up the Turtle and pushed in the Turtle with internet cabel while holding the button  3sec. Then the Green and orange leds were both burning. But still no internet connection.  So now I am working with a normal Internet connection,   

I checked if the downloaded  Turtle-2.bin file matched the Version 2 Update - Check for Updates from the Config menu : 479ebbb06ceea051d383d2e635a08e18. See Attachement  I did this check with the little program WinMD5 I found on the internet.

I think I did everything right. Now I am going to Push in the Turtle agai with internet cable holding button of Turtle 3sec.  Still no internet connection.        My next Question is - how do I  Manually SCP the file to the LAN Turtle in /tmp (ex: scp turtle-2.bin root@172.16.84.1:/tmp/) ? Can I do this with the program WinSCP? If yes what do I have to do?

Regards Jos

CHECKSUM Testprogramma II.JPG

Link to comment
Share on other sites

If you are trying to use the reset button to get it into recovery mode. Follow the instructions:

 

Factory Reset / "Unbricking"

In the extreme case that a LAN Turtle has become permenantly inaccessible or inoperative, there is a quick method for recovery using a special web interface.
  1. Download the latest factory image from https://downloads.lanturtle.com/turtle-2-factory.bin
  2. Carefully open the LAN Turtle case by removing the two screws underneath the sticker on the bottom
  3. While holding the button on the bottom of the LAN Turtle, plug the device into a computer
  4. After 3 seconds let go of the button and wait an additional 30 seconds to receive an IP address from the LAN Turtle
  5. If you do not receive an IP address in the 192.168.x range from the LAN Turtle within a minute, statically assign the LAN Turtle's interface to 192.168.1.2 (netmask 255.255.255.0)
  6. Browse to the LAN Turtle firmware recovery web interface at http://192.168.1.1
  7. Follow the on screen prompts to upload and flash the factory image downloaded in step 1
  8. When the flash is complete the LAN Turtle will reboot and will be accessible again from 172.16.84.1 with the default username root and password sh3llz

Those instructions will get you to a point where you can update if needed. I'm not sure if the factory image is fully up to date. 

Information on WinSCP can be found here. Basically it uses SSH credentials to secure copy files (SCP).

https://winscp.net/eng/docs/start

Link to comment
Share on other sites

Good Evening Mr.Protocol,

I think I did almost everything you asked for But I still got no IP-address from the Turtle.  I still also have some questions.

- When I download the turtle-2-factory bin file, as I mentioned before, it comes in the "download"map. Is this correct and is that just it? Don't I have to open this Bin- file somehow? Or has the file to be downloaded to a specific map?

- Further in you're instructions you say "If you do not receive an IP address in the 192.168.x range from the LAN Turtle within a minute, statically assign the LAN Turtle's interface to 192.168.1.2 (netmask 255.255.255.0)". How do I have to do this?

Regards Jos

 

Link to comment
Share on other sites

Hello Mr. Protocol,

I tried again today and did what you told me to do and somehow I think I a close but something is missing. So let show you the details of the LAN Connection and the Turtle Connection (see attachements). I hope you can tell me what I have to change and how to manage this. I also had a succesfull the LAN Turtle recovery upload. LAN Turtle Recovery mode starts downloading Firmware upload successful.JPG

Details Turtle Connection.JPGDetails Turtle Connection.JPG

Link to comment
Share on other sites

Hello Mr-Protocol,

Finally I got the Turtle running again. Before that I made some changes in the windows network environment (See Attachement). Impotant ofcourse is the fact to enable DHCP and let the computer automatically asign an IP address. 

Thank you so far,

Regards Jos

Correcte Turtle Netwerk Instelling II (via geavanceerd).JPG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...