Jump to content

Rogue DHCP on Mk5


Dice
 Share

Recommended Posts

'Ello
I recently upgraded to the latest Firmware 2.4.0 and the upgrade reset my MK5 to factory defaults.
I have the eth0 connected to cable, standard config :
IP 172.16.42.1/24
DefGw 172.16.42.42
DNS 8.8.8.8
Wlan1 is connected to an isolated wlan on my router with internetaccess in client mode.
Since the upgrade the DHCP server from the Mk5 is overruling the dhcp server of my router.
Here is my problem :
Since the upgrade the DHCP server from the Mk5 is overruling the dhcp server of my router.
Normal (authorised) clients on my own wlan are getting DHCP adresses from the MK5 (172.16.42/24 defgw 172.16.42.42)
while NOT connected to the isolated network.
is there a way to prevent ETH0 to pass on the DHCP requests and isolate the DHCP answers to the wlan requests only ??
In other words; remove the binding of DHCP on the eth0 ?
note : I have not seen this behaviour prior to the upgrade.

kind regards

./Dice

Link to comment
Share on other sites

Have you enabled Client Mode in the Wired tab, in the Network tile?

Classic Mode is the original (classic) Wired network mode where eth0 is bound to br-lan and the inbuilt DHCP server. This is the mode to use if you want to connect a computer directly to the WiFi Pineapple via Ethernet.

Client Mode is for when you want to connect the WiFi Pineapple to an existing wired network. You can then enable DHCP (the WiFi Pineapple will get an IP address, gateway, etc. for eth0 from an existing DHCP server on the wired network)... or you can set a Static IP address, Netmask, Gateway and DNS entries manually if you wish.

You don't want to have Classic Mode enabled when you connect to an exisiting wired network. Two competing DHCP servers on the one network will only invite confusion.

Lunokhod.

Link to comment
Share on other sites

Changed it to the settings as you said:

Used the standard setting for the eth0 as i am using a small VM to control it on the same subnet.

clients on my internal lan have not had problems getting the correct scope now.

Now will have to see if the dhcp server on my lan wont be used for distributing IP's on the Wlan i am setting up as a honeypot.

(Eg ; they will have to get an ip in the 172.16.42.xxx scope > 100)

Two competing DHCP servers on one net is asking for trouble indeed.

Thanks so far

./Dice

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...