Jump to content

DNS-Server settings


BeNe
 Share

Recommended Posts

The Turtle runs a local DNS Server per default and use it. I just checked resolv.conf. The Problem is that if you deploy it inside a company no internal DNS Name will be resolved.

It doesn´t get quicker to find the turtle if you add it to a pc, beacause the person that uses the pc can´t work anymore.

Just added it to my pc in the company and i was unable to access the file or mail server (srv-exchange.internal.a-company.com).

If i add the DNS manually on the interface to the correct internal DNS it works.

Is there a workaround ?

The Turtle should use the DHCP provided DNS Server - until you active a DNS Module for a man in the middle attack.

Or did something wrong ?

Thanks & Greez

Link to comment
Share on other sites

The /tmp/resolv.conf.auto is automagically consulted by the dnsmasq configuration. This file contains the DNS servers provided by the DHCP lease to eth1. (LAN side)

Lookups over 127.0.0.1 will be forwarded to this nameservers. There is no need to manual change the /etc/resolv.conf.

  • Upvote 1
Link to comment
Share on other sites

I am also having issues with internal DNS. Whenever I plug the turtle into a computer, only internal IP addresses work and not DNS. For example, I am able to ping IP's, but not hostnames and I can browse to say our internal mail server by IP, but not DNS. Is this something I have to set manually. We run DHCP.

Link to comment
Share on other sites

  • 1 year later...
On 9/10/2015 at 8:35 AM, compiledkn said:

I think it can be solved by setting 'option rebind_protection' to 0 in /etc/config/dhcp. A reload of dnsmasq is required. (/etc/init.d/dnsmasq reload or a power-cycle)

I've been having the same problem as the OP.  This config change from compliedkn worked like a charm.  Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...