Jump to content

Gateway always sets to the default - 172.16.42.42


SnuggleTwin
 Share

Recommended Posts

When connecting my test laptop to the Pineapple's AP the default gateway that is assigned is always 172.16.42.1 even though it hasbeen set to 192.168.0.200In the Pineapple's network settings page this is what the Routes are set at:Kernel IP routing tableDestination     Gateway         Genmask         Flags Metric Ref    Use Ifacedefault         192.168.0.200   0.0.0.0         UG    0      0        0 eth0192.168.0.0     *               255.255.255.0   U     0      0        0 eth0192.168.0.0     *               255.255.255.0   U     0      0        0 br-lan

The wired Internet Settings are set to Client Mode with these settings:

Static:

IP 192.168.0.166

NetMask:255.255.255.0

Gateway: 192.168.0.200

DNS.75.75.75.75

Local Network Settings:

IP 192.168.0.166

NetMask:255.255.255.0

Gateway: 192.168.0.200

DNS.75.75.75.75

The laptop is setup to obtain an IP address automatically. IP config shows:

IP:192.168.0.115

Subnet: 255.255.255.0

Default Gateway: 172.16.42.1

The Pineapples DHCP settings seem to point to the problem.....:

From the file: /etc/config/dhcp

option 'filterwin2k' '0'
option 'localise_queries' '1'
option 'rebind_protection' '1'
option 'rebind_localhost' '1'
option 'local' '/lan/'
option 'domain' 'lan'
option 'expandhosts' '1'
option 'nonegcache' '0'
option 'authoritative' '1'
option 'readethers' '1'
option 'leasefile' '/tmp/dhcp.leases'
option 'resolvfile' '/tmp/resolv.conf.auto'
config 'dhcp' 'lan'
option 'interface' 'lan'
option 'start' '100'
option 'limit' '150'
option 'leasetime' '12h'
option 'ignore' '0'
list 'dhcp_option' '3,172.16.42.1'
list 'dhcp_option' '3,172.16.42.1'
list 'dhcp_option' '6,172.16.42.1'
list 'dhcp_option' '6,172.16.42.1'
It looks like I am going to have to change the settings in /etc/config/dhcp via a terminal connection and that the interface that is designed for this in the Pineapple is not updating as expected. Any insight in this would be greatly appreciated, thanks!
Link to comment
Share on other sites

i was able to get the proper Gateway assigned by changing the list list 'dhcp_option' '3,172.16.42.1' to the gateway address. I also assigned the correct DNS server address.
Now on my laptop all of the network information is correct.

Using a NetGear router AP with the same net configuration everything works as expected, I can access the internet as expected via our gateway.
Using a Cisco router AP it also works as expected
Using a Linksys router AP it also works as expected

It looks like the functionally surrounding the 'Client Mode' is not working properly. If an Ethernet connection is used the Pineapple does not allow connectivity though the gateway.

If anyone can confirm this it would be very helpful thank you!

Link to comment
Share on other sites

  • 1 month later...

i can confirm the same issue, once i use "client mode" on the wired connection tab i don't have internet access.

i used as parameters:

default 192.168.1.254 0.0.0.0 UG 0 0 0 wlan1

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 wlan1

once i use recon mode or pine ap i will lost the internet connection so does the client connected thru the mark5

using last firmware available 2.4.0

Link to comment
Share on other sites

i can confirm the same issue, once i use "client mode" on the wired connection tab i don't have internet access.

i used as parameters:

default 192.168.1.254 0.0.0.0 UG 0 0 0 wlan1

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0

192.168.1.0 * 255.255.255.0 U 0 0 0 wlan1

once i use recon mode or pine ap i will lost the internet connection so does the client connected thru the mark5

using last firmware available 2.4.0

PineAP / Recon mode make use of wlan1, therefore breaking internet connectivity.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...