Jump to content

Help with access denied when trying to do a privilege escalation


aceforsale
 Share

Recommended Posts

I have a Red Hat Linux 3.2.2-5 VM with a 2.4.20-8 kernel.

I am logged on as a basic user currently and am trying to perform a Privilege Escalation.

I was told by a good resource to use the working privilege escalation for this box at:

http://www.rmccurdy.com/scripts/downloaded/localroot/2.4.20/

I've saved them all and when I try to run them using (Ex: ./kmod)

It always comes back at Permission Denied

I've found three other .c scripts at exploit-db.com (binfmt_elf.c & pwnedUselibKernelExploit.c & mremap_poc_2.c) but I also get access denied trying to run the using ./program

I've tried running gcc for the .c files but I get "gcc: command not found".

What am I missing to get these exploits to run?

---

when I ran ./ptrace it started to do something but just hanges at

attached

exec ./insert_shellcode 2149

Thank you.

Link to comment
Share on other sites

I've tried running gcc for the .c files but I get "gcc: command not found".

What am I missing to get these exploits to run?

Is this for some education you're getting or are you teaching yourself or... what?

If you get that specific error and you don't know what's going on (the error is fairly self-explanatory) you shouldn't (yet) be messing with exploits and such. You're effectively trying to operate an F1 race car before learning to crawl. Get a book on basic Linux administration and read it.

To not leave you hanging completely, try a few of these commands:

"man gcc"

"find / -name gcc"

"ls -al $(which cc)"

If you don't understand what these commands do, DON'T FUCKING RUN THEM! I could be harvesting your machine for my botnet for all you know.

And please understand that the same goes for those exploits you mention. If you don't understand what they do how can you be sure they do what you want them to do?

Link to comment
Share on other sites

I was thinking the same thing, if you don't understand what gcc is and can't read the error message then you need to go back to basics and learn those before trying to mess with privilege escalation.

From the versions you've given I know the vulnerability you are trying to exploit, are you doing one of the Offensive Security courses by any chance?

Link to comment
Share on other sites

  • 9 months later...

If you read some of the replies already given in this thread 8 months ago you should know that what you describe isn't the solution.

In fact "chmod 777" on anything is NEVER the solution.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...