Jump to content
Hak5 Forums
Darren Kitchen

[GUIDE] Manually updating the LAN Turtle

Recommended Posts

I write this guide while at DEF CON realizing that many people are going to want to update to the latest version of LAN Turtle and may not readily have access to an Ethernet connection to provide the LAN Turtle with an Internet connection. So rather than using the "over the air" upgrade method of going to Config -> Check for Updates, please follow these steps:

1. Download the latest UPDATE file from https://downloads.lanturtle.com/

2. Verify that the MD5 checksums match

3. Manually SCP the file to the LAN Turtle in /tmp (ex: scp turtle-2.bin root@172.16.84.1:/tmp/)

4. From the LAN Turtle, exit shell to the bash prompt and issue: sysupgrade -n /tmp/turtle-2.bin

5. Wait about 5 minutes for the LAN Turtle to flash the firmware and reboot

When you SSH back in keep in mind the password resets back to the default "sh3llz" (and is required to be changed)

  • Upvote 2

Share this post


Link to post
Share on other sites
demarti   

Hi Darren,

I was able to ssh into the LAN Turtle but even with an Internet connection, I was getting an error:

-> The LAN Turtle is currently offline. Please check your internet connection.
So I then tried the manual upgrade:

root@turtle:~# sysupgrade -n /tmp/turtle-2.bin

killall: watchdog: no process killed
Sending TERM to remaining processes ... ubusd askfirst logd netifd odhcpd atd hts ptunnel S95done sh dnsmasq
Sending KILL to remaining processes ... S96led
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...
Writing from <stdin> to firmware ...
Upgrade completed
Rebooting system...
But now I'm unable to ssh into 172.16.84.1 using root like before.
$ ssh -l root 172.168.84.1
ssh: connect to host 172.168.84.1 port 22: Operation timed out

Any ideas on how to get back into the Turtle interface?

Thanks.

Share this post


Link to post
Share on other sites
demarti   

It seems that the device's orange light isn't flashing anymore, showing no Internet activity and unable to get DHCP anymore.

Any suggestions or advice you may have will help thanks.

Share this post


Link to post
Share on other sites
Onus   

I just got my lan turtle in the mail and immediately am having the same problem as demarti..  when i ssh-ed into the turtle the first time i immediately went to the config menu and checked for upgrade.. i know its online.. my laptop has internet on the same network and the router that the lan turtle is plugged into sees the turtle as connected.. but i too get the following error:

-> The LAN Turtle is currently offline. Please check your internet connection.

I followed the manual upgrade above, and still same problem. Thinking, maybe it just means i don't need and upgrade and is a bad message.

I went to module manager and i was able to download QuickCreds, but again when i go to QuickCreds configure, i get the damn offline message..

I am so so so sad.. please help Mr Kitchen!  i buy lots of stuff from you..

@Darren Kitchen

oh.. and i am guessing its not offline, as the laptop im using is only connected to the internet via the turtle and im writing this from that connection now.. also, if it was offline why would i have been able to download Quick/cred'

 

Edited by Onus

Share this post


Link to post
Share on other sites
Onus   

i like an idiot have an xfinity router, had to set the firewall settings to LOW and then i could update.. i guess the offline message is because these scripts use a "ping" to test update and pings were being blocked by my firewall settings

 

Share this post


Link to post
Share on other sites
Sebkinne   
3 minutes ago, Onus said:

i like an idiot have an xfinity router, had to set the firewall settings to LOW and then i could update.. i guess the offline message is because these scripts use a "ping" to test update and pings were being blocked by my firewall settings

 

That would do it :)

Share this post


Link to post
Share on other sites
lumin   

Hi there eny help please i did factory reset 2 times but it stuck in rebooting system let it more then 15 minutes and get nothing PLZ help 

Thank you

Share this post


Link to post
Share on other sites

"The Lan Turtle is currently offline. Please check your internet connection"

So I followed all the recommendacities, no joy. I enabled and configured ICS for HTTPS and HTTP. I now have connectivity on a shared internet connection with my Winblows7 pc. I made a short slide show that shows both the current state of my network and the the lights on the turtle. I have connectivity. I can ping the LT ONCE and it pukes. I still cannot download modules.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×