Jump to content

Nmap log trouble


telot
 Share

Recommended Posts

Hey guys - When I try to run the nmap scan, I'm not able to configure a log location. I select the "Log - Choose Log Location" from the turtle gui, but I don't go to another screen, it just flashes the same screen.

I setup sshfs just fine so I don't clog up the internal storage on the device, so ideally I'd point the nmap to /sshfs. Any ideas? Known bug? Anyone else able to reproduce this?

Thanks in advance

telot

Edited by telot
  • Upvote 1
Link to comment
Share on other sites

Having the same issue with every module it seems. SSHFS is enabled and functioning, but when you try to configure modules to save the log using sshfs, it doesn't work. Quite a pita.

Using urlsnarf and you can start it, but it doesn't log anywhere. If you go to configure and you tell it to save the log location to /tmp or to SSHFS, it selects, you hit ok, go back into the configuration and it's right back to "do not save log file".

I've tried several things, like rebooting the turtle and rebooting my linux machine, but nothing works reliably. I'm getting to the point, just like with the Pineapple, of just using the command line and running things manually.

Link to comment
Share on other sites

If you go into the CLI and head into the /etc/config directory, you'll find the nmap config file. You can edit it and add a line, "config 'log' " (no quotations) into the file and save it. That allowed me to set the log directory within the Turtle Shell GUI.

  • Upvote 2
Link to comment
Share on other sites

Awesome RussDR - thanks for checking this out. Unfortunately I wasn't able to repeat your success. I changed the /etc/config/nmap file like you suggested, as seen below:

config 192.168.1.1 'target'

config 7 'profile'

config 'log'

Saved it and went back to the turtle gui - when I try to configure the log location, I get the same slight screen refresh, and no entry to the menu. Can you share what your /etc/config/nmap file looks like after you've configured it within the module? Maybe I can just manually enter it and it will work then? I tried:

config /sshfs 'log'

but to no avail. Any additional help would be much appreciated!

telot

Link to comment
Share on other sites

ha! Not one minute later, I changed it to:

config /sshfs/ 'log'

and BOOM it works. Can't believe I zoned out not the last "/". Cheers!

telot

Edited by telot
  • Upvote 1
Link to comment
Share on other sites

Awesome RussDR - thanks for checking this out. Unfortunately I wasn't able to repeat your success. I changed the /etc/config/nmap file like you suggested, as seen below:

config 192.168.1.1 'target'

config 7 'profile'

config 'log'

Saved it and went back to the turtle gui - when I try to configure the log location, I get the same slight screen refresh, and no entry to the menu. Can you share what your /etc/config/nmap file looks like after you've configured it within the module? Maybe I can just manually enter it and it will work then? I tried:

config /sshfs 'log'

but to no avail. Any additional help would be much appreciated!

telot

I'm glad it worked out for you!

Link to comment
Share on other sites

  • 2 weeks later...

Found a different workaround, exit and type:

# uci set nmap.log="/sshfs"
# uci set nmap.profile="10"
# uci commit

Then the script will run and log to the remote fs. (no trailing slash needed here, and choose whatever profile you want ;)

  • Upvote 1
Link to comment
Share on other sites

Found the fix for /etc/turtle/modules/nmap-scan : a default putty window is 80x24 which requires the dialog --dselect option to use a height of 14 or less (not 18). The dialog program errors off if it can't create the window (tried -1 but it doesn't work). Height and width are at the end of line 162 (and you can delete the second --title too).

Neither the nmap-scan profile nor the log file UI screens will show you your previously selected and saved values: dialog --dselect doesn't take a default value, and dialog --radiolist needs a bunch more fancy shell script work.

  • Upvote 2
Link to comment
Share on other sites

  • 1 month later...

Found the fix for /etc/turtle/modules/nmap-scan : a default putty window is 80x24 which requires the dialog --dselect option to use a height of 14 or less (not 18). The dialog program errors off if it can't create the window (tried -1 but it doesn't work). Height and width are at the end of line 162 (and you can delete the second --title too).

Neither the nmap-scan profile nor the log file UI screens will show you your previously selected and saved values: dialog --dselect doesn't take a default value, and dialog --radiolist needs a bunch more fancy shell script work.

That's it!!
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...