Jump to content

RTL-SDR stopped working.


Recommended Posts

It's been a few months since I last played with my RTL-SDR and since then I've moved to Ubuntu MATE and IIRC it was working under Ubuntu MATE but now it's not working. I get this error message:

Kernel driver is active, or device is claimed by second instance of librtlsdr.

In the first case, please either detach or blacklist the kernel module

(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6

FATAL: Failed to open rtlsdr device.

Trying to fill up 1 missing channel(s) with null source(s).

This is being done to prevent the application from crashing

due to gnuradio bug #528.

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::math::rounding_error> >'

what(): Error in function boost::math::round<f>(f): Value -inf can not be represented in the target integer type.

Aborted

Not really sure what's going on. I'd like to figure it out so I can get it working again. Any ideas? Thanks.

Link to comment
Share on other sites

It looks like Ubuntu is automatically loading the builtin kernel module for the dvb tuner. Try running

sudo rmmod dvb_usb_rtl28xxu

and see if it works. It it does, then you can make the change permanent (after reboot) by creating "rtlsdr.conf" in "/etc/modprobe.d" and put

blacklist dvb_usb_rtl28xxu

in it. Hope that helps!

Link to comment
Share on other sites

Kernel driver is active, or device is claimed by second instance of librtlsdr.

This is what's going on. The rtl-sdr device is claimed by another program already. So what you should do is try and find the program that might be responsible. Take a long, hard look at the output of ps and check its man page for some sensible options. I normally go for 'ps -faux'. If there's nothing in that list that you think or know to be using the device, go for the first suggestion - a kernel driver that claimed the device. Run 'lsmod' to see if any bad kernel modules got loaded and are now getting in the way. You can remove them with 'rmmod' but be careful you know for a fact you don't need that module or you'll end up needing to reboot.

If you still can't figure it out, remove the device and re-insert it. The program using the device should either stop, crash or lock up. Even when it locks up and keeps a hold of the now absent device, when you re-insert it the USB stack should create a new device node so when you start your sdr program again it should now find it.

Link to comment
Share on other sites

Thanks for the info guys. I'll give all of it a try and see if I can get it working.

Edit for addtional info.

The "sudo rmmod dvb_usb_rtl28xxu" worked to get it up and running. Guess I just need to blacklist it by by creating "rtlsdr.conf" in "/etc/modprobe.d" and putting "blacklist dvb_usb_rtl28xxu" in it. Thanks again guys.

Edited by TN.Frank
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...