Jump to content

Newb: Ubuntu Internet Sharing. Can't get it working


MacDaddy
 Share

Recommended Posts

OK, I know I am doing something wrong, but I have no idea what. I've tried a few times now, read the instructions, watched the video and I can't this working for the life of me. I am running a Dell Latitude 2100 running Ubuntu. I am not a big Terminal user, but I can follow directions and know a little of how to do things. I can't seem to find anything on the forums for similar issues (Though it could be the terms I'm searching), so if I missed a solution I apologize.

If the Pineapple is connected via Ethernet, I can access it, but I can't access the internet via WiFi. If I disconnect, no problem at all.

So I downloaded and ran the wp5 file, and get the prompts, but the Internet Gateway shows the Pineapple IP. So no internet, but access to Pineapple is OK. If I try and check for updates, I get an error saying it can't connect. Here is the wp5 output

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: 
Internet Gateway [172.16.42.1]: 
IP Address of Host PC [172.16.42.42]: 
IP Address of Pineapple [172.16.42.1]: 

     _ .           ___          \||/   Internet: 172.16.42.1 - wlan0
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0
SIOCDELRT: No such process
SIOCADDRT: Network is unreachable

Browse to http://172.16.42.1:1471

Now, if I unplug the Pineapple from my Ethernet port, and run again, I get this:

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: 
Internet Gateway [192.168.1.254]: 
IP Address of Host PC [172.16.42.42]: 
IP Address of Pineapple [172.16.42.1]: 

     _ .           ___          \||/   Internet: 192.168.1.254 - wlan0
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 172.16.42.42
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0

I get this. I did ifconfig and checked the IP and such and tried the below, manually adding the IP and the mask, but get the error included.

Pineapple Netmask [255.255.255.0]: 
Pineapple Network [172.16.42.0/24]: 
Interface between PC and Pineapple [eth0]: 
Interface between PC and Internet [wlan0]: 
Internet Gateway [172.16.42.1]: 192.168.1.254
IP Address of Host PC [172.16.42.42]: 192.168.1.70
IP Address of Pineapple [172.16.42.1]: 

     _ .           ___          \||/   Internet: 192.168.1.254 - wlan0
   (  _ )_  <-->  [___]  <-->  ,<><>,  Computer: 192.168.1.70
 (_  _(_ ,)       \___\        '<><>' Pineapple: 172.16.42.0/24 - eth0
SIOCDELRT: No such process

So... Really not sure what I am doing wrong or how to get this to work. I've tried 4-5 times and get some variation of the above depending on what info I try.

Can anybody offer any suggestions or solutions? I'm baffled!

Thanks in advance.

Link to comment
Share on other sites

Connect your laptop to your WiFi that has internet

Disable network manager on Ubuntu.

Run the wp5.sh and make sure the interfaces reflect what they are in regards to internet and pineapple connection.

Another thing to try, is open network manager and create a static setting for your ethernet port called pineapple. Set the ip address and gateway, then save. Now select it from the icon on the desktop. Then run the wp5.sh script.

Link to comment
Share on other sites

Mr-protocol,

Couldn't get that working either. I was on WiFi and had connection, but when I disable Network Manager then I lose all connections. Am I missing a step here?

Barry,

Set the static IP as whatever the Pineapple is giving it over DHCP? And what icon on th desktop, I don't have any icons on my desktop...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...