Jump to content

Connecting to internet using ethernet (client mode)


markcoker
 Share

Recommended Posts

So i have a fresh install, default settings. I changed wired to client mode (DHCP).

My understanding this should work but it is unable to access the internet, no ip address is received (eth0).

Router(DHCP Enabled, standard setup other devices work. IP: 192.168.1.1) <-----> WifiPineapple (default settings except now in client mode).

any ideas or hints?

[side issue] Pineapple doesn't detect my access point (wireless) anymore, it used to work fine, no settings have been changed and is in range.

Edited by markcoker
Link to comment
Share on other sites

It does work for me and on the latest firmware. I would suggest before ruling it as something wrong with the pineapple, have you tried it on a different router?

Have you factory reset the pineapple?

Have you tried to verify that all settings on the internet providing are correct, and or on the pineapple?

Link to comment
Share on other sites

other devices are getting dhcp assigned addresses, i haven't tried another router but i currently think its unlikely that it will be the router. cable seems fine, I've tested it.

i have factory reset pineapple, I believe i have all the correct settings, i don't believe there is much required to be set on the pineapple correct? for "normal setup" in client mode.

Link to comment
Share on other sites


[ 197.860000] eth0: link up (100Mbps/Full duplex)

[ 197.860000] br-lan: port 1(eth0) entered forwarding state

[ 197.870000] br-lan: port 1(eth0) entered forwarding state

[ 199.870000] br-lan: port 1(eth0) entered forwarding state

[ 201.860000] eth0: link down

Repeats


config interface 'loopback'

option ifname 'lo'

option proto 'static'

option ipaddr '127.0.0.1'

option netmask '255.0.0.0'

config interface 'lan'

option type 'bridge'

option proto 'static'

option netmask '255.255.255.0'

option dns '8.8.8.8'

option ipaddr '172.16.42.1'

option gateway '172.16.42.42'

config interface 'wiredwan'

option proto 'dhcp'

option ifname 'eth0'

# Failed client mode dhcp setting above (current settings)

# My attempt at static below (its been a while but i believe it should work but it doesnt)

# option proto 'static'

# option netmask '255.255.255.0'

# option dns '8.8.8.8'

# option ipaddr '192.168.1.200'

# option gateway '192.168.1.1'

config interface 'wan'

option proto 'dhcp'

Edited by markcoker
Link to comment
Share on other sites

  • 1 month later...

Doesn't work for me either. I can set a static ip address, but it still doesn't route to the internet. DHCP does nothing.

@DataHead, this is for wired, not wireless client mode. Wireless client mode works as advertised.

Edited by barry99705
Link to comment
Share on other sites

When trying the wired client mode with dhcp, I can see that my dhcp server issues an ip address. The pineapple does apply the issued address on the eth0 nic, and the correct default gateway is set in the routing table.

Internet access is not working however, nor is the address reachable in any way.

could this be an iptables issue ?

Link to comment
Share on other sites

ok, finaly figured this out. Took me a while since i've never used the Pineapple before (unboxed it yesterday, so wasn't clear how the hardware was configured) ...

Current status : Wired client mode is working as described in the guides.

Description of the problem i had : when using wired client mode with dhcp, the Pineapple received and applied the issued ip address from the dhcp server, routing table was updated correctly, however no inbound or outbound communication was possible over the eth0 nic.

Why it took so long to figure out : i am a complete novice to Pineapple and was not aware of how the nic configurations were done on the box. Since the Pineapple received a correct dhcp address i mistakenly concluded that all was working fine on the network layer. So after a few hours of checking interface configurations and iptables settings i was forced to conclude that the issue had to be on the network layer (didn't like that at all ...).

What was the problem : I was using tagged vlan's on the network switch (this means in fact that the port was configured as a trunk port and not an access port). This is a normal setup in my lab since i play around with lots of virtualised environments that use virtual switches and hence use vlan tagging to seggregate the traffic. So after changing the port to access mode all worked correctly.

Maybe somebody can benefit from the answer provided.

Link to comment
Share on other sites

  • 4 weeks later...

This is the same issue I'm having, except we don't have VLANs here. I've got my turtle working properly with DHCP no problem so I know our config should work. Not sure what I'm missing here. Wanted to use it as a drop and deploy box with the ethernet DHCP connection, and then autossh so I could remotely play with wifi in a clients office.

Link to comment
Share on other sites

This sounds like the reverse problem from what I'm seeing, in that my eth0 works fine in wired client mode through a machine with Internet Connection Sharing. However wlan0 doesn't seem to work when in wireless client mode; it gets an IP within WPA2 sessions on two different models of router, but can't ping the Internet, and wlan0 connected guests can't ping or get to anything on the Internet.

Seems weird that folks on this thread are seeing the exact opposite configs working (and not working) from mine. Maybe there's some kind of conflict between the two client modes...

I will try to factory reset and start with a wireless client mode. If that works for me, I might bet a small amount that my wired client mode may no longer work. Has anyone tried and succeeded in having both modes work in recent releases without having to do a factory reset?

My problem was posted by a team member on a separate thread, but I'm replying here because these issues could be related, and nobody has responded to our original post. Sorry if these turn out to be unrelated issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...