Jump to content

Using the function key in a key sequence


scastle
 Share

Go to solution Solved by scastle,

Recommended Posts

I would like to open the command entry dialog inside of linux (ubuntu). The keyboard short cut on my computer is ALT FN F2. I have not been able to figure out how to input this in the ducky script so that it actually opens the command entry dialog. Any help would be greatly appreciated.

Thanks in advance.

Link to comment
Share on other sites

Ubuntu probably isn't actually reading the FN key, just the key codes for ALT and F2. Holding FN is an implementation detail of your keyboard to allow it to send the F2 key code instead of whatever keycode it normally sends for that key.

You can check which key codes are actually being received by the system with the 'xev' utility.

Link to comment
Share on other sites

Thanks for the reply when running xev is shows that the keys hit are ALT_L and F2. I also ran evtest and it showed that LEFTALT and F2 were pressed. Both of these get an error when trying to creat the .bin file using duckencoder and ALT F2 doesn't bring up the command entry dialog box. I do believe is a matter of figuring out which key combination brings up the command entry dialog box and will also make it through the duckencoder. I guess my next step is to better understand the duckencoder. I guess it would not be fun if it were too easy.

Link to comment
Share on other sites

When you plug in your ducky it becomes like a normal external keyboard. This is why ducky doesn't need a FN key. Key presses are all registered in software by the OS and not the hardware of your laptop. :)

Try CONTROL ALT t

NVM that is for terminal

Edit: Maybe it is a Timing issue? Have you tried setting a delay at the beginning of the file?

Edited by Polisher
Link to comment
Share on other sites

  • Solution

I appreciate the suggestions, they led me down the path to the solution. In order to pull up the command entry dialog box I had to use the WINDOWS command in Ducky Script. This would have been obvious if I had read the descriptions more carefully.

The working command was:

WINDOWS a

Thanks again for the help in pointing me in the correct direction.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...