Jump to content

Unable to flash the Rubber Ducky


steps
 Share

Recommended Posts

Hi everybody!

I was reviving three Rubber Duckies today - well, I tried.

A while back, I flashed my personal Rubber Ducky to be both an HID and a USB mass storage device. This worked fine at the time and is still performing great.

But today I tried to flash two company-owned Rubber Duckies - and failed horribly.

I pressed the tiny button on the Rubber Ducky while plugging it in.

Here's what I tried so far:

1. Dump the working Rubber Ducky's firmware and flash it to one of the other Duckies:

sudo dfu-programmer at32uc3b1256 dump > working-rubber-ducky.hex
sudo dfu-programmer at32uc3b1256 reset
sudo dfu-programmer at32uc3b1256 erase
sudo dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem working-rubber-ducky.hex

This was followed by this error message:

Error parsing the line.
Something went wrong with creating the memory image.

2. Download one of the firmware images from GitHub and try it with them (same commands as in the listing above). I tried several images.

That got me the same error.

I googled the error message and found articles claiming that this error means that the firmware image is corrupted.

Can anyone of you guys please help me figure this out?

What I want to do:

1. Flash all three Duckies with the same firmware

2. Find out what firmware I originally used (the one that creates a "hybrid" ducky)

Any help on the matter is highly appreciated and I thank you guys in advance.

Link to comment
Share on other sites

  • 2 weeks later...

I am having the exact same problem, but I have just received my ducky. You might be correct about firmware being corrupt, especially if you downloaded it with Chrome. I had problems download many tools/files. Try to disable all AV software, also don't forget windows defender. Re-download the firmware with IE and try again. Sometimes Chrome says malicious file and deletes it automatically, although you can recover it if you go into your downloads.

Link to comment
Share on other sites

I was able to flash it on Windows without a single problem. Then I kept getting a java exception trying to encode it on Kali.Used the GUI Encoder once again without a single problem.So @steps if you really need to flash it, just use Windows. If anyone figures out how to flash it on Kali please post the solution, I'm still curious.

Thanks

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...